Problem Change Sound output device

Discussion in 'Community Support' started by skswat, Jul 12, 2018.

  1. skswat

    skswat Well-Known Member

    Joined:
    Jan 4, 2016
    Ratings:
    +69 / 0 / -0
    Is there option how to change sound device output in Raceroom?
    It keeps play sound on default Realtek drivers, but I am using Razer software for sound. It was working OK before.
    Now I am unable to hear any game sound until I switch my sound in windows from Razer to Realtek.
    I dont see any option in game to switch it directly.
     
  2. Christian G

    Christian G Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,354 / 0 / -0
    Are you using the latest Windows 10 version (1803)?
     
  3. m.bohlken

    m.bohlken Well-Known Member

    Joined:
    Jan 29, 2015
    Ratings:
    +986 / 0 / -0
    AFAIK the windows-Version doesn't matter in that case. Raceroom always uses the Windows default Audio-Device. It was like that since I started playing Raceroom 2013 on Win7
    As @skswat mentioned I don't think there is a way to change the Audio-Device ingame...

    At least when I swiched from Speaker to Headset or back, I've changed the default Audio-Device in the windows Audio-Settings and than I had the Sound from Raceroom on my headset or on my speakers.
     
  4. Olijke Poffer

    Olijke Poffer Active Member

    Joined:
    Jul 1, 2018
    Ratings:
    +34 / 0 / -0
    Yes there is an option where you can choose which output you want to use.

    Edit: Sorry, I was wrong. I thought it was RaceRoom but apparently it is in an other game..
     
    Last edited: Jul 13, 2018
  5. m.bohlken

    m.bohlken Well-Known Member

    Joined:
    Jan 29, 2015
    Ratings:
    +986 / 0 / -0
    hm, seems I have never found it... do you know where it is?
     
  6. Olijke Poffer

    Olijke Poffer Active Member

    Joined:
    Jul 1, 2018
    Ratings:
    +34 / 0 / -0
    See my post, I edited it.. I was wrong.
     
    • Useful Useful x 1
  7. Christian G

    Christian G Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,354 / 0 / -0
    So little faith in my reasoning... :p

    It does matter in this case, because with the April Update (1803) Windows introduced a nifty little option that allows users to define audio output devices per application, called 'App volume and device preferences'.

    So if you're on Win10 1803, go to settings -> system -> sound, and click on App volume and device preferences.
    GIPfJ.png
    On the next page you'll be able to define the audio output device for running applications.
    QcQvp.png
     
    • Informative Informative x 3
    • Like Like x 2
    • Winner Winner x 1
  8. m.bohlken

    m.bohlken Well-Known Member

    Joined:
    Jan 29, 2015
    Ratings:
    +986 / 0 / -0
    hehe, thanks guys.. really have missed that new option... Since I'm using the Oculus rift, my Audio-Headset is collecting dust and don't switch between devices...
    But now as I know about it, it could be very usefull when using it as Media-PC...
     
    • Like Like x 1
  9. skswat

    skswat Well-Known Member

    Joined:
    Jan 4, 2016
    Ratings:
    +69 / 0 / -0
    Yes, I am on newest Win10 update and this fixed my issue.
    RaceRoom was actually set to 0 volume in that App volume and device preferences. I have absolutely no idea why. Because in default windows settings it was on 100 and I was never in that APP volume settings before. :confused:

    Thanks for solution. Now everything works like before ;);)
     
    • Wonderful Wonderful x 1