Bug DTM 2016 UI Bug Report

Discussion in 'Community Support' started by Yevgeny Lazorenko, Sep 9, 2019.

  1. Yevgeny Lazorenko

    Yevgeny Lazorenko Well-Known Member

    Joined:
    Mar 29, 2015
    Ratings:
    +755 / 0
    Hello, Dear Sector3!


    Reporting following bug with UI of the DTM 2016 (probably all modern DTM cars affected with this) in the section of Brake Bias of the car. Please, also check other Modern DTM years, it probably affected them either starting from 2013. I have checked only DTM 2016: Audi, BMW and Merc. All of them having the same problems.

    Previously I was reporting about similar issues with other classes and in another sections, but the issue the same. Looks like interface has some bugs.

    It happens when you clicking on arrows icons. Sometimes the value changes sometimes don’t and this is confusing and very-very annoying.

    I am providing the URL for the video where you can clearly notice this bug.




    Video recorded in Single Mode, so Internet delays are impossible. It happens everywhere.


    Best regards, Yevgeny.
     
  2. RacerMark

    RacerMark Member

    Joined:
    Jul 20, 2016
    Ratings:
    +6 / 0
    I didn't notice this until seeing your post, (currently in mp in dtm16 bmw), just checked and i can confirm same bug at least in dtm16. It will be annoying now that i know ;):D
     
    • Funny Funny x 1
  3. Nico Kunze

    Nico Kunze Well-Known Member

    Joined:
    Sep 1, 2018
    Ratings:
    +94 / 0
    Think this is just an inconsistency in rounding numbers. In most cars (all that i checked anyways) you can only change the brake bias in 1% steps so this issue doesnt occur there. In the modern dtm cars you have 0.5% steps tho and each click does actually change the brake balance by 0.5%. With the setup page only showing whole numbers it is to be expected that the number you see wont change with every click tho. The only issue is that there doesnt seem to be a clear rule whether 55.5% is displayed as 55% or as 56%.
    But you can still always set the exact brake bias you want when starting from the default setup (or knowing the exact brake bias of your custom setup) by simply counting your clicks
     
  4. Andi Goodwin

    Andi Goodwin Moderator Beta tester

    Joined:
    Jan 16, 2015
    Ratings:
    +437 / 0
    in bug tracker

    Andi
     
  5. Alex Hodgkinson

    Alex Hodgkinson Sector3 Developer

    Joined:
    Jun 5, 2017
    Ratings:
    +1,171 / 0
    We fixed this today :cool:
     
    • Like Like x 1
    • Love it! Love it! x 1
  6. Yevgeny Lazorenko

    Yevgeny Lazorenko Well-Known Member

    Joined:
    Mar 29, 2015
    Ratings:
    +755 / 0
    Nope, mate, sometimes you have to do 2 clicks to change and sometimes 1, doesn't make any sense.
    It's simply UI bug, that already fixed, hopefully, according to the last message from Alex.
    I have seen same issues with other parameters on diffferent cars. What been fixed already there either.
     
    Last edited: Sep 11, 2019
  7. Nico Kunze

    Nico Kunze Well-Known Member

    Joined:
    Sep 1, 2018
    Ratings:
    +94 / 0
    Each click does actually change the brake balance. When you start at say 55% and click eight times and then go on track, your brake balance will be 59% regardless of what number you see on the setup page.
    But as long as its fixed it doesnt really matter what went wrong previously :D
     
  8. Yevgeny Lazorenko

    Yevgeny Lazorenko Well-Known Member

    Joined:
    Mar 29, 2015
    Ratings:
    +755 / 0
    Anyway, if it does really change value for 0.5%, I would like to see it in the setup menu, otherwise, it does a lof of confusion...
    But I got your point! Thanks for attention to this!
     
    • Like Like x 1