Resolved Error 503

Discussion in 'Community Support' started by GregoryLeo, Oct 22, 2015.

  1. GregoryLeo

    GregoryLeo Well-Known Member

    Joined:
    Feb 22, 2015
    Ratings:
    +313 / 0 / -0
    This happens a lot when I try to log into the game.
    It fails to log in thru steam and asks for my registration info. Then gives me the error 503 portal services unavailable message, or goes to the open screen and never changes. I've sat for 10 minutes waiting for some thing to happen before I kill the game. It usually happens at night here in Hawaii. Which is 11 to 12 hours behind Europe. Rarely happens in the morning. Consequently. I've spent more time in race 07 and GTR2 than in this game lately.
     
    • Agree Agree x 3
    • Like Like x 1
    Last edited: Oct 22, 2015
  2. Z_i_g

    Z_i_g Member

    Joined:
    Sep 15, 2015
    Ratings:
    +8 / 0 / -0
    I had the same problem for the longest time. Sometime I'd log right in, but a lot of 503 's . In my case it was my router linksys Wrt54g v3 . if I plug my computer straight to the modem I had no problems. Since my router was 10 years old I recently purchased a new linksys. Cleared up my 503's . Rebooting the old router help out . But I had a lot of game closing and couldn't get in to servers online. Good luck with your issues. Did you submit a ticket? help desk may have information that helps .
     
    • Like Like x 1
    • Useful Useful x 1
  3. mr_belowski

    mr_belowski Well-Known Member Beta tester

    Joined:
    Apr 23, 2015
    Ratings:
    +1,297 / 0 / -0
    503s for me too at the moment :unamused:
     
    • Like Like x 1
    • Agree Agree x 1
  4. Hannes Wallstedt

    Hannes Wallstedt Well-Known Member

    Joined:
    Jan 15, 2015
    Ratings:
    +278 / 0 / -0
    503's are a bit tricky since they just mean that the connection timed out. A lot of things that can cause that issue unfortunately.

    The portal has been a little bit unstable around the patch, so there's some chance that at least some of these connection time outs are caused by that.

    But like Z_i_g points out one of the things that might be causing the trouble is the router, so if it is possible for you to do so please try connecting your PC directly to your modem/outlet to see if that solves the issue. Other possible culprits can be your Anti-virus or Firewall, and in some cases even your ISP (I believe these were German ISPs though). Just take a look and make sure that RaceRoom Racing Experience hasn't been added to any watchlists or similar features that might impede the communication to the servers.
     
    • Winner Winner x 1
    • Useful Useful x 1
  5. mr_belowski

    mr_belowski Well-Known Member Beta tester

    Joined:
    Apr 23, 2015
    Ratings:
    +1,297 / 0 / -0
    so are you using the 503 "internal server error" code for something other than an internal server error?

    Edit... ahh, it's a "service unavailble" not "internal server error", sorry :)
     
  6. Sean Lander

    Sean Lander Well-Known Member

    Joined:
    Feb 10, 2015
    Ratings:
    +65 / 0 / -0
    Was fine yesterday but today I can't connect as I keep getting this error.
     
  7. Dave R

    Dave R Well-Known Member

    Joined:
    Apr 19, 2015
    Ratings:
    +539 / 0 / -0
    I'm having loads of trouble now as well getting in.
     
  8. kendoslow

    kendoslow Active Member

    Joined:
    Apr 22, 2015
    Ratings:
    +44 / 0 / -0
    I've done all that and am on a direct connection but still having issues. Could raceroom be doing something?
     
  9. Erwan960

    Erwan960 Active Member

    Joined:
    Jan 30, 2015
    Ratings:
    +30 / 0 / -0
    503s for me too, yesterday evening, this morning and this afternoon.
    After 5 or 6 clicks on "return to the game", it finally worked but it was very slow...
     
    • Like Like x 1
    • Creative Creative x 1
  10. kendoslow

    kendoslow Active Member

    Joined:
    Apr 22, 2015
    Ratings:
    +44 / 0 / -0
    Bit like me on track then.;)
     
    • Funny Funny x 1
  11. AzkarateAsi

    AzkarateAsi Well-Known Member

    Joined:
    Apr 18, 2015
    Ratings:
    +72 / 0 / -0
  12. Hannes Wallstedt

    Hannes Wallstedt Well-Known Member

    Joined:
    Jan 15, 2015
    Ratings:
    +278 / 0 / -0
    Yes, the issue can be on our end as well and we know the portal has been unstable since the update. But it is good to eliminate possibilities. We're looking into it.
     
    • Like Like x 1
    • Creative Creative x 1
  13. kendoslow

    kendoslow Active Member

    Joined:
    Apr 22, 2015
    Ratings:
    +44 / 0 / -0
    It just worked flawlessly for me in the last 5 minutes.
     
  14. jayblue

    jayblue Active Member

    Joined:
    Jun 22, 2015
    Ratings:
    +38 / 0 / -0
    Getting fed up of various log in errors at game start up now. Current one is error 2104. Pretty depressing when you can't get on to play.
     
    • Agree Agree x 1
  15. Erwan960

    Erwan960 Active Member

    Joined:
    Jan 30, 2015
    Ratings:
    +30 / 0 / -0
    Everything seems fine now and the navigation in the menu is as quick as possible ! :)
     
  16. Gopher04

    Gopher04 Well-Known Member

    Joined:
    Mar 6, 2015
    Ratings:
    +225 / 0 / -0
    Started getting the 503 error again, followed by the white screen of death, meaning no menu just the animated background.
     
  17. Hannes Wallstedt

    Hannes Wallstedt Well-Known Member

    Joined:
    Jan 15, 2015
    Ratings:
    +278 / 0 / -0
    If you're not seeing any menu buttons that most likely means you're having an issue with hardware acceleration in the menus.
    To work-around this:
    • Right Click on the game in the steam library.
    • Click "properties."
    • Click "SET LAUNCH OPTIONS..."
    • Enter -cefNoGPU in the text field.
    • Click Ok.
    • Start the game.
     
    • Useful Useful x 1
  18. m.bohlken

    m.bohlken Well-Known Member

    Joined:
    Jan 29, 2015
    Ratings:
    +984 / 0 / -0
    Hm, I had something smilar (just the white animated background) in combination with the 503 error.
    When the 503-Error-Message came up, I could choose between to buttons - Continue or Back to Desktop. As I choose Continue I got that Background without any buttons.
    Without the 503-Error everything is fine in the Game. Maybe the Continue-Button is misleading?
     
  19. Frenchfly

    Frenchfly New Member

    Joined:
    Oct 7, 2015
    Ratings:
    +0 / 0 / -0
    Ok I've been getting the 503 error for the last 2 weeks without being able to log into the game at all. I finally fixed it today by uninstalling the game completely including deleting any associated folders and running a registry cleaner, restarting my pc and re-installing. Not the ideal solution but it may help others. Note that I did try re-installing previously without deleting folders and still had the 503.
     
  20. GregoryLeo

    GregoryLeo Well-Known Member

    Joined:
    Feb 22, 2015
    Ratings:
    +313 / 0 / -0
    Wow, glad I'm not the only one with this problem. (Sort of:p) Anyway this is the first time I've had time to respond. For my part, some of the problem could be definitely be on my end. Our internet is known for cutting out. But it's nice to hear that s3e is on top of things as well. Also think the only real option is to drop out of the game and try again when it happens. Question to Frenchfly. Do you play in single player with adaptive AI? And if so, when you did a complete re-install what happened with them? did you loose all that data as well? I've spent a lot of time getting them dialed in and would hate to have to start over. :confused: