Problem FPS problems after Windows 10 update

Discussion in 'Community Support' started by Erico Stefanni, Aug 4, 2016.

  1. Andi Goodwin

    Andi Goodwin Moderator Beta tester

    Joined:
    Jan 16, 2015
    Ratings:
    +559 / 0 / -0
    if you hunt around you will find that a lot of people are experiencing this problem with certain dx9 games in windows 10 ; one of the latest updates broke some of dx9 ;
    there are articles on toms hardware etc ...

    Andi
     
    • Informative Informative x 1
  2. fl0wf1r3

    fl0wf1r3 Well-Known Member

    Joined:
    Apr 24, 2016
    Ratings:
    +224 / 0 / -0
    nice way to force people to jump on a higher dx version. OK, there are a lot of articles in the internet about the issues with w10 and dx9. Know I know where it comes from. It probably has nothing really to do with Raceroom, its more a Microsoft issue and dx9 support in w10. I will try to install dx 9.29 (June 2010) - hello, 6 years old :(
     
    Last edited: Sep 28, 2016
  3. Andi Goodwin

    Andi Goodwin Moderator Beta tester

    Joined:
    Jan 16, 2015
    Ratings:
    +559 / 0 / -0
    i have avoided win 10 on my rig as win 10 isnt about anything new really more about having greater control over the harvesting of your info , once you disable everything that does this you have the same functionality as win 7 ; but unlike win 7 half the drivers are fubar , and your dragged into updating stuff to something thats more broken ....

    So i will wait until windows fix it ... somewhere around windows 10 update 99

    Andi
     
    • Winner Winner x 3
    • Agree Agree x 1
    • Funny Funny x 1
  4. Christoph

    Christoph Well-Known Member

    Joined:
    Sep 26, 2016
    Ratings:
    +83 / 0 / -0
    hi andi,
    thank you for your feedback and the informations.
    have I understood that correctly you will recommend to wait until a new update of win 10 and change anything previously ?
    and not driving race room until this date?

    Christoph
     
  5. m.bohlken

    m.bohlken Well-Known Member

    Joined:
    Jan 29, 2015
    Ratings:
    +984 / 0 / -0
    I guess he meant, that he recommend to wait with an installation of win10 and use win7 instead.
     
  6. Christoph

    Christoph Well-Known Member

    Joined:
    Sep 26, 2016
    Ratings:
    +83 / 0 / -0
    ok this is another situation, which system you use for R3E win 7 ?
    it is better for R3S going back to windows 7?
     
  7. m.bohlken

    m.bohlken Well-Known Member

    Joined:
    Jan 29, 2015
    Ratings:
    +984 / 0 / -0
    thats a quite difficult topic. For my system I had some benefits on performance-side after switching from Win 7 x64 to Win10 x64. Others had some problems with it. But yeah - I notice a lack of performance after the last "Anniversary-Update" from Win 10, too.

    IMO you should have a deeper look in your driver and system-settings first. I notice some resets of Driver-Settings. Especially my graphics settings were set to default, which causes a loss of performance. Some other users reported other drivers as well that were resetted and had some processes running/tools in the background. So might be worth checking.
     
  8. Christoph

    Christoph Well-Known Member

    Joined:
    Sep 26, 2016
    Ratings:
    +83 / 0 / -0
    what do you recommend me to do? the driver I'll check tonight.
    I have other options ? I am confused and do not know how I can use again R3E with my quick good performance.

    @fl0wf1r3,
    is your system running fast and good again as before?
     
  9. fl0wf1r3

    fl0wf1r3 Well-Known Member

    Joined:
    Apr 24, 2016
    Ratings:
    +224 / 0 / -0
    Yes and no. It is really annoying at the moment. Yesterday I had done practice labs on the Nordschleife, no problems. After one hour, I decided to start the crew chief. I accidentally turn on the rear view mirror and suddenly Raceroom was not smooth any longer. I restarted the game, turned off crew chief, turn off the position bar at the top, switched between the cameras, no chance, the stuttering effect remains. I didn't not change anything in the video settings. I just restarted the lab. It really s.... I have no idea what causes this effect :(
     
  10. Sonat Ozturk

    Sonat Ozturk Well-Known Member

    Joined:
    Jan 13, 2015
    Ratings:
    +2,009 / 0 / -0
    Can someone who is still having this issue send me a video (perhaps upload it to youtube)?

    Can you also use a performance monitor such as MSI Afterburner and look out for dips and spikes in framerate and cpu usage when the stuttering occurs.

    If someone solved the problem for good can you share your solution with us? (Apart from reverting the update or going back to Win7)
     
  11. Subway

    Subway New Member

    Joined:
    Apr 2, 2016
    Ratings:
    +0 / 0 / -0
    its strange the game is stuttering an bad performance since the annivisary update but when i use the EVGA Precision Tool with On Screen Display enabled the game run perfect without stuttering
     
  12. Christoph

    Christoph Well-Known Member

    Joined:
    Sep 26, 2016
    Ratings:
    +83 / 0 / -0
    After the last update yesterday ( Win 10 64 bit ) R3E is replayable but not as good as before
    that's for sure.
     
    Last edited: Oct 1, 2016
  13. S-AMG

    S-AMG Well-Known Member

    Joined:
    Jan 29, 2015
    Ratings:
    +77 / 0 / -0
    The similar , it was nacessary that I push options in the control panel N'vidia so that it is similar that before , and still times this lag :(
     
  14. Tarik Userli

    Tarik Userli Well-Known Member

    Joined:
    Mar 7, 2015
    Ratings:
    +578 / 0 / -0
    Try to enable in the NVIDIA cp the NVIDIA vsync vsfast and disable it ingame.

     
  15. S-AMG

    S-AMG Well-Known Member

    Joined:
    Jan 29, 2015
    Ratings:
    +77 / 0 / -0
    ok thanks Tarik
     
  16. fl0wf1r3

    fl0wf1r3 Well-Known Member

    Joined:
    Apr 24, 2016
    Ratings:
    +224 / 0 / -0
    great, I had v-sync set to "adaptive" (Nvidia CP) when the game was running smooth I think. Then I updated the driver and have forgotten about that setting since I was trying so many things and nothing really helped. I even re-installed DirectX 9 from the Microsoft side and it didn't help either. I tried the compatibility mode in windows 10, didn't work at all. In the meantime I installed iRacing (not so convinced btw ;) but I do like the information (delta bar) one gets on the screen in iracing, lap times etc) and iRacing updated DirectX as well. I will turn off v-sync in game and test the options in the Nvidia Control Panel, sounds interesting indeed
     
    Last edited: Oct 2, 2016
  17. Christoph

    Christoph Well-Known Member

    Joined:
    Sep 26, 2016
    Ratings:
    +83 / 0 / -0
    @Tarik Userli
    many thanks it helped me my R3E is running now well.
    but in game i must use VSync on ( An ) without this it was not working nice and not playable.

    @all,
    a question I have to the experts here. what is better Multisampling 2 x AA or 8 x AA?
    and which thereby changes the game
     
    • Like Like x 1
    • Informative Informative x 1
    Last edited: Oct 2, 2016
  18. Sonat Ozturk

    Sonat Ozturk Well-Known Member

    Joined:
    Jan 13, 2015
    Ratings:
    +2,009 / 0 / -0
    Can you guys confirm that changing Vsync in Nvidia Control Panel from "Use the 3D application setting" to "Fast" solves the problem? Might be something else than "Fast" but one of our testers who was having the issue solved it this way. We just need more to confirm.
     
  19. okehr

    okehr New Member

    Joined:
    Sep 8, 2016
    Ratings:
    +0 / 0 / -0
    Yes, it works for me (Vsync in Nvidia Control Panel at fast & Vsync on in game).
    Thank you very much Tarik.
     
  20. fl0wf1r3

    fl0wf1r3 Well-Known Member

    Joined:
    Apr 24, 2016
    Ratings:
    +224 / 0 / -0
    as soon as I have time I will check it, for sure :)