Problem Frozen display (but game still running)

Discussion in 'Community Support' started by haik, Apr 3, 2016.

  1. haik

    haik Well-Known Member

    Joined:
    Feb 13, 2015
    Ratings:
    +46 / 0 / -0
    Issue:
    After a random amount of time (sometimes as soon as 5 minutes, sometimes after 20 or so minutes), the display is freezing (no artefacts or anything, just a still image).
    I can hear the game running, ie my car crashing (because, driving blind ain't easy :eek:), or I can Rev (so controls are responsive), if I hit Esc the game mouse cursor appears (but not the menu, still the same still image).
    My only course of action is to kill the process, either with Alt-F4 or by bringing the Task Manager up on my 2d screen (extended desktop, that one is fine and responsive even during the freeze)

    Sometimes, if I'm really "lucky", the freeze only last 3 to 5 seconds, but 9 times out of 10, it is a permanent freeze.

    It is NOT track-dependent: it happened at the Nordschleife, or at Sonoma. Neither it is "track-location" dependent, it happens at any given point in the track.

    It seems it MAY be IA-dependent: after 3 days, I still have to finish a Race Week-End since the display has always crashed at one point.
    It happens whether I set-up a big grid or not: it has happens with as low as 10 cars on track, and as high a 50 or 99 cars.
    It can happen during practice, qualifying or race.
    But it happens every time at one point if I try to run a full race WE.

    I didn't test that much driving solo - a quick test at Sonoma with only my car on the track did not bring the issue up, but I only ran for 10 or 15 minutes.

    Otherwise, the game is running at a smooth 60fps, safe for a few dips below that here and there.

    And this issue only happens with R3E, I do not have any issue with any other games.


    My setup:
    Intel core i5-3570 / GTX660 (latest drivers)
    The game is running single-screen, but I have the main display mirrored to my TV and a secondary screen as extended desktop
    Logitech G27 (latest drivers)

    Included is what I think are the latest logs after the latest occurrence - I don't think the game generates crash logs, since it doesn't crashes and I have to manually kill it.
     

    Attached Files:

  2. SniperFire69

    SniperFire69 New Member

    Joined:
    Jun 14, 2015
    Ratings:
    +1 / 0 / -0
    Interesting I just posted this
    Can you tell me if you can drive fine in just a practice session? edit: just read where it does, we did not test with long stints just a few minutes in practice.
    my mates only froze during a race for us but his froze everytime within 30 seconds

    Hi guys, I have the weirdest issue on a friends new pc we just built.
    brand new PC
    core i7 6700k
    16gig ram
    windows 10 64bit .
    AMS is perfect. Assetto is perfect.
    Raceroom every single time he goes into a race he gets in about 10-15 secs into the race and game completely freezes and a machine reboot is only way to get back in. We can practice with the AI, we can Qualify but as soon as race starts the machine freezes, It gets even stranger as we went onto a multi server and we ran around for quite a few minutes without an issue, tried a single player race straight after and bang lockup in first corner, tried different tracks and cars all with the same result.
    We also deleted game and reinstalled with the same result.
    I give up!
     
    Last edited: Apr 5, 2016
  3. haik

    haik Well-Known Member

    Joined:
    Feb 13, 2015
    Ratings:
    +46 / 0 / -0
    @Sniper: yeah, I don't not know if it's related - my game did not crash, only the display.

    Either way:
    Good news, I think I've found a solution :)
    I switched Fullscreen to Off.

    Further testing are needed, but I've been able to run a full race WE (20 AI), 45min practice, 30min Quali' and 45min Race, without a hitch.

    I suspect something foul between Win10, nVidia drivers, my setup( my GPU and the way my screens are layout) and the game - not the first time I have some issues with fullscreen applications since I've upgraded to Win10...
     
  4. Melluish

    Melluish New Member

    Joined:
    Apr 7, 2016
    Ratings:
    +0 / 0 / -0
    This is also happening to me. I'm on a single screen and the game will freeze after about 2mins, but I can still hear the game running.

    i7 3770
    8GB RAM
    GTX 680
    Windows 10
     
    Last edited: Apr 8, 2016
  5. Melluish

    Melluish New Member

    Joined:
    Apr 7, 2016
    Ratings:
    +0 / 0 / -0
    When you say fullscreen off did that mean you are running in windowed mode?
     
  6. haik

    haik Well-Known Member

    Joined:
    Feb 13, 2015
    Ratings:
    +46 / 0 / -0
    I just turned Fullscreen off in the Graphic option.
    I guess the game is effectively running in "borderless" windowed mode.
     
  7. Melluish

    Melluish New Member

    Joined:
    Apr 7, 2016
    Ratings:
    +0 / 0 / -0
    Ahh, I see now. I've just tried this myself. I got 1 lap in a thought it had solved it and them boom, frozen again. The interesting this is though in windowed mode it said that my Nvidia driver had stopped functioning, so maybe it's driver related?
     
  8. haik

    haik Well-Known Member

    Joined:
    Feb 13, 2015
    Ratings:
    +46 / 0 / -0
    Oh, I never had a message error from the drivers.
    I guess in your case, yeah, that looks like a driver issue - I'm afraid I don't know that much about it tho.

    Make sure you are on the latest drivers - and if that is the case, try to "rollback" to an older driver?
     
  9. SniperFire69

    SniperFire69 New Member

    Joined:
    Jun 14, 2015
    Ratings:
    +1 / 0 / -0
    Which driver are you guys using? Very latest?
     
  10. haik

    haik Well-Known Member

    Joined:
    Feb 13, 2015
    Ratings:
    +46 / 0 / -0
    Yes, very latest (364.72 released 28 March 2016)
     
  11. Melluish

    Melluish New Member

    Joined:
    Apr 7, 2016
    Ratings:
    +0 / 0 / -0
    Yep, same. Latest version. I can't see an option in Geforce Experience to roll back and there were no beta drivers available, so I guess I'll have to just wait. It's a bit of a ball-ache but I could try removing the Nvidia drivers and then rebooting to see if the ones Windows 10 installs automatically are slightly older. It'll have to be after work tomorrow though, I'm going to bed :)
     
  12. haik

    haik Well-Known Member

    Joined:
    Feb 13, 2015
    Ratings:
    +46 / 0 / -0
    Yeah, there is no option to automatically roll back to an older driver - like you said, you have to manually remove your current one then install the older one (they are still provided by nvidia on their website)
    Bear in mind, that was just a suggestion, I have absolutely no idea if it might help or not
     
  13. SniperFire69

    SniperFire69 New Member

    Joined:
    Jun 14, 2015
    Ratings:
    +1 / 0 / -0
    Last edited: Apr 8, 2016
  14. Sascha Reynders

    Sascha Reynders Well-Known Member

    Joined:
    Feb 18, 2016
    Ratings:
    +102 / 0 / -0
    I don't think it's driver version related, I've been having these kind of system freezes ever since I installed R3E on a new Windows 10 PC a couple of months ago, and I've had them with every GeForce driver from version 361.43 up to the latest 364.72.
    In my case, the freezes mostly occur when going from one session to another (practice to qualify, qualify to race) when I hit "End Session" but on occasion it also happens when I'm on track. The game locks up, sound goes on for a while then gets stuck in a loop, alt-tab doesn't work and ctrl-alt-del brings up a completely black screen...only solution is to hit the reset button and re-boot my PC. There are no reported display driver errors and usually there are no game crash dump files, as R3E doesn't report it's crashed.
    Except for yesterday: I was doing a race weekend in the GT3's at Zolder and had three consecutive game freezes: the first when going from practice to qualify with "End Session", the second at the start of the race when I hit "Escape" and then "Restart" and the third right after crossing the finish line. I didn't get any messages saying R3E crashed, but there were three crash dump files nevertheless. I'll attach them here in case any of the devs would come across this thread.

    I used to think this was caused by an unstable overclock on my GTX 970 (+150 core clock/+250 memory clock),but it happens at default clock settings as well. And it's definitely not an overheating issue either, the GPU has never gone above 56° C and the CPU never above 42° C (even though that's also overclocked from 3.5 to 4.7Ghz).
    I have no idea what's causing this but it would be nice if this could be solved in any way. It doesn't stop me from playing R3E but it sure is annoying :(

    Anyway, here are the crash dump files:
     

    Attached Files:

  15. SniperFire69

    SniperFire69 New Member

    Joined:
    Jun 14, 2015
    Ratings:
    +1 / 0 / -0
    This is exactly what is happening to my friends PC
     
  16. Sascha Reynders

    Sascha Reynders Well-Known Member

    Joined:
    Feb 18, 2016
    Ratings:
    +102 / 0 / -0
    And is he using an Nvidia GPU as well ? If so, it looks like the common factor for all of us having this issue is Windows 10 + Nvidia GPU. Maybe @Hannes Wallstedt or another S3 dev could take a look at the crash dump files I posted above ? It would be much appreciated.
     
  17. SniperFire69

    SniperFire69 New Member

    Joined:
    Jun 14, 2015
    Ratings:
    +1 / 0 / -0
    yup
    gtx980
    core i7 6700k
    16gig ram
    windows 10 64bit
     
  18. Melluish

    Melluish New Member

    Joined:
    Apr 7, 2016
    Ratings:
    +0 / 0 / -0
    Don't know what happened, but I was able to play R3E for hours this evening and it didn't freeze once?
     
  19. Sascha Reynders

    Sascha Reynders Well-Known Member

    Joined:
    Feb 18, 2016
    Ratings:
    +102 / 0 / -0
    Two new crashes today, GT3 at Monza. This time the switch from practice to qualy and qualy to race went flawless but my system froze a first time after restarting the race. The second crash happened after my car broke down, I was sent back to the menu and I hit "Continue to results". The first crash happened with my GPU at stock clock speeds, the second time it was running overclocked, so I guess I can at least rule out my GPU overclock as cause of the problem...

    I love R3E but it must be the single most unstable sim I ever played... :(
     

    Attached Files:

  20. Sascha Reynders

    Sascha Reynders Well-Known Member

    Joined:
    Feb 18, 2016
    Ratings:
    +102 / 0 / -0
    Just curious: was this during race sessions ? 'Cos it seems I can run practice sessions on my own or leaderboard challenges for hours on end without any issues, but from the moment I start running races, bam ! System freezes at one point or another...