Problem G27 900 Degrees

Discussion in 'Community Support' started by FormelLMS, May 11, 2015.

  1. FormelLMS

    FormelLMS Well-Known Member

    Joined:
    Apr 8, 2015
    Ratings:
    +151 / 0 / -0
    Hi there,

    I really try to make it happen, that I can use my G27 wheel with 900 degrees. But it seems strange to me.

    What I did:

    Open the Profiler, make a new R3E profile with 900 degrees (but its also standard with 900 degrees)
    Than in the settings after starting R3E, I choose 900 degrees, too.
    Than starting a Practice, get out of it, going into car setup, choosing again 900 degrees et voila... everything is messed up. I can push my wheel 90 degrees and you can see the steering wheel in the game is going half way round. So its not synchronized. And second, in the game I have to push the wheel a little bit and the car makes a big turn. This couldn't be normal.

    Looks to me, that in game the wheel is steering 450 degree or so.

    Hope that someone knows, what I mean and coul please help me.

    Is 900 degree best for R3E? On Pcars it works well ith 900 degrees.

    Thank you!!!!
     
  2. FormelLMS

    FormelLMS Well-Known Member

    Joined:
    Apr 8, 2015
    Ratings:
    +151 / 0 / -0
    What I can see is, when I change the ingame settings in the screen, where we can change the wheel to wheel with driver arms (unchecked the driver arms) to 625 degrees, it looks okay. But on Profiler it's set to 900 degrees.
    So why 625? Is my wheel not okay? (but on other games I can calibrate the wheel to 868 degrees)
    Or I have to calibrate the wheel ingame? (where?)
     
  3. m.bohlken

    m.bohlken Well-Known Member

    Joined:
    Jan 29, 2015
    Ratings:
    +972 / 0 / -0
    I believe that everything is fine with your wheel. I'm not sure if the Option for Driver-Arms is just limited to 625° - haven't tried it that high as I prefer Driving with 540°.

    You don't need to calibrate the wheel in R3E (as there is no option for it). But you can check, if it rotates 900° in the Wheel-Settings.
     
  4. FormelLMS

    FormelLMS Well-Known Member

    Joined:
    Apr 8, 2015
    Ratings:
    +151 / 0 / -0
    Thanks for your answer!
    Driver arms are off, but with more than 625 degrees it isn't synchron with my G27.

    Can you please tell my, how I can check the wheel in wheel settings? I can't find an option.
     
  5. D.Boon

    D.Boon Well-Known Member

    Joined:
    Feb 19, 2015
    Ratings:
    +385 / 0 / -0
    Hello @FormelLMS,
    Not sure it will solve your problems but you can try the settings in THIS thread. I use a G27 with no issues at all.
    There are plenty (probably too many) threads discussing similar issues, remember, the forums search bar is your friend ;)
     
  6. FormelLMS

    FormelLMS Well-Known Member

    Joined:
    Apr 8, 2015
    Ratings:
    +151 / 0 / -0
    Hi!

    No, I can't find any information about my issue here. Thats why I've asked.
    Your linked thread doesn't help me either.
     
  7. D.Boon

    D.Boon Well-Known Member

    Joined:
    Feb 19, 2015
    Ratings:
    +385 / 0 / -0
    Do you mean your getting 900 degree rotation from your G27 but the in-game wheel is turning less, or is it that your getting 900 degree in-game but not on the G27?
    Sorry, trying to understand your problem before I see if I can offer a solution :)
     
  8. FormelLMS

    FormelLMS Well-Known Member

    Joined:
    Apr 8, 2015
    Ratings:
    +151 / 0 / -0
    Hi.
    No. Look, I can set my wheel in Logitech Profiler to 900 degrees. Now starting R3E, go to the settings, where you can set the graphics to driver / arms / wheel only.
    I've set it to wheel only and 900 degrees.
    Now starting a Race and the wheel on the display isn't synchronous with my logitech wheel.
    When I hold my logitech at 90 degrees, the wheel on my monitor is at about 180 degrees.
     
  9. D.Boon

    D.Boon Well-Known Member

    Joined:
    Feb 19, 2015
    Ratings:
    +385 / 0 / -0
    Ah, OK, have you tried going in to the car settings (while your in the garage before a race/practice), you'll see an option for steering settings, you may have to set that for 900 degrees too, each car has it's own default steering rotation.
    If you've already tried that, let us know.

    Edit:
    Under the wheel rotation option is another option to do with lock, THIS THREAD should answer any questions about that.
    Hope it helps.
     
    Last edited: May 12, 2015
  10. FormelLMS

    FormelLMS Well-Known Member

    Joined:
    Apr 8, 2015
    Ratings:
    +151 / 0 / -0
    Oh, yes, I've tried that. But it doesn't change anything.
    The problem, that it doesn't synchronize optical isn't affected by that it seems.
     
  11. D.Boon

    D.Boon Well-Known Member

    Joined:
    Feb 19, 2015
    Ratings:
    +385 / 0 / -0
    That's odd... I don't usually run my G27 at 900 degrees, I'm on R3E tonight though and will look into this and see if I can replicate your problem, should be about an hour and I'll get back to you with any results.
    If I can replicate and fix it, I'll post all the settings I use for 900 degree. If that doesn't help.... o_O

    Won't be long.
     
  12. FormelLMS

    FormelLMS Well-Known Member

    Joined:
    Apr 8, 2015
    Ratings:
    +151 / 0 / -0
    Sounds great! Thank you! I can wait. :-D
     
  13. D.Boon

    D.Boon Well-Known Member

    Joined:
    Feb 19, 2015
    Ratings:
    +385 / 0 / -0
    OK so I couldn't replicate your issue, everything seems to work fine for me. Just in case, I'll post my full settings anyway.

    Profiler:
    Global settings: (The bit that matters), 900 degree rotation, Allow game to adjust settings (checked/enabled)

    R3E Settings:
    Options/vehicle settings: 900 degree rotation, wheel only.
    Controller/advanced: Steering Sensitivity 50%

    Car Setup:
    Steering Settings: 900 degrees
    40 lock

    Aside from that, I have no idea what's going on.

    If you use a specific game profile in your logitec Profiler, make sure you have "allow game to adjust settings" enabled.

    Hope that solves your problem, sorry I can't be of more help.
    Good luck.
     
    • Like Like x 1
    Last edited: May 12, 2015
  14. FormelLMS

    FormelLMS Well-Known Member

    Joined:
    Apr 8, 2015
    Ratings:
    +151 / 0 / -0
    Hey, thank you for your help, but it seems that it doesn't work here.
    Is it okay, when I make some Screenshots tomorrow?
    Hopefully I'm to dumb or my English isn't good enough, so we can speak through pictures? :-D
     
  15. D.Boon

    D.Boon Well-Known Member

    Joined:
    Feb 19, 2015
    Ratings:
    +385 / 0 / -0
    Yeah, no problem :)
     
  16. FormelLMS

    FormelLMS Well-Known Member

    Joined:
    Apr 8, 2015
    Ratings:
    +151 / 0 / -0
    Wow!!!! That works. It was too late yesterday evening!
    Thanks man!!!!
    Now, which degrees do you use in R3E? You say, you don't use 900 degrees?
     
  17. D.Boon

    D.Boon Well-Known Member

    Joined:
    Feb 19, 2015
    Ratings:
    +385 / 0 / -0
    That's awesome!
    I use 540 degrees with lock set to 23, steering sensitivity is default on 50%.

    My complete settings (profiler and in-game) are HERE (second post down from the top), I don't use any of the 3 new wheel options although @nate has solid settings on the post under mine in that same thread.
     
    • Like Like x 1
  18. FormelLMS

    FormelLMS Well-Known Member

    Joined:
    Apr 8, 2015
    Ratings:
    +151 / 0 / -0
    Thanks so much for your help! I can't believe. My problem was, that steering sensitivity was at 100 percent.
    It was really hard to drive :p
    I'll now have a look at your linked thread.

    Merci!
     
  19. D.Boon

    D.Boon Well-Known Member

    Joined:
    Feb 19, 2015
    Ratings:
    +385 / 0 / -0
    De rien. :)