In-Gameplay Web Overlays

Discussion in 'Community Workshop' started by J-F Chardon, Apr 4, 2019.

  1. OtterNas3

    OtterNas3 Well-Known Member

    Joined:
    Jan 9, 2018
    Ratings:
    +313 / 0 / -0
    @Ela Six
    If you are using this version of the HUD, your kinda out of luck, it is what it is.
    It was only a "Example-HUD"
    I know that in this version there was a "Reset Settings" in case anything got wrong, which also caused the HUD configuration to reset every now and then, for a "unknown" reason.


    I made a Extended version of the HUD, which has a better check if the configuration needs to be resetted or not.
    Has a lot more features also.
    If you wanna have a look:
    https://forum.sector3studios.com/in...custom-webhud-with-additional-features.13152/

    Moo,
    Otter
     
  2. OtterNas3

    OtterNas3 Well-Known Member

    Joined:
    Jan 9, 2018
    Ratings:
    +313 / 0 / -0
    It reads the best lap from the Memory of the Game, so short answer: No
     
  3. Ela Six

    Ela Six New Member

    Joined:
    Apr 2, 2021
    Ratings:
    +0 / 0 / -0
  4. Skidmark

    Skidmark Well-Known Member

    Joined:
    Oct 9, 2015
    Ratings:
    +229 / 0 / -0
    Thanks
     
  5. xMOx

    xMOx New Member

    Joined:
    Jul 3, 2021
    Ratings:
    +0 / 0 / -0
    I cannot get Otterhud working. When I run through Crewchief I get No Data-Feed detected. When I run dash.exe, I get System.NullReferenceException. Any ideas what the problem is? Could it have anything to do with having steam installed on my C: but my steam install directory for games is on D:? Thanks!
    upload_2021-7-3_13-19-56.png upload_2021-7-3_13-21-16.png
     
    Last edited: Jul 3, 2021
  6. Danny Michael

    Danny Michael Member

    Joined:
    Mar 14, 2021
    Ratings:
    +12 / 0 / -0
    Have you enabled R3E WebHud integration in Crew Chief?

    https://forum.sector3studios.com/in...custom-webhud-with-additional-features.13152/
     
  7. xMOx

    xMOx New Member

    Joined:
    Jul 3, 2021
    Ratings:
    +0 / 0 / -0
    Yes. I pasted the launch option in steam also.
     
  8. Danny Michael

    Danny Michael Member

    Joined:
    Mar 14, 2021
    Ratings:
    +12 / 0 / -0
    Got threads mixed up...

    Edit: and you are not running dash.exe AND Crew Chief at same time, right?
     
    Last edited: Jul 4, 2021
  9. Michael L

    Michael L Member

    Joined:
    Jan 26, 2021
    Ratings:
    +8 / 0 / -0
    You didn't forget to click on the "Start" button on crewchief?
     
  10. MarcoP

    MarcoP Active Member

    Joined:
    Aug 3, 2021
    Ratings:
    +26 / 0 / -0
    Hello guys,
    I tried to get the sample web ui running to check if I can implement the tool to calculate changes for camber/pressure.
    For some reason I cannot get the sample files running...
    Here are the steps I followed:
    - I downloaded and installed node/npm.
    - I downloaded the sample files from the url (which I cannot post here since this is my first post) for the sample ui
    - Opened Powershell to run the command "npm install"

    The command "npm install" fails with a sysntax error in a python command.
    Can you tell me what I am doing wrong according to the attached log file?
     

    Attached Files:

  11. Martin1782

    Martin1782 New Member

    Joined:
    Jun 21, 2022
    Ratings:
    +0 / 0 / -0
    Hello,

    I have a problem with the custom dashboard. Im using the dash.zip from github.
    Im able to set up the single information displays (radar, pedal and steering position etc.)
    As i drive in practice and qualifying everything is ok, but when i switch after qualifying to race, the single information displays move to the bottom right corner. its the standard i think.
    Do you know this case?
    What should i do to fix it? Or do you need more information?

    Thanks