In-Gameplay Web Overlays

Discussion in 'Community Workshop' started by J-F Chardon, Apr 4, 2019.

  1. majuh

    majuh Well-Known Member

    Joined:
    May 1, 2015
    Ratings:
    +104 / 0
    I can't make it work that way. When I click on the Drive button, the game immediately pauses and the index.html is shown in the Steam overlay web browser instead... When I disable the Steam overlay, the game works, but no Web HUD is being shown.
     
  2. Thomas Jansen

    Thomas Jansen Sector3 Developer Beta tester

    Joined:
    Apr 5, 2018
    Ratings:
    +301 / 0
    You have to add -webdev i believe when using the file
     
  3. Scout

    Scout Well-Known Member Beta tester

    Joined:
    Sep 3, 2018
    Ratings:
    +292 / 0
    Can you open the index.html in your browser too and try again?
     
  4. majuh

    majuh Well-Known Member

    Joined:
    May 1, 2015
    Ratings:
    +104 / 0
    You are right, it works with -webdev -webHudUrl=file:///C:/path/to/dist/index.html

    It takes a few seconds for the Web HUD to show up after clicking on Drive this way, though.
     
  5. NL-Jos

    NL-Jos Well-Known Member

    Joined:
    Jun 5, 2015
    Ratings:
    +162 / 0
    I tried again but i never see some lights or something so i can see if i have the pit-limiter on or off
     
  6. Meodread

    Meodread Member

    Joined:
    Aug 6, 2016
    Ratings:
    +5 / 0
    I had the In Game Overlay working fine but as of yesterday it started giving an error that reads "Version Mismatch"

    Anyone else having that issue?
     
  7. Thomas Mueller

    Thomas Mueller New Member

    Joined:
    Mar 15, 2019
    Ratings:
    +0 / 0
    Hello, i have seen in a Video that the Radar give Sound when a Car is near. I´ve no Sound. Why ?

    Thanks for Help
     
  8. NL-Jos

    NL-Jos Well-Known Member

    Joined:
    Jun 5, 2015
    Ratings:
    +162 / 0
    In the settings you can turn it on
    I don't want it on, i get crazy at the start with 20 riders :cool::confused::D
     
  9. Thomas Mueller

    Thomas Mueller New Member

    Joined:
    Mar 15, 2019
    Ratings:
    +0 / 0
    It´s activatet, but there is no Sound.
     
  10. NL-Jos

    NL-Jos Well-Known Member

    Joined:
    Jun 5, 2015
    Ratings:
    +162 / 0
    Look at the place of my mouse (in my case the schuld beep is off)
     

    Attached Files:

  11. Thomas Mueller

    Thomas Mueller New Member

    Joined:
    Mar 15, 2019
    Ratings:
    +0 / 0
    In my Case is on.... no Sound :/
     
  12. Nico Kunze

    Nico Kunze Well-Known Member

    Joined:
    Sep 1, 2018
    Ratings:
    +94 / 0
    Are you sure youre actually close enough to the other cars to trigger the sound?
     
  13. Thomas Mueller

    Thomas Mueller New Member

    Joined:
    Mar 15, 2019
    Ratings:
    +0 / 0
    oh yes i am verry sure ;)
     
    • Funny Funny x 1
  14. Goffik

    Goffik Active Member

    Joined:
    Jun 30, 2017
    Ratings:
    +29 / 0
    Maybe you're just missing it? It's very subtle, hard to hear over loud engines revving high. Maybe try setting engine volume to zero just to check that it's definitely working?
     
  15. majuh

    majuh Well-Known Member

    Joined:
    May 1, 2015
    Ratings:
    +104 / 0
    Funnily enough, I can't turn off that beep even if I uncheck the setting.
     
  16. Gopher04

    Gopher04 Well-Known Member

    Joined:
    Mar 6, 2015
    Ratings:
    +211 / 0
    Yeh I've stopped using the new hud, it does seem to to be the cause of performance issues for me especially when the AI are on track which is a shame..
     
    • Agree Agree x 1
  17. MattStone

    MattStone Well-Known Member

    Joined:
    Mar 6, 2016
    Ratings:
    +95 / 0
    Yeah I’ve found the same thing :(
    I do miss the proximity indicator tho:(
     
  18. [RWB] FxUK

    [RWB] FxUK Well-Known Member

    Joined:
    Dec 2, 2018
    Ratings:
    +77 / 0
    I wonder if you would still get performance issues using simhub and an in-game dash instead of the sector 3 webhud. It has a proximity indicator too.
    Even if it wasn't for you, would be interesting to know if it made a difference, that could then point to it being related to the code for the webhud and not the browser implementation in game, I guess.

    Personally, I don't get any performance issues with either, but prefer simhub's flexibility and ease of editing / creating my own things, compared to the sector 3 example.

    p.s I'm not affiliated with simhub in any way, just a normal user, but love it. Just in case it looks like I'm advertising it all the time :p
     
    Last edited: Apr 24, 2019
  19. MattStone

    MattStone Well-Known Member

    Joined:
    Mar 6, 2016
    Ratings:
    +95 / 0
    I’ve been watching the thread and I’m hoping to try it out this weekend.
     
  20. [RWB] FxUK

    [RWB] FxUK Well-Known Member

    Joined:
    Dec 2, 2018
    Ratings:
    +77 / 0
    The only reason I am thinking it is, similar to the broadcast overlay, if you have a dash (web-page) running that is fairly intensive, it causes performance issues in-game. i.e Scout removed some animation things from that broadcast overlay (iirc) due to performance impact and the track map that it can overlay also causes the same. But with them off, its butter smooth. So maybe the webhud has too many effects etc going on.
     
    • Informative Informative x 1