Question Logitech G29

Discussion in 'Community Support' started by Sébastien Degraeve, Aug 29, 2015.

  1. ango

    ango New Member

    Joined:
    Jan 25, 2016
    Ratings:
    +0 / 0 / -0
    Thank you for your information, looking forward the support :)
     
  2. Paradox Agi

    Paradox Agi Active Member

    Joined:
    Dec 26, 2015
    Ratings:
    +31 / 0 / -0
    Great! This helped me to get my T150 working properly. I now can adjust the angle per car in game. Thanks for that.
     
  3. Paradox Agi

    Paradox Agi Active Member

    Joined:
    Dec 26, 2015
    Ratings:
    +31 / 0 / -0
    The animation has to be adjusted separately in the vehicle settings menu. Set it to 'wheel only' and the rotation angle according to the one you setup in the car itself or in the Logitec profiler. Did Stiku's workaround for making the angle be adjustable in game not work out for you?
     
  4. F1mre

    F1mre New Member

    Joined:
    Jan 3, 2016
    Ratings:
    +0 / 0 / -0
    Thanks, it was set to wheel and hands. But that should also have a 360 degree angle, rotating a wheel 180 degrees one way is possible. :)

    With Stiku's profile, I am unable the change wheel rotation in the settings (during sessions)
     
  5. Paradox Agi

    Paradox Agi Active Member

    Joined:
    Dec 26, 2015
    Ratings:
    +31 / 0 / -0
    With hands enabled, it just turns 90 degrees to each side currently. So I disabled the hands to match rotation angle with the angle of my real wheel.

    I don't know what wheel stiku is using, but I thought he was using a g29 himself and the fix he provided was tested with that wheel. Did you make sure your wheel uses the same device ID as the one included in his code?
     
    • Informative Informative x 1
  6. F1mre

    F1mre New Member

    Joined:
    Jan 3, 2016
    Ratings:
    +0 / 0 / -0
    Where can I find my device ID?
     
  7. Paradox Agi

    Paradox Agi Active Member

    Joined:
    Dec 26, 2015
    Ratings:
    +31 / 0 / -0
    In your custom device profile, you should find it here

    <your documents folder>\My Games\SimBin\RaceRoom Racing Experience\UserData\ControlSet

    search for deviceId in the rcs file, using a text editor. (If you don not have a rcs-file there, you have to create a custom profile in the game for your wheel first.) In the rcs-file you will find something like

    DeviceId[00]="(<some numbers>, -1, -1, 0)"

    These Numbers are your device id. To make stiku's fix work, your device id has to match the numbers within his code in the line

    <key type="uint32">3259958381</key> <!-- Logitech G29 -->

    If your device id already macthes 3259958381, the code stiku provided should work, as long as you get it properly implemented into your 'steering_wheels.xml' file. If it still does not and your xml-file is modified correctly, the wheel is not providing rotation angles to the game currently and you have to wait for the devs to fix the problem. They are working on it. If you are not sure if your xml file is messed up in any way, just upload it in a post so I can look into it.
     
    • Useful Useful x 1
  8. F1mre

    F1mre New Member

    Joined:
    Jan 3, 2016
    Ratings:
    +0 / 0 / -0
    Thanks. I missed the steering_wheels.xml part (new computer, done on the other one)

    Will an update replace Stiku's G29 profile and modify the steering_wheels xml?
     
  9. Paradox Agi

    Paradox Agi Active Member

    Joined:
    Dec 26, 2015
    Ratings:
    +31 / 0 / -0
    What kind of update are you talking about? A game update will probably affect the steering_wheels.xml but it should not change your custom profiles in your documents folder.
     
  10. EsxPaul

    EsxPaul Well-Known Member

    Joined:
    Feb 17, 2016
    Ratings:
    +50 / 0 / -0
    Trying to get my G29 to work is proving a real headache.

    I've added this to the xml file:
    <key type="uint32">3259958381</key> <!-- Logitech G29 -->
    < value>
    <supportsWheelRange type="bool">true</supportsWheelRange>
    <minWheelRange type="uint32">40</minWheelRange>
    <maxWheelRange type="uint32">900</maxWheelRange>
    </value>

    Then I added the G29 .rcs profile kindly supplied by Stiku (thank you) into the correct folder.
    The throttle, brake and paddles all seem to work. I select a gear, press the throttle but the car won't move at all from its position in the pit.

    I'm feeling real dumb right now!
     
    • Agree Agree x 1
  11. mr_belowski

    mr_belowski Well-Known Member Beta tester

    Joined:
    Apr 23, 2015
    Ratings:
    +1,297 / 0 / -0
    when I configured my G29 I didn't do any fiddling with profiles. I started the game and it detected it as an unrecognised controller and allowed me to configure it all. I had to bind each axis and button to the appropriate control but after I did all that it worked very well
     
    • Like Like x 1
  12. EsxPaul

    EsxPaul Well-Known Member

    Joined:
    Feb 17, 2016
    Ratings:
    +50 / 0 / -0
    Thanks for the reply
    .
    I deleted the modifications I had previously made and started again from scratch. I went through the steps exactly as you mention and I can get the car moving again. Problem is the steering... the wheel is being ripped out of my hands as soon as the car moves. It swings left to right with a very strong force right away.

    I've tried running through the calibration in Windows 7 control panel but the problem is I cannot move the wheel from lock to lock when asked because the force feedback seems to be on and stops me from moving more than around 10 degrees off centre when I'm being asked by Windows to move it through its full range. I will definitely break something if I move the wheel more than those 10 degrees.

    I think that may be why the car only seems to have that tiny amount of lock to lock rotation in game, therefore making it unusable for me.
     
  13. Stiku

    Stiku Member

    Joined:
    Dec 6, 2015
    Ratings:
    +5 / 0 / -0
    Sounds to me like that your rotation settings in Logitech Gaming Software aren't right?
    Have you set them to 900° and the wheel to PS4 mode?
     
    • Useful Useful x 1
  14. mr_belowski

    mr_belowski Well-Known Member Beta tester

    Joined:
    Apr 23, 2015
    Ratings:
    +1,297 / 0 / -0
    also make sure the 'reverse force feedback effects' setting is checked in the game

    [edit] i didn't bother with the windows calibration stuff. Just installed the logic software, plugged the wheel in, waited a bit, then launched RaceRoom and went through the device configuration stuff

    There's a little switch on the top of the wheel for selecting PS3 or PS4 mode. Mine's in PS4 mode
     
    • Like Like x 1
    • Informative Informative x 1
  15. EsxPaul

    EsxPaul Well-Known Member

    Joined:
    Feb 17, 2016
    Ratings:
    +50 / 0 / -0
    Thanks guys, I think I'm starting to get somewhere now.

    This is what I have done.

    In LGS, I have rotation set to 900 (Always has been)
    Wheel switch is in PS4 mode (Always has been)
    'reverse force feedback effects' - I'll have a check for that one when I'm next in game

    I did re run the Windows calibration and that made a big difference. I had to very slowly move the wheel through its full left to right rotation. That took around 5 minutes to do as I had to very slowly overcome the force feedback fighting against me. Really thought I was going to break the wheel if I went any faster lol

    Once I did that, I had to redo it again once in the game menu and I could see the sliding bar graph showing that I had to move fully from lock to lock in order to see the grey slider move through its full range.

    900 degrees seems an awful lot of lock to have in game and I'm finding that the car is needing loads of lock to get around corners but at least for now I can try to have a very slow first drive around a single lap!

    The force feedback and amount of effort needed to get around even a shallow corner seems far to high still but I think I will need to find another G29 users in game force feedback settings and copy them over to try and dial things in a lot more.

    Still a long way to go and I'm sure I'm missing a lot of things due to having zero experience with wheels and games in general.
     
  16. mr_belowski

    mr_belowski Well-Known Member Beta tester

    Joined:
    Apr 23, 2015
    Ratings:
    +1,297 / 0 / -0
    the ffb settings I have in-game are 'nothing unusual' - just a few random clicks based on some old G27 settings I found, and even with the defaults I certainly never struggled to turn the wheel. There's something else weird going on I think. I have the overall ffb strength at about 80, the steer force at 90(ish) and the vertical and lateral loads at about 70 & 120 respectively. I just guessed at these - it felt OK before I made the changes. I also have 0 smoothing, 0 spring and 0 damper, and the engine vibrations at 0. Brake vibrations are about 5, the gear shift effect is high (80 I think), and the kerb rumble is about 10.

    I did edit my g29.rcs file (in ...\Documents\My Games\SimBin\RaceRoom Racing Experience\UserData\ControlSet) and changed FFB steer force exponent to 0.6, which seems to have helped with the ffb deadzone, but it didn't make the wheel lighter or anything.

    I also changed the rotation to 720 in the Logic software because 900 is just too much for my tastes. I also tweak the steering lock in the car setup too.

    But none of this explains your issue - I really don't understand why the wheel is so heavy for you
     
    • Useful Useful x 1
  17. EsxPaul

    EsxPaul Well-Known Member

    Joined:
    Feb 17, 2016
    Ratings:
    +50 / 0 / -0
    Thanks for taking the time to write such a detailed reply. I'll take your settings over and give them a shot. I agree that 900 seems far too high and changing to 720 should make things easier for me.

    I really think my hardware is ok now, I'm just lacking any point of reference on how things should feel due to this being my first time ever with any kind of racing wheel or game.

    I'm at least able to now drive a few very slow laps and I think that if I put in a lot of time playing around with settings, I'll slowly get there in the end.

    The experience doesn't feel realistic at all presently but I'm starting to realise just how much changing a single FFB setting makes such a large difference to the feel you get. That has to be where I'm going wrong I think.

    I'll keep going at it and see where it leads.

    Thanks again, I really appreciate the help.
     
  18. mr_belowski

    mr_belowski Well-Known Member Beta tester

    Joined:
    Apr 23, 2015
    Ratings:
    +1,297 / 0 / -0
    the only settings that (I think) could make the wheel impossibly stiff are the spring and damper settings - if these are at 100 then maybe it'd behave like that. But IIRC the default for these is like 0
     
  19. AMG Vilas ®™

    AMG Vilas ®™ Well-Known Member

    Joined:
    Jan 30, 2015
    Ratings:
    +45 / 0 / -0
    • Useful Useful x 1
  20. EsxPaul

    EsxPaul Well-Known Member

    Joined:
    Feb 17, 2016
    Ratings:
    +50 / 0 / -0
    I changed LGS setting to 720 and copied over your FFB settings and things are felling much better now. Thank you.

    One thing I have found has helped is that I went into the "car setup" tab
    The "wheel range" setting showed N/A
    The "steering lock" showed 13 by default - I changed that to 20 and that made the steering input feel much more positive

    I'm not sure how important these settings above are but the steering lock change made a lot of difference for me.

    I still feel that I'm fighting the wheel more than the track itself but I'm in a much better position now that I was this time yesterday!

    Getting there slowly...