Resolved Logitech G920 (Possibly all G wheels) Automatic Rotation Fix

Discussion in 'Community Support' started by tothrauldaniel, Jul 24, 2017.

  1. tothrauldaniel

    tothrauldaniel Member

    Joined:
    Jan 22, 2017
    Ratings:
    +23 / 0
    The automatic soft lock is not working on the Logitech G920 wheel. If I set the wheel to 900 and ingame wheel off and match settings every car has 900 and 13 lock. Tried checking integrity of files in Steam, a new controller profile, reinstalling the game. It works in Project Cars and Assetto Corsa. It's been like this for a while now.
     
    Last edited: Jul 31, 2017
  2. Oreos

    Oreos Well-Known Member Beta tester

    Joined:
    Mar 29, 2017
    Ratings:
    +144 / 0
    [​IMG]

    Have you got this box checked in your G29 settings? Click the cog in the bottom right of LGS.
     
    • Informative Informative x 1
  3. Oreos

    Oreos Well-Known Member Beta tester

    Joined:
    Mar 29, 2017
    Ratings:
    +144 / 0
    Make sure you go to the LGS website and update it manually. I have these options now under my wheel axis too.

    [​IMG]
     
    • Informative Informative x 1
  4. tothrauldaniel

    tothrauldaniel Member

    Joined:
    Jan 22, 2017
    Ratings:
    +23 / 0
    Ok, so here are the settings:
    [​IMG]
    [​IMG]
    [​IMG]

    I don't think there's anything wrong at my end to be honest, everything is up to date and all. Tried reinstallations for everything involved.
     
    Last edited: Jul 31, 2017
  5. tothrauldaniel

    tothrauldaniel Member

    Joined:
    Jan 22, 2017
    Ratings:
    +23 / 0
    Shouldn't it look like this in the car steering settings?
    [​IMG]
    Here is what I have on any car:
    [​IMG]
     
  6. Paul Darke

    Paul Darke Moderator Beta tester

    Joined:
    Jan 29, 2015
    Ratings:
    +155 / 0
    I get the N/A in the wheel range if I start the game before I turn on my wheel. Not the same wheel as yours though.
     
    • Informative Informative x 1
  7. nate

    nate Well-Known Member Beta tester

    Joined:
    Jan 31, 2015
    Ratings:
    +874 / 0
    Yes, this is correct.

    If you are getting N/A in the car setup menu, then something is wrong. The G920 is officially supported as far as I know, however Logitech has had plenty of problems in the past.

    What version of the Logitech Gaming Software are you using? Perhaps this isnt properly up to date. You could also try uninstalling the LGS and reinstalling that too, to see if the game recognizes the rotation better.

    Perhaps try a different USB port too and try starting the LGS before entering the game.
     
    • Informative Informative x 1
  8. tothrauldaniel

    tothrauldaniel Member

    Joined:
    Jan 22, 2017
    Ratings:
    +23 / 0
    Yep, already tried those things, unfortunately to no avail. The software is the latest, no problems there, or any other games. It's a very weird thing this especially since it used to work in the beginning for a short while. The wheel it's almost new but I don't really like it anyway and plan on giving it away as a gift to a friend, and get a Fanatec system. I just got it as an exchange for a moderately outdated and unfinished gaming system plus the difference in money. Honestly I don't think we are gonna figure this out to be honest, guess I will just use my own realistic settings like in the old days of sims :p
     
    Last edited: Jul 27, 2017
  9. Thomas Bienert

    Thomas Bienert Member

    Joined:
    Nov 22, 2015
    Ratings:
    +9 / 0
    Yo have them same issues with my g27 since years. But RR doesnt cares. Couldnt fix it yet =( Very sad for cars like FR Junior because either I have to drive 450° (+90°) or 180° (-180°) =/ Normally I adapt the steering lock. Butfor exampel frj has max lock at 360° and its a real struggle to keep the pace up with fast drivers if you cant react that fast. There was never a solution. All other racing games dont have this problem.

    https://forum.sector3studios.com/in...cks-after-90-degree-rotation.3452/#post-40928

    Newest driver software for g27 for sure! Talked a lot with many people from different communities about it. And tryed lots of stuff. But there has to be a very small bug with logitech wheels. So I assume because if it happens with g29 too, it has to be something with the logitech drivers.
     
    Last edited: Jul 26, 2017
  10. Case

    Case Well-Known Member

    Joined:
    Apr 7, 2017
    Ratings:
    +74 / 0
    If you're using Windows 10, then it overwrites Logitech wheel drivers with certain updates (happened to me again two or so weeks ago), even if you have the driver updates disabled (I have). This causes plenty of issues, as the drivers, despite being newer, don't work well with older wheels.

    Can't comment on how (if in any way) this issue affects the G29, though.
     
    • Useful Useful x 1
  11. tothrauldaniel

    tothrauldaniel Member

    Joined:
    Jan 22, 2017
    Ratings:
    +23 / 0
    Def a rotation auto calibration issue, but not really the same problem.
     
  12. tothrauldaniel

    tothrauldaniel Member

    Joined:
    Jan 22, 2017
    Ratings:
    +23 / 0
    It does affect the G25 as I used that before, but not the G920, as far as I know windows has not done anything else to the G920 after I installed the latest gaming software and firmware update from Logitech. But who knows can't really be 100% sure.
     
  13. tothrauldaniel

    tothrauldaniel Member

    Joined:
    Jan 22, 2017
    Ratings:
    +23 / 0
    I have found the problem. Right when you install Logitech Gaming Software in the background Windows 10 installs a new device, the G920 xbox bla bla wheel as a controller. This is the problem. If I remove the windows part of the installation it works as it should. Now I am trying to figure out how to permanently block Windows 10 from installing anything for this device, as blocking driver updates does not work in this case.
    [​IMG]
    [​IMG]
    The thing is you don't always get the notification in the lower-right of the screen, in the action center that Windows is installing a device, sometimes it just does it in the background. I have tested this with the G25 (which was locked at 180 degrees no matter what) and G920 so it should work for the G27 and G29 also. This is possibly a fix for the whole G wheel series from Logitech in regard to their automatic rotation settings related problems. Hope this will help others as I know how frustrated I was for the past few months.
     
    • Informative Informative x 1
    Last edited: Aug 4, 2017
  14. tothrauldaniel

    tothrauldaniel Member

    Joined:
    Jan 22, 2017
    Ratings:
    +23 / 0
    Ok, so here is how to prevent Windows 10 from installing a specific device:
    1. Open the Windows Device Manager
    2. Locate the device in the device listing, right-click on it, and select properties from the context menu.
    3. Switch to the Detalis tab and selec Drive IDs from the drop down menu.
    4. Copy the Driver ID of the device
    5. Tap on the Windows-key, type gpedit.msc, and hit the Enter-key.
    6. Go to Computer Configuration > Administrative Templates > System > Device Installation > Device Installation Restrictions.
    7. Double-click on "Prevent installation of devices that match any of these device IDs".
    8. Switch the status of the preference to enabled.
    9. Click on the show button afterwards
    10. Add hardware IDs for the devices that you don't want Windows to update under value (in each row one device).
    11. Click apply and ok.
    I have tested this with the G25 and G920 so it should work for the G27 and G29 also.
    Hopefully this will work in the long run :)
     
    • Informative Informative x 1
    Last edited: Aug 4, 2017
  15. Thomas Bienert

    Thomas Bienert Member

    Joined:
    Nov 22, 2015
    Ratings:
    +9 / 0
    After manually reinstalling the gpedit I couldnt find the "device installation" either i am looking at the wrong things or searching for the wrong things

    do you mean the driver key? i dont have a driver-id but it may comes with my german language. so need so ask
     
  16. tothrauldaniel

    tothrauldaniel Member

    Joined:
    Jan 22, 2017
    Ratings:
    +23 / 0
    I
    You misunderstood something. Try following this guide because it has pictures too:
    https://www.howtogeek.com/263851/ho...from-automatically-updating-specific-drivers/
    By the way, this method seems to have broken the wheel in Project Cars and F1 2016, annoying lol
     
  17. Sean Daniel

    Sean Daniel New Member

    Joined:
    Oct 4, 2017
    Ratings:
    +0 / 0
    I'm having this exact same problem on Windows 7 (x64) on a Logitech G27. Using VR, on an HTC Vive.

    The lock points on the "actual" wheel. Do not coincide with the wheel lock in game. (to say nothing for the non-alignment with the rotation of the in game steering wheel. "Nothing in the settings came close to bringing them to parity, not even close")
     
  18. tothrauldaniel

    tothrauldaniel Member

    Joined:
    Jan 22, 2017
    Ratings:
    +23 / 0
    In my case there was actually a conflict of drivers because even after I uninstalled the G25 drivers there were still some leftovers and until I completely deleted everything, including registry entries the G920 did not work correctly.