Problem Low replay FPS

Discussion in 'Community Support' started by voronov92, May 7, 2016.

  1. tothrauldaniel

    tothrauldaniel Member

    Joined:
    Jan 22, 2017
    Ratings:
    +23 / 0 / -0
    Only used some tracks and some cars but I am willing to bet it does it regardless since the problem occurred in other games during replays also. Will have to test everything one of this days to be sure how things stand now with the other games since I have not raced in them for a while.
    In RaceRoom I saw this happening on Spa, Bathurst and Road America lately, and the cars I used were GT3 cars, to many to matter honestly.
     
    • Agree Agree x 1
  2. TopGun82

    TopGun82 New Member

    Joined:
    Feb 7, 2018
    Ratings:
    +0 / 0 / -0
    It will happen every time, but somtimes it takes longer than other times. Especially when it's a replay of a crowded session. Like the previous comment, once it happens it carries on to the actual playing part (and menu stutters as well). Only a restart of the game will solve it for a while. During the stutter, processor and gpu temps are normal and on screen FPS still indicates 90fps, as locked by rivatuner.
     
    • Agree Agree x 1
  3. m.bohlken

    m.bohlken Well-Known Member

    Joined:
    Jan 29, 2015
    Ratings:
    +984 / 0 / -0
    And you are both using the 64bit-Version or have a 64bit Windows-Version?
     
    • Agree Agree x 1
  4. TopGun82

    TopGun82 New Member

    Joined:
    Feb 7, 2018
    Ratings:
    +0 / 0 / -0
    I have a freshly installed Windows 10 64bit and RR is also running in 64bit mode. Yesterday night I could play RR for quite some time before the stutter problem started (2-3 hours). Again, the stutter started once watching a replay. Most of the time, I can watch a replay after a fresh start. Looks like some sort of a memory leak.
     
    • Agree Agree x 2
  5. TopGun82

    TopGun82 New Member

    Joined:
    Feb 7, 2018
    Ratings:
    +0 / 0 / -0
    tothrauldaniel - It looks like the problem is gone (or at least delayed) when I am using the graphic setting "high" instead of custom. Maybe you can try that out as well. Still strange as my computer can easily run custom (higher) settings smoothly.
     
    • Useful Useful x 1
  6. tothrauldaniel

    tothrauldaniel Member

    Joined:
    Jan 22, 2017
    Ratings:
    +23 / 0 / -0
    Interesting find, but that is not an option for me, I sit at 67cm from a 42 inch screen, I really need that 4k max settings.
    But there is something strange here, I know we are talking about RaceRoom here but I find it suspicions that the same thing used to happen in F12017 replays and more rarely but did sometimes happen in Project CARS 2 replays as well. Also in GTA5 and The Witcher 3 if you just stand there and don't touch anything it will also drop drastically. I suspect some sort of hidden idle power management setting of the GTX1080 to be honest, but I could not find one.
     
    Last edited: Feb 16, 2018
  7. TopGun82

    TopGun82 New Member

    Joined:
    Feb 7, 2018
    Ratings:
    +0 / 0 / -0
    I discovered that cycling the screen resolution (changing it too one step lower, then back to normal) fixes the issue without the need of a restart of the game. After I cycled the resolution in-game, I haven't been able to reproduce the stutter while watching replays. Might be worth a try. Maybe this info is also usefull for the developers?
     
    • Useful Useful x 1
  8. TopGun82

    TopGun82 New Member

    Joined:
    Feb 7, 2018
    Ratings:
    +0 / 0 / -0
    Unfotunately, last suggestion (resolution cycle) does not do the job either for the long run. This really annoys me as I spent more than 2k on my new PC for RaceRoom and it is not working for more than 2 races in a row. :-(
     
    • Agree Agree x 1
  9. tothrauldaniel

    tothrauldaniel Member

    Joined:
    Jan 22, 2017
    Ratings:
    +23 / 0 / -0
    Found a thread about this problem. Gonna try the solution tomorrow when home:

    "OK, I think I finally have found the solution! This was the malfunction of nVidia programmes. I went to the Event viewer and saw that something like nvstream causes errors. So I went to msconfig (START and type msconfig), then tab Services and unchecked NVIDIA Streamer Service. Applied, restarted and voila! No drops! I hope I will help someone in the future with this thread."

    And this:

    "If I may pop in on this, as a Computer Technician, I'd like to help by informing that there are three places that Power Management (where the system tries to 'save power utilization by slowing things down') can be found:

    1. In the GPU Control Panel
    2. In Windows Power Management
    3. In the BIOS of the Mainboard (Motherboard Settings)

    You might have to check them all, to make sure that any 'power saving' settings are Off or Disabled. Don't forget to turn off your CPU Power Savings as well (as the issue is not just related to the GPU). "
     
    Last edited: Feb 26, 2018
  10. TopGun82

    TopGun82 New Member

    Joined:
    Feb 7, 2018
    Ratings:
    +0 / 0 / -0
    Thanks tothrauldaniel, will try that as well. However, I think I have solved the issue by installing GPU-Tweak II. Since this app is running I am able to watch the replays with no stutter at all. Maybe it forces the video card to stay out of any sort of sleep mode, I don't know. Just happy that it seems to be fixed.

    Looking forward to your findings, maybe you can try the GPU-Tweak II as well and see if it helps.
     
  11. tothrauldaniel

    tothrauldaniel Member

    Joined:
    Jan 22, 2017
    Ratings:
    +23 / 0 / -0
    Didn't test extensively either but it does look like that was the issue. I fixed the GPU clock in MSI Afterburner and set Prefer Maximum Performance in Nvidia Control Pannel for Desktop Window Manager (dwm.exe) c:\windows\system32, Windows Explorer (Explorer.exe) c:\windows and Steam because I play most games in Borderless Window, so basically the same thing as you did and tested 4 cars on 4 tracks and no issues during replays so far so maybe that was the issue. So as I thought it was not a Raceroom issue, and hence it happened in almost any game when idle for long times.
     
  12. tothrauldaniel

    tothrauldaniel Member

    Joined:
    Jan 22, 2017
    Ratings:
    +23 / 0 / -0
    So I figured it out what it is. It's the CPU. Tested using Afterburner in GTAV. After some idle time the framerate always drops to 5-15 and I noticed that the GPU state is locked but the CPU usage drops from the normal 35-45 to 15-20. Now it's good that we know what it is but the strange thing is I disabled every thing related to this stuff for the CPU to, but for some reason it does the same thing.
     
  13. tothrauldaniel

    tothrauldaniel Member

    Joined:
    Jan 22, 2017
    Ratings:
    +23 / 0 / -0
    Here is a video about the problem. This time it reverted to normal after moving the mouse but that happened only once more, every other time I had to restart the game. Look at what happens at 1:05, the CPU usage goes down from about 35-40 to 15-17.

     
  14. Robineto

    Robineto New Member

    Joined:
    Mar 2, 2018
    Ratings:
    +1 / 0 / -0
    It's strange that nobody mentioned it, but it's widely known (except the devs apparently) that the stutter from replay in raceroom come from the compression of the replay folder.
    If you want to see a replay you must decompress the folder mydocument/my games/simbim/raceroom racing experience.
    But the game will automatically recompress the folder after a while, so that's not a fix in the long term, and there is no fix until the devs know it, so please tell them to not compress this folder or better decompress and store data in memory before playing it.
     
    • Useful Useful x 2
    Last edited: Mar 4, 2018
  15. tothrauldaniel

    tothrauldaniel Member

    Joined:
    Jan 22, 2017
    Ratings:
    +23 / 0 / -0
    I was not aware of this. So how exactly do I decompress that folder? I see no option of the sort when right clicking on it.
     
  16. fdeutsch

    fdeutsch New Member

    Joined:
    Dec 4, 2017
    Ratings:
    +1 / 0 / -0
    Really? They do that?
    I have the same issue while viewing replays, but also when racing after some time long sessions.
    One way to avoid this is to not save the replays, I know there is a command line option to not save replays.
     
  17. Robineto

    Robineto New Member

    Joined:
    Mar 2, 2018
    Ratings:
    +1 / 0 / -0
    right click on the folder/settings (or properties i don't use the english version)/click on button advanced/uncheck the box "compress content to save disk space"
    windows will automatically uncompress this folder.
     
    • Useful Useful x 2
  18. tothrauldaniel

    tothrauldaniel Member

    Joined:
    Jan 22, 2017
    Ratings:
    +23 / 0 / -0
    Thanks.
     
  19. Robineto

    Robineto New Member

    Joined:
    Mar 2, 2018
    Ratings:
    +1 / 0 / -0
    Yes they use NTFS inbuilt compression. The devs probably though hey, i don't think replays need real time performance let's save space and let's tell windows to compress this folder.
     
    • Useful Useful x 2
  20. tothrauldaniel

    tothrauldaniel Member

    Joined:
    Jan 22, 2017
    Ratings:
    +23 / 0 / -0
    Yep. Finally figured it out. That compression is the issue. If I manually decompress the folder there are no issues with the replay while watching until the game automatically recompreses it, and that's the moment it starts. Hopefully they will fix this in a patch because it's really unacceptable I think to not be able to watch replays with the awesome sound this sim has.
     
    • Agree Agree x 1
    • Useful Useful x 1