Resolved Massive Stutters that don't show up in RTSS

Discussion in 'Community Support' started by johndough247, Sep 3, 2019.

  1. johndough247

    johndough247 New Member

    Joined:
    Jul 21, 2019
    Ratings:
    +2 / 0
    I have a serious problem and have spent a week trying several solutions without success; getting tired of it now and need help. First off my full rig and specs:

    CPU: 8700K @ 5.0GHz
    GPU: RTX 2080 (MSI Gaming X Trio)
    RAM: 2 x 8GB DDR4 3000Mhz
    Boot Drive: 970 Evo SSD
    Steam Drive: 8 TB HDD
    Monitors: 3 x 27" 144Hz G-sync Monitors
    OS: Windows 10 Home version 1903

    Wheelbase: Fanatec CSW v2.5
    Steering Wheel used: Fanatec F1 2018 LE
    Pedals: Fanatec CSP v3 inverted
    Other gear: Fanatec ClubSport Shifter SQ V 1.5 and ClubSport Handbrake V1.5 (attached to Wheel), Logitech G27 Shifter as a button box (connected with Leo Bodnar adapter)

    Config used to test in R3E:
    Single Player Practice session
    Car: FR X-17
    Track: Spa
    AI opponents: None

    Description of problem:
    • At random points in time (sometimes at start of lap 1 in the pits, sometimes 10 laps in), the game will start to visually stutter for the rest of the session: The FFB in the wheel starts to stutter as well (feels very notchy) as well as missed shifts, and the audio also stutters: revving the car sounds more like a piano playing notes than a smooth change in pitch.
    • Looking at RTSS in-game and the graphs in Afterburner, framerate (110 - 141 FPS) and frametime (7 - 9ms) stays consistent with previous laps before the stutter started. GPU and CPU graphs also remain consistent.
    • When I return to the menu in-game, the counter then drops to 6-7 FPS and it is visually slow.
    • Return to the track after that and it's stuttering again immediately, but again RTSS shows everything normal (141 FPS in pits).
    • Exit to main menu i.e. quitting the race session and FPS goes to 45 FPS. It's normally at 68 FPS.
    • Game will not return to normal unless you restart R3E.
    • Before the stuttering started, I had RaceRoom crash 60 mins into a 90 mins multiplayer race. The visuals permanently froze but the audio and FFB was still working. Had to use Task Manager to exit.
    • Game runs at 5864 x 1080 @ 144Hz. I've used S3's Web Dash, the OtterHUD Web Dash, the standard R3E Dash and No dash...problem exists in all configurations. Problem only exists in RaceRoom; No problems in Assetto Corsa.



    Here are all the steps I've taken to fix this (in the order I did them) based of previous threads with similar problems. Ran game after each step but eventually stuttering returned.
    1. Reduce shadow quality, contact shadows, AA and # of cars.
    2. Steam Integrity check (no errors)
    3. Removed S3 Web Dash files and removed the web dash launch code from steam
    4. Full uninstall and reinstall from steam + Erasing all User data (backup car setups to separate location)
    5. Erased Raceroom's Cache folder in My Documents.
    6. Erased X64 folder in raceroom and then did Steam integrity check to have them replaced.
    7. Installed all pending Windows updates.
    8. Ran windows System File Checker (sfc /scannow) and if found and fixed a few corruptions/permissions errors.
    9. Used DDU to remove everything GPU related in safe mode, clean install of latest Nvidia drivers (436.15) and setup Nvidia surround again. **This step did fix some visual slowdown I would have when hovering over certain apps (Dropbox, Bluestacks). PLEASE NOTE: I do not have Dropbox or Bluestacks running in the background when playing R3E.**
    10. Installed OtterHUD and tried all performance options.
    11. Assigned programs to different CPU cores. RRRE64: Cores 1 - 6, CrewChief: Cores 7 and 8, RRREwebbrowser: Cores 9 - 12.
    12. Downgraded Fanatec Drivers from v336 beta to the certified v328. Downgraded Motor and Steering wheel firmware as well (Wheel being used is the F1 wheel).
    13. Turned off Force Feedback on in R3E as well as on the wheel.
    14. Deleted controller profile in RaceRoom and created a new one.
    I have a race tomorrow in a series and need the game to be solid. The only thing I haven't fulled tested yet is Running R3E in 32-bit mode; will do that shortly. Please help somebody.
     
    Last edited: Sep 3, 2019
  2. Andy Blade

    Andy Blade Well-Known Member Beta tester

    Joined:
    Feb 21, 2016
    Ratings:
    +299 / 0
    I guess you tried without Afterburner and Rivatuner ? I would also close other apps like dropbox and blustacks definitely
     
  3. johndough247

    johndough247 New Member

    Joined:
    Jul 21, 2019
    Ratings:
    +2 / 0
    Did not try without Afterburner. I'm running minimal apps, I only mentioned Dropbox and Bluestacks because around the same time R3E started giving problems those apps had visual issues as well, but they are always closed when gaming.
     
  4. johndough247

    johndough247 New Member

    Joined:
    Jul 21, 2019
    Ratings:
    +2 / 0
    Did several runs with the 32-bit version tonight (including a 10 mins race with 20 car grid) and no stutters like in my video, but the performance doesn't seem as smooth as 64-bit when it's working properly (going through corners seems like a little drop in FPS). RTSS doesn't seem to work in the 32-bit version of RaceRoom though, so no frame counter it seems.

    Still need a solution for the 64-bit, running on 32-bit for the forseeable future seems crazy considering my PC specs and the resolution I'm using.
     
  5. Thomas Jansen

    Thomas Jansen Sector3 Developer Beta tester

    Joined:
    Apr 5, 2018
    Ratings:
    +301 / 0
    Fairly certain you just answered your own problem here, this is a very common problem with those programs like afterburner and rivatuner in combination with raceroom 64 bit. turn those off and there should be a big chance it will be fixed
     
  6. mr_belowski

    mr_belowski Well-Known Member Beta tester

    Joined:
    Apr 23, 2015
    Ratings:
    +1,287 / 0
    If you've not already tried it, see if running in boarderless windowed mode helps
     
  7. johndough247

    johndough247 New Member

    Joined:
    Jul 21, 2019
    Ratings:
    +2 / 0
    Don't quite see how that conclusively answered it; I may have had a setting in RTSS wrong that wasn't hooking RaceRoom 32-bit to show the overlay, or it could have just been a bug where the 32-bit version doesn't let it show...which is why I mentioned it. Nevertheless, I am finding threads and videos showing the same issue, so I'm glad to know what it is finally. Is there any effort being made to address this issue? Seems like a pretty big bug to me. Funny thing is, I don't get why all of a sudden this issue surfaces, when I've been playing R3E 64-bit with Afterburner and RTSS running for at least 2 months now in long online races before it froze last week. Was I just extremely lucky before that?

    I don't mind disabling Afterburner and RivaTuner for it (ok I do mind a little)...but I need to set a 141 FPS limit to get the best G-sync performance with no lag. A few questions for you:
    1. Is the issue here about having the programs running simultaneously with raceroom, or is it having the overlay enabled that's causing the issue? (I'd like to still use the FPS limiter from RTSS if possible, since raceroom doesn't have a limiter, which would have been the best option if it was available)
    2. Does raceroom have a built-in FPS counter?
    3. If I use Steam's FPS counter will that also cause an issue?
    4. Is there a recommended Fanatec driver version for Raceroom?
    It's 3AM over here, so I can't test this stuff anytime soon.
     
  8. MattStone

    MattStone Well-Known Member

    Joined:
    Mar 6, 2016
    Ratings:
    +95 / 0
    Clutching at straws here but hear are a few more things you can try
    • Ensure your Video card is in the 16x agp slot and not the 8x slot
    • Is your ram running at the correct speed? some bios need to activate OC mode for ram to use the higher speed ram
    • Unplug all your USB devices (including the wheel) and drive with a keyboard and see if that still happens.
      If that solves the problem start plugging back one device at a time and test (this solved a problem for me as I had a dodgy usb hub)
     
  9. johndough247

    johndough247 New Member

    Joined:
    Jul 21, 2019
    Ratings:
    +2 / 0
    • Video card is in the right spot (16x)
    • Ram is running at stock speed using XMP profile. Speed is 3000 MHz.
    • I’ll try the keyboard test as well, but my wheel and pedals are plugged directly into the USB ports of the motherboard. The G27 shifter is plugged into a hub, but I don’t really use it for anything while driving in R3E.
     
  10. Sebastien Brunier

    Sebastien Brunier Active Member Beta tester

    Joined:
    Dec 17, 2017
    Ratings:
    +35 / 0
    to avoid disabling RTS manually each time, just add the game executable in the Application profile properties and set Application detection level to None

    That way RTS won't hook up on the specified game

    upload_2019-9-3_18-27-11.png
     
  11. Sebastien Brunier

    Sebastien Brunier Active Member Beta tester

    Joined:
    Dec 17, 2017
    Ratings:
    +35 / 0
    I've been using RTS 7.2.2 for few months too but since some Windows updates in August it no longer works (haven't changed driver version, neither RTS version and there wasn't a new R3E build in the mean time either...), and in VR it even crashes the game at startup... Until there is a newer version of RTS to test, I guess the only thing you can do is an application profile in RTS as explained just in previous post.
    You can leave MSI After Burner in the background imo, for my own case only RTS is the culprit.
    I also would like this to be fixed but you should understand that multiple layers are involved : graphic driver, RTS version, OS version, and the game API so it's hard to tell who is to "blame" and we all need to be patient.
     
  12. MattYKee

    MattYKee Member

    Joined:
    May 16, 2019
    Ratings:
    +14 / 0
    Possibly unrelated but i experienced a similar issue in the past i had tracked it down to windows context menu/aero was somehow bugging out the game. Suspiciously whenever a notification message popped. Disabling windows aero+context menu in task bar settings resolved my issue in that case.
     
  13. johndough247

    johndough247 New Member

    Joined:
    Jul 21, 2019
    Ratings:
    +2 / 0
    Thanks for all the replies guys. Disabling RTSS for Raceroom was the answer, runs fine with otterhud web dash no issues. Just ran a 40 min race at Hockenheimring with zero stuttering. What I did test after the race was using steam's FPS counter (You have to enable Steam Overlay in settings if you have it disabled)...that's really all I wanted to monitor in game and it seems to work just fine with Raceroom.

    Thanks again!
     
    • Like Like x 1
  14. Case

    Case Well-Known Member

    Joined:
    Apr 7, 2017
    Ratings:
    +98 / 0
    Just use the 32bit version of Raceroom if that works for you. There's no real reason to run the 64bit anyway.

    Aero (or the equivalent of it) can't really be disabled on Win10.
     
  15. johndough247

    johndough247 New Member

    Joined:
    Jul 21, 2019
    Ratings:
    +2 / 0
    I'm gonna do a comparison sometime this week to see the FPS difference (if any) using Steam FPS counter. I could be wrong but it felt like the 32-bit one, with identical settings, wasn't running as smooth when I first tried it compared to 64-bit.

    Sidenote: Does anyone know how to hack the Steam FPS counter to a custom position? I don't mean the presets they have like top-left, bottom-right, etc. Using Triple Screens it's hard to keep track and stay on the road when it's way in the corners.
     
    • Like Like x 1
  16. Sosruko

    Sosruko Member

    Joined:
    Jan 6, 2018
    Ratings:
    +8 / 0
    If there are many cars at Nordschleife 32bit client crashes quite often for me.
     
  17. Vale

    Vale New Member

    Joined:
    Jul 4, 2019
    Ratings:
    +3 / 0
    I can´t see the FPS indicator in RRE even though I have it activated and it shows in other games. Did you do anything special to have it?
     
  18. johndough247

    johndough247 New Member

    Joined:
    Jul 21, 2019
    Ratings:
    +2 / 0
    Steam's FPS Counter? No nothing special...Enable steam overlay in settings and choose a position for the FPS counter. Check the steam settings for raceroom as well to make sure Steam overlay is enabled for that specific game. I did it with the 64-bit version.
     
  19. Case

    Case Well-Known Member

    Joined:
    Apr 7, 2017
    Ratings:
    +98 / 0
    Really? I've done 99 AI races on the Nordschleife with the 32bit client without issues. But fair enough, there certainly may be situations where the 64bit is helpful. But generally, then tend to be rare, and to be honest, I even got a slightly (very slightly) better performance of the 32bit version during some tests.

    I'm interested what OP will find, if he does compare the two versions on his HW.
     
  20. ravey1981

    ravey1981 Well-Known Member Beta tester

    Joined:
    Apr 15, 2018
    Ratings:
    +280 / 0
    32 bit version can't access more than 4gb of ram. Causes issues on bigger grids.