Problem Mega stuttering!

Discussion in 'Community Support' started by Tuborg, Mar 15, 2019.

  1. Tuborg

    Tuborg Well-Known Member

    Joined:
    Feb 4, 2015
    Ratings:
    +454 / 0
  2. Christian Göpfert

    Christian Göpfert Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,167 / 0
    Haven't had a response yet,
    From what I could see in those logs, it seemed that there was some kind of rendering issue at the time the error occurred, like frames being rendered twice, but that's about all I could find on my own.
    I'll ask around.
     
    Last edited: Mar 22, 2019
  3. Christian Göpfert

    Christian Göpfert Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,167 / 0
    @Tuborg Had some talks and feedback now.

    The dev I was talking to mentioned that with high-end gpus there could be a possible conflict if asynchronous rendering is enabled. So please try opening your game's graphics_options.xml in the game's documents folder (Documents/My Games/Simbin....) and changing line 42 from 'true' to 'false' in order to disable asynchronous rendering.
    15269095d2eea61e45deaa873d791f71.png
    Make sure to save the file after making that change.

    Apart from that you might also wanna check vsync settings and disable in case it's on, or vice versa, just to narrow it down. Related to that, are you maybe using a gsync monitor? If so, what are your exact sync settings?

    One last thing brought up while discussing this was Fanatec drivers, as there was an issue some months ago that could potentially create issues similar to what you're describing. So make sure you're using the very latest Fanatec drivers.

    But, bearing in mind the double rendered frames log message I mentioned above, I also think the asynchronous rendering setting sounds like the most likely culprit at this point, so try disabling that first.

    Hope this helps,
    Best regards

    Christian
     
    • Like Like x 1
    Last edited: Mar 22, 2019
  4. Koly™

    Koly™ Member

    Joined:
    Feb 17, 2018
    Ratings:
    +8 / 0
    i have i7 9700k at 5ghz and 1080ti, and now my fps are stuck at 45.....
    i don't know if it's windows update or Raceroom update, but my game is stuck at 45fps, and few month ago, i had smooth 120fps :)
    It's the only one game with this issue (iRacing, rFactor2, AMS, Dirt rally 2.0....) all others are smooth.
    I cant' play, i have tried to reinstall, remove read only diles, delete documents files, everything, now my fps is at 45fps, like something broken..
    Even i have put' false" at the line 42 of the graphics option....
    Nothing, so i guess raceroom is finished for me.
     
  5. RacingSym

    RacingSym Active Member

    Joined:
    Aug 19, 2017
    Ratings:
    +33 / 0
    i have the prob with some games like this. I have to swith the energy usw to full power in the nvidia driver settings for the game. So create a profil for the game and switch. The next stutter trouble maker Can be the Gaming software from Logitech. I have to close the whole driver.
     
  6. Christian Göpfert

    Christian Göpfert Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,167 / 0
    @Koly™ I would agree with @RacingSym , the game being locked at 45 fps does sound like some kind of driver issue, I don't know of any setting in the game that would cause this. So check the energy option in you gpu driver, maybe sth is limiting it.

    Do you have any additional gpu software installed, like MSI Afterburner or Gforce Experience? There's many reports regarding other games that were locked at 45 fps all of a sudden and uninstalling GE solved it.

    Last but not least there seems to be a new Windows function that might cause such behaviour. To disable it, right-click the game exe (32 or 64 bit, whichever you use, to be sure just do it for both), select properties, go to compatibility tab and disable 'full screen optimisation'. @Tuborg could also give this a try, if the above didn't change anything.
     
    • Like Like x 1
  7. Koly™

    Koly™ Member

    Joined:
    Feb 17, 2018
    Ratings:
    +8 / 0
    Thank you, I have all checked, i don't know, (I have forza 7, pcars 2, pcars 1, dirt 3-4- rally 1.0, 2.0, iRacing, rFactor, AMS, rFactor 2, F12011-2018) and only raceroom has this issue, and few month ago i could play.
    Maybe it's time to pass...i wait the reiza rF2 bundle, sorry have no choice to pass.
    i have 50fps with GPU and CPU at 30%, i know there is something but i don't know what.
     
  8. Case

    Case Well-Known Member

    Joined:
    Apr 7, 2017
    Ratings:
    +88 / 0
    Also, like I've already suggested, if you are running the 64bit version of the game, have you tried the 32bit? That was the workaround for at least some of us suffering from this issue before.
     
    • Like Like x 1
  9. Koly™

    Koly™ Member

    Joined:
    Feb 17, 2018
    Ratings:
    +8 / 0
    i give up, i have all tried, i will focus on rF2 and Reiza.
    Sorry I have no choice
     
  10. Tuborg

    Tuborg Well-Known Member

    Joined:
    Feb 4, 2015
    Ratings:
    +454 / 0
    @Case @Christian Göpfert

    Havent had so much time to test yet but for so long, it has worked with 32-bit (Forgot to test 32 first time you mentioned it Martin...)
    But thanks nevertheless Christian with other sync settings I got better flow in AC :)

    What is the disadvantage of 32, something with memory?
     
    • Like Like x 1
    • Informative Informative x 1
  11. Christian Göpfert

    Christian Göpfert Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,167 / 0
    Yep, the only significant drawback is RAM usage being limited, so you might run into issues if you try running large grids with many different car models on huge tracks like Nordschleife.

    if this is a decent workaround for the time being that's ok, but still it should run on 64 and knowing that there's an issue only when running in 64 should help narrow it down.
     
    • Like Like x 1
    • Agree Agree x 1
  12. Case

    Case Well-Known Member

    Joined:
    Apr 7, 2017
    Ratings:
    +88 / 0
    I honestly never saw any real issue with the 32bit version, but then again I don't really do AI races. It even seems to perform a tiny bit better based on the tests I've done (but it's just a small difference, below 5 % or so). But obviously you want to be running 64bit if possible.

    For me, the requirement to run the 32bit version to not get the random stutter disappeared with one of the game updates a while back.
     
    • Informative Informative x 2
  13. Christian Göpfert

    Christian Göpfert Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,167 / 0
    Was going to ask you if you also still had issues with 64 but that's answered now. Still curious, think this is a lead to follow, looks to me like there's sth specific about 64, maybe in relation to some changes in the very latest drivers, or how they interact with the very latest hardware, seeing as this only seems to affect high-end gpu users.

    I've added this bit of info to my report and will keep an eye on it. Thanks for everybody's patience and feedback.
     
    • Like Like x 2
  14. 2ndLastJedi

    2ndLastJedi Well-Known Member

    Joined:
    Aug 22, 2016
    Ratings:
    +88 / 0
    Well tonight without any updates R3E is back to 25-35 fps again !!!!!!!!!!!! I'm starting to really regret buying more content and have just about thrown the towel in the ring on it ! I tried again to rename the SimBin file so it writes a new one but that didnt work this time ! I don't get it , going from 60fps maxed out in 4k with GPU sitting around 70% to 30 ish fps with GPU @ 100% without any updates from Win 10 or nVidia , nothing has changed other than R3E is at console frame rates !
     
  15. Christian Göpfert

    Christian Göpfert Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,167 / 0
    Can you confirm that this is connected to using the 64bit version? Please try starting the 32bit exe instead and see if it's the same.

    Have you read the above suggestions and tried them, like that full screen optimisation setting, or checking sync settings and energy options in driver/Windows?

    All I can say for certain is that nothing changed on game's side either, so this is really weird. Are you 100% certain there wasn't some Windows change? They do have a tendency to sneak things in or cause changes without notifying users..
     
  16. Andi Goodwin

    Andi Goodwin Moderator Beta tester

    Joined:
    Jan 16, 2015
    Ratings:
    +426 / 0
    im not saying this will work , but can you try using nvidia inspecter ? go into the advanced bit , look for the raceroom settings and select them then apply changes
    you will need to change the app path , do it for both , 32 and 64 bit
    Andi
     
    Last edited: Mar 26, 2019
  17. 2ndLastJedi

    2ndLastJedi Well-Known Member

    Joined:
    Aug 22, 2016
    Ratings:
    +88 / 0
    Last Win 10 update was 16/3 , Win 10 is still in power mode as is nVidia driver (same driver 419.35 as last time i played), I tried both 32 and 64 bit with same outcome , I just tried that nVidia inspector bit and applied to no avail , i've disabled full screen optimisation , not sure what the sync option is ??
    There has definitely been an update to R3E since last play because i have never seen the "we are hiring" screen till tonight.
     
  18. Andi Goodwin

    Andi Goodwin Moderator Beta tester

    Joined:
    Jan 16, 2015
    Ratings:
    +426 / 0
    thats on the web back end , its a web page , you dont get an update to see that , its automatic; nothing is downloaded from steam

    Andi
     
    • Agree Agree x 1
    • Informative Informative x 1
  19. 2ndLastJedi

    2ndLastJedi Well-Known Member

    Joined:
    Aug 22, 2016
    Ratings:
    +88 / 0
    Okay cool , the only thing i can see that might be different on my end is when i look at my nVidia GPU Activity i have windowsinternal.composableshell.experience.textinput.inputapp.exe running , but when i view usage in task manager there is no load on GPU . That windowsinternal.composableshell.experience.textinput.inputapp.exe pops up every now and then , the way i know its running is because my GPU idles at 1531MHz instead of 139MHz and causes idle temps to be 41c instead of 30c!
     
  20. Christian Göpfert

    Christian Göpfert Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,167 / 0
    Google says that's a Windows component related to touch input devices and/or on-screen keyboard.