Resolved Mouse Problem

Discussion in 'Community Support' started by greski, Mar 10, 2017.

  1. greski

    greski New Member

    Joined:
    Mar 10, 2017
    Ratings:
    +0 / 0 / -0
    Just downloaded RaceRoom and I'm having trouble getting started.

    The program seems to think that my wheel and pedals are mice. The mouse constantly moves to the side of the screen. If I disconnect my wheel (Fanatec CSR) and pedals (homemade with DSD controller) then the mouse works, but as soon as I plug either of them back in the problem returns. I've seen others with this problem who solved it by deleting a virtual mouse driver, but I can find no such driver. When the wheel is plugged in, I can affect the movement of the mouse with the mini joystick on the wheel so I know its looking at the wheel as a mouse device. Any help would be appreciated.
     
  2. Henri Puustinen

    Henri Puustinen Well-Known Member

    Joined:
    Oct 23, 2016
    Ratings:
    +100 / 0 / -0
    On Windows 10 (similar on Win 7):

    - Push the Windows Start Icon.
    - In the search bar write "devmgmt" (or access Device Manager through PC Settings).
    - In the top menu bar, click "View" and then "Show hidden devices".
    - Then the "Fanatec Gaming Devices" should show in the list, if not already showing.
    - Left click on "Fanatec Gaming Devices".
    - Find the "Fanatec Wheel virtual mouse/keyboard".
    - Right click, choose "disable".
     
    • Like Like x 1
  3. greski

    greski New Member

    Joined:
    Mar 10, 2017
    Ratings:
    +0 / 0 / -0
    Yes, that was it. Thank you very much.
     
  4. greski

    greski New Member

    Joined:
    Mar 10, 2017
    Ratings:
    +0 / 0 / -0
    After Henri posted his solution to my problem, I received this response from Tech Support. It's a different approach to solving the mouse problem.
    The mouse cursor in the menus can also be controlled by other controllers such as gamepads and steering wheels. If one such device is constantly giving input, the mouse cursor will constantly move.
    If you have a device which is designed to give constant input you can instead turn off the ability to control the mouse cursor with other devices.

    To do this:

    There is a file in the game's documents folder called menu_controller_options.xml. In this document you can disable the menu support for controllers which allows gamepads/Steering wheels etc to control the mouse cursor.

    To disable it:
    · Find the document in the following location: \Documents\My Games\SimBin\RaceRoom Racing Experience\UserData\
    · Find the first line that reads <custom type="bool">true</custom>
    · Change it to <custom type="bool">false</custom>
    · Save the changes
    It should now be disabled, and if that was the cause behind the drifting cursor then it should be solved.
     
    • Informative Informative x 2
  5. fl0wf1r3

    fl0wf1r3 Well-Known Member

    Joined:
    Apr 24, 2016
    Ratings:
    +215 / 0 / -0
    you made my day ! htx
     
  6. fl0wf1r3

    fl0wf1r3 Well-Known Member

    Joined:
    Apr 24, 2016
    Ratings:
    +215 / 0 / -0