Known Issue Multiplayer: Flickering, disappearing cars issue

Discussion in 'Community Support' started by Sonat Ozturk, Dec 1, 2016.

  1. Sonat Ozturk

    Sonat Ozturk Well-Known Member

    Joined:
    Jan 13, 2015
    Ratings:
    +2,009 / 0
    Update:

    Hey guys we are testing some fixes on a beta branch. If you are one of the players who are known to turn invisible a lot during Multiplayer you can follow the steps in the link below to get the game with our fixes and join the mentioned server where we check and monitor things.

    This is an ongoing progress and some fixes already showed that the issue is still present.

    https://forum.sector3studios.com/in...isappearing-cars-issue.6773/page-2#post-97145


    --------------------
    Hi guys,

    As most of you know, the patch introduced severe issues in Multiplayer that cause opponents to disappear and flicker which leads to accidents and unplayable sessions. There are other problems such as immediate disqualification and players entering race session without the garage menu but we'll focus on the disappearing car issue in this thread.

    We are continuing our investigation and have some potential leads but we can always use more information from players to help us narrow down the problem(s). If the potential fix doesn't prove to solve the problem we will look into reverting certain things altogether to stabilise things.

    Here are some questions we hope you guys can answer. Players who disappear may not realise the issue themselves so hopefully some of the close-knit communities that know their opponents can help.

    • Do the disappearing cars get normal and more stable after a while e.g. after a minute?
    • Does the issue occur on a server with just a few players?
    • Are the players that tend to disappear often or always the same ones?
    • Are the players that tend to disappear using Windows 7?
    • If using Windows 7, do you have Windows Firewall turned on? Does the issue continue to occur if you turn Firewall off?

    There might be more questions to ask based on the answers and our findings. Let's try to stay on topic and use this thread to help us get to the bottom of the issue.
     
    • Like Like x 12
    • Useful Useful x 2
    • Dislike Dislike x 1
    Last edited: Dec 2, 2016
  2. BullKopp

    BullKopp New Member

    Joined:
    Jul 7, 2016
    Ratings:
    +4 / 0
    • No.
    • The issue occurs on every Server, that have more than 2 cars.
    • Yes, they´re often the same ones. In my case, i´m often invisible and jumping around like a Ping-Pong Ball.
    • I´m using Windows 7. I don´t know, what the others are using.
    • Yes, my Firewall is turned on. But the Problem is still alive when i turned the Firewall off.
     
  3. R. Winkler

    R. Winkler Well-Known Member

    Joined:
    Apr 2, 2015
    Ratings:
    +50 / 0
    First of all i am not having issues. I've never heard that my car is disappearing. But I still want to picture one of our last races at virtualracing.org:

    • Do the disappearing cars get normal and more stable after a while e.g. after a minute?
    Some do, others do not​
    • Does the issue occur on a server with just a few players?
    Yes, we had a race with about 8-10 players, some of them left but the problem still existed​
    • Are the players that tend to disappear are often or always the same ones?
    Yes there where players who disappeared often and some who didn't disappear the whole time​
    • Are the players that tend to disappear using Windows 7?
    I am using Windows 7 but I don't have any issues​
    • If using Windows 7, do you have Windows Firewall turned on? Does the issue continue to occur if you turn Firewall off?
    Firewall is enabled.
    When the connection switched to P2P disappearing players didn't disappear anymore. When switching back the ping went over 1000 and they disappeared again.
     
    Last edited: Dec 1, 2016
  4. Sonat Ozturk

    Sonat Ozturk Well-Known Member

    Joined:
    Jan 13, 2015
    Ratings:
    +2,009 / 0
    Thank you @BullKopp

    So far we have quite a few players who disappear confirming that they're using Windows 7. Let's see if someone with another OS also disappears that can let us know here. But so far a Windows 7 specific issue seems likely.
     
  5. wozdecky

    wozdecky Active Member

    Joined:
    Mar 9, 2016
    Ratings:
    +41 / 0
    My experience is that all this issues are random, so it was happen that same car dissapear a few times, or more cars dissapear randomly during race and shows in front of me.
    My firewall n win 7 is off.
     
  6. Tuborg

    Tuborg Well-Known Member

    Joined:
    Feb 4, 2015
    Ratings:
    +454 / 0
    I using Windows 7 and have the firewall turned on. Maybe you could open your "Fun testing"?
     
  7. Stede

    Stede Active Member

    Joined:
    Jan 4, 2016
    Ratings:
    +30 / 0
    According to R.Winkler...
    I am one of the players on virtualracing.org-servers, who disappear very often. This happend to me serveral times since the patch. Before the patch I was visible all the time. I didn't change anything at my PC after the patch.

    I'm using Windows 10, 64bit (1607). So it is not a Windows 7 specific issue.
     
  8. Vojvoda

    Vojvoda Well-Known Member

    Joined:
    Jan 31, 2015
    Ratings:
    +143 / 0
    • No.
    • More than 2 players.
    • Randomly
    • No, W7 & W10.
    • Firewall disabled.
    In my experience this issue only occurs in race session, practice or qualy works fine.
     
    Last edited: Dec 1, 2016
  9. D.Boon

    D.Boon Well-Known Member

    Joined:
    Feb 19, 2015
    Ratings:
    +385 / 0
    Is that a technical preview, of windows 10?
     
    • Funny Funny x 1
  10. pargiNOS

    pargiNOS Well-Known Member

    Joined:
    Mar 31, 2015
    Ratings:
    +46 / 0

    • Thx for letting us now that you looking in to it.


    • Do the disappearing cars get normal and more stable after a while e.g. after a minute?
      It helps but not for every flickering car.
    • Does the issue occur on a server with just a few players?
      Anything with more than 3 players
    • Are the players that tend to disappear often or always the same ones?
      Most of the times are the same, but it happened to most of us.
    • Are the players that tend to disappear using Windows 7?
      I was playing with w7, after a crash i switch to w10, with the same results.
    • If using Windows 7, do you have Windows Firewall turned on? Does the issue continue to occur if you turn Firewall off?
      It doesn't matter i tried both ways
     
    Last edited: Dec 1, 2016
  11. Alex Stiene

    Alex Stiene New Member

    Joined:
    Jun 7, 2016
    Ratings:
    +3 / 0
    I race together with R. Winkler in the WTCC league and i have noticed, that nearly always the same drivers disappear. That the "ghostdrivers" get stable after a while, i didn't observe.

    After the big patch the did a test-race on NOS (24h). After the first race-minutes we know the problem was still present and after the first round we standstill together on track, several minutes, and discussed. Even there, the disappearing cars stay invisible the most of the time, but are noted correctly in the time-table.
     
  12. Stede

    Stede Active Member

    Joined:
    Jan 4, 2016
    Ratings:
    +30 / 0
    No, it's the anniversary update, wich was deployed in July 2016...thats why Version 1607. On Windows 10 you can see the release of the major updates on the number of the version.
     
  13. OverTheClock

    OverTheClock Member

    Joined:
    Sep 5, 2016
    Ratings:
    +13 / 0
    Last week on sunday our league have tried to complete a official race without success.

    In generally:
    Disappearing cars resulting in crashes and a permanent blue flag warning on some players behind the field. They have to drive each round in the box.

    See: strafe.jpg

    But all test races with fewer palyers before (~3-8 players), where without problems.

    I think this is random. After 30min Race the cars still disappers.

    Hard to say. It looks like the problems are more with more players.

    Most times the same.

    Dont know at the moment which version the other players have. I will ask.
    I use Win 10 with Trend Micro Firewall
     
    Last edited: Dec 1, 2016
  14. RacerMark

    RacerMark Member

    Joined:
    Jul 20, 2016
    Ratings:
    +6 / 0
    I tried a server a couple of days back, myself and my friend in the race could not see each other at all. Other cars joined (around 4) and they were all visible to us both. Sorry I cant remember the server name as I don't venture to mp much..... yet. We are both on win10 1607 .447 latest update (KB3200970) with n-vidia gpu's.
     
  15. LTC Mike

    LTC Mike Active Member

    Joined:
    Mar 29, 2015
    Ratings:
    +41 / 0
    • Do the disappearing cars get normal and more stable after a while e.g. after a minute?

      as we shut down our community R3E dedi, because every race we did after the big november patch was a mess, I have not so much data, but the few races we tried the issue was always: training and qualification ran pretty normal without issues but as soon as the session was switched to race one or all cars were invisible to each other but the timings bar showed some erratic jumping positions and numbers; in one race at least one car was gone at the start and then appeared suddenly in front of us all after about half of the first lap.
    • Does the issue occur on a server with just a few players?
      it happened with just three and as well with 8..10 players
    • Are the players that tend to disappear often or always the same ones?
      in the few public hosted test races we did it was sometimes the whole field that became invisible and sometimes just one or two, so nothing I would rate as symptomatic
    • Are the players that tend to disappear using Windows 7?
      no, it happened with Win7 as well as on Win 10 systems
    • If using Windows 7, do you have Windows Firewall turned on? Does the issue continue to occur if you turn Firewall off?
      I am not using Windows7 firewall, but I can't speak for the others
    Just to ad: thanks for adressing this issues in a more scientific approach now. Maybe I can convince some of my communitiy to do some short test events in R3E at the upcoming weekend to check a little deeper into the symptoms.
     
    • Like Like x 1
  16. axxis278

    axxis278 Well-Known Member

    Joined:
    Jan 29, 2015
    Ratings:
    +46 / 0
    Last wednesday during a race, I was following the same player for about 10 laps, and he only had this issue when we were in a group of 4 cars, after passing 2 cars he stopped disappearing during 3-4 laps where there was only him and I. Then back in a group of 4 cars and he was disappearing again, his car was like coming out of the ground. We passed the cars, and he stopped disapearing again.
    Forgot the detail, he was unvisible on the starting grid, confirmed by other players.
    Hope this can help.
     
    • Love it! Love it! x 1
    Last edited: Dec 1, 2016
  17. GooseCreature

    GooseCreature Well-Known Member

    Joined:
    May 30, 2015
    Ratings:
    +581 / 0
    I can't answer most of the questions as I really don't pay enough attention to which server I'm in etc but it's usually the same drivers flickering, on some servers it improves on others it declines, I sometimes appear in pits, sometimes in menu and occasionally on grid with not enough fuel! :(
    I'm using a pucker copy of win 10 ultimate through a BitDefender Firewall.
    Would it not be an idea to set up some test servers so we can all try to race while your systems analysts monitor the chaos or not? May at least give an idea to if it's a geographical, OS, Browser or other issue, especially if there was a dedicated thread so those with issues could list their hardware/software/ISP/Prefered choice of biscuit to dunk?
     
    • Like Like x 2
  18. Sonat Ozturk

    Sonat Ozturk Well-Known Member

    Joined:
    Jan 13, 2015
    Ratings:
    +2,009 / 0
    Yeah we might get to that. Currently we're testing some things with testers that are known to disappear so keeping it isolated to prove/disprove some things before expanding the tests.
     
    • Like Like x 4
    • Informative Informative x 1
  19. OverTheClock

    OverTheClock Member

    Joined:
    Sep 5, 2016
    Ratings:
    +13 / 0
    A question to the R3E developers.
    If i am not wrong, there are a Browser Engine running in the background of the game?
    Is this the Chronium Engine?
    I ask, because it feels like the last updates of the Chrome Browser where not positive for the performance in all. An maybe Chronium is connected to the running Chrome services in the background?
    Have no idea ... it's just a guess.
     
  20. GooseCreature

    GooseCreature Well-Known Member

    Joined:
    May 30, 2015
    Ratings:
    +581 / 0
    Well I'm damned sure there are plenty of us willing to help stamp on the bug, just say the word!
     
    • Agree Agree x 4