Known Issue Multiplayer: Flickering, disappearing cars issue

Discussion in 'Community Support' started by Sonat Ozturk, Dec 1, 2016.

  1. OverTheClock

    OverTheClock Member

    Joined:
    Sep 5, 2016
    Ratings:
    +13 / 0
    Here my Logs.
    Only issues with kL1ck and wood on this test. For example by kL1ck, the ping jumps from 25 to 2000+ and car disappears. I have talked with him, but all his settings should be ok. He have a fresh installed windows also. On games like csgo etc he has an stable ping.
     

    Attached Files:

    Last edited: Dec 1, 2016
  2. David Slute

    David Slute Well-Known Member

    Joined:
    Feb 7, 2015
    Ratings:
    +73 / 0
    • Do the disappearing cars get normal and more stable after a while e.g. after a minute? yes around the 2nd to 3rd lap
    • Does the issue occur on a server with just a few players? yes
    • Are the players that tend to disappear often or always the same ones? most of the time
    • Are the players that tend to disappear using Windows 7? not sure
    • If using Windows 7, do you have Windows Firewall turned on? Does the issue continue to occur if you turn Firewall off? no
     

    Attached Files:

  3. LTC Mike

    LTC Mike Active Member

    Joined:
    Mar 29, 2015
    Ratings:
    +41 / 0
    Hi Sonat, I did as adviced to join the beta test, but as soon as I start R3E I get a "Content server error 24002"
    [​IMG]

    Edit / Update: after closing Steam, doing a Steam check of R3E I could start it...
     
    Last edited: Dec 1, 2016
  4. OverTheClock

    OverTheClock Member

    Joined:
    Sep 5, 2016
    Ratings:
    +13 / 0
    Here another Logs.
    Xen Tran and I without issues. kL1ck and Wood disappearing.
     

    Attached Files:

  5. Xentran

    Xentran New Member

    Joined:
    Jun 8, 2015
    Ratings:
    +1 / 0
    Here are my Logs from the Beta version. Allways the same players are flickering and porting around the track.
     

    Attached Files:

  6. sbtm

    sbtm Well-Known Member

    Joined:
    Mar 29, 2016
    Ratings:
    +521 / 0
    I had an online race at hungaroring dtm2016. I was the one that was flickering or invisible because everybody bumped into me at race start. After some laps it seemed to be normalised again. It was the first time I was invisible I guess.
    I could post the replay when I'm home. also I think that there were at least one other invisible car

    It was an official [RR] server with ehm... 18 players at the beginning i think.

    I use windows 10, with firewall, but r3e is on the white list.
     
  7. Woodie von Wood

    Woodie von Wood Member

    Joined:
    Nov 28, 2016
    Ratings:
    +9 / 0
    Here again new data
     

    Attached Files:

  8. BullKopp

    BullKopp New Member

    Joined:
    Jul 7, 2016
    Ratings:
    +4 / 0
    New logs.
     

    Attached Files:

  9. Xon3

    Xon3 Well-Known Member

    Joined:
    Nov 19, 2016
    Ratings:
    +168 / 0
    Do the disappearing cars get normal and more stable after a while e.g. after a minute?
    - Yes and no. Sometimes all oponents just disapear for like 5 seconds then come back and look stable. In those "5 seconds" (or so) the cars apear on the minimap but not on track. generally after a lap it gets more stable. My oponents get super high ping though, but this could be the fact that players dont live next to me so ... because when i played a friend of mine hes ping was fine.
    Also i think i may be flickering cause people bump into me way more often that they bump into each other. Also sometimes they dont even react to hitting me and nothing happens to their cars.

    Does the issue occur on a server with just a few players?
    - On few player races the issue exists but goes away very quickly. On large servers .... oh boy ...

    Are the players that tend to disappear often or always the same ones?
    - Its all or nothing most of the times. Then there are specific cases with bad ping racers .... Sometimes half way through the race all is good then all hell breaks loose then goes back to normal.

    Are the players that tend to disappear using Windows 7?
    - No idea ... oh me ?! I use Windows 10. I also have the game on windows 7. It seems to run better there.
    The info i have from internet testing seems to be normal (around 2ms ping, 100down and 25up) and i play other online games and they work fine. I also have no firewall and all ports from my router are open when i play R3E.

    Hope this helps

    Edit: something i read and noticed is that this problems are amplified when near other group os cars.
     
    Last edited: Dec 2, 2016
  10. Paul Darke

    Paul Darke Moderator Beta tester

    Joined:
    Jan 29, 2015
    Ratings:
    +193 / 0
    I have logs for a race where I was the only person taking part. These may be totally pointless but I can post them if you think they may be any use/help. Not sure if it would give you some type of base line?
     
  11. LTC Mike

    LTC Mike Active Member

    Joined:
    Mar 29, 2015
    Ratings:
    +41 / 0
    And some data from my tests today - should be comparable to the latest ones from @Woodie von Wood as we were driving some sessions together between approx. 22:30 and 22:45 (CET)

    And this is a short recording of the last session - I recorded starting with Training - Race session starts at 6:00:


    (sorry for the Community-Overlay - had forgotten to disable this in OBS).
    The race before it was just Woodie and me and everything was fine. As soon as there are 3+ drivers it seems that some cars get invisible (Woodie in that case to me), me myself was having pings over 1200 as the others told me and Yanni got greyed out for me.

    Remark: I am on a German Telekom T-DSL 50.000 VDSL line with Upload of 10.000 via a Fritzbox 7490 Router and never had in any other MP race pings beyond 50 on european servers. On the German hosted Rackservice root server that my community uses I rather have pings over 30 even when I am streaming or recording in parallel.

    Don't know if its for any use, but here are some screenshots from the connection data that the Fritzbox recorded:
    [​IMG]
    [​IMG]
     

    Attached Files:

    • Informative Informative x 1
  12. elkingdu50

    elkingdu50 Well-Known Member

    Joined:
    Aug 30, 2015
    Ratings:
    +77 / 0
    ping zero is officialy back :D
     
  13. V8Olli

    V8Olli Active Member

    Joined:
    Feb 5, 2016
    Ratings:
    +35 / 0
    Here are some observations we made in our last league races:
    • Do the disappearing cars get normal and more stable after a while e.g. after a minute?
    It depends. Some drivers were permanently invisible in the first race minutes. This condition improved to a "only part-time invisible" state after one or two laps, but it was still impossible to race with them.
    Others were permanently visible at the start and only began to disappear after a while, ususally when they became part of a larger group of drivers.
    • Does the issue occur on a server with just a few players?
    Yes. The player count seems to have no influence.
    • Are the players that tend to disappear often or always the same ones?
    Definitely. Some of our drivers (I'd say around 20%) have this problem in every race they participate in, many others are never invisible and have rock-stable pings. There are also a few pilots who are only sporadically invisible.
    • Are the players that tend to disappear using Windows 7?
    I can't say for sure if all of them use Windows 7, but many of them do. However, if I have read this thread correctly this has already been ruled out as a potential cause.
    • If using Windows 7, do you have Windows Firewall turned on? Does the issue continue to occur if you turn Firewall off?
    At least a few drivers have the Windows Firewall turned off in favor of third-party Antivirus / Firewall software.

    Nothing new so far, I'm afraid. But I also wanted to include some other observations we made:

    (1) Most of the time, the cars only disappear when they are in p2p-range. The closer you get to a driver with an unstable connection, the greater the percentage of time where he is invisible.

    (2) When the affected drivers disappear, it usually happens without any warning out of a condition where they have relatively good pings. When they become visible again after a few seconds, their ping is extremely high and then quickly drops down to normal levels - before they disappear again.

    (3) In our league, we have a few family teams. In one case, we have two drivers, living in the same home, using the same internet connection (Kabel Deutschland 100000) and playing over the same router (D-Link DIR-615, IPV6 not Activated). They also have nearly identical hardware configurations (both use the same mainboard, cpu, RAM, graphics card etc.) and use the same operating system (Windows 7). Both of them have the Windows-Firewall turned off and use Symantec's Norton instead. Before the last patch, both of them never had problems with their pings and were always visible to everyone. Because they share one router, they also enjoyed extremely low p2p-pings (around 2 ms) when driving against each other. Since the last patch though, one of them remains always visible to everyone and still has stable pings, while the other one has become one of the unlucky guys who disappears in almost every race he participates in. When he disappears, he is also invisible to his teammate. Additionally, the p2p-ping between these two drivers has worsened significantly, to around 20-40 ms.

    While this is very weird and - in our opinion - eliminates a lot of potential causes it might also provide a chance to narrow the error down. What do you devs think? There has to be a subtle difference between the two PC Configurations which is responsible for the problem, or not? If you can tell me what to look for, I'll do my best to gather the required informations.

    Keep up your good work!

    Olli
     
    • Useful Useful x 2
    • Like Like x 1
    • Agree Agree x 1
  14. Rui Paiva

    Rui Paiva Member

    Joined:
    Aug 20, 2016
    Ratings:
    +18 / 0
    Guys, maybe from now on stick this post only to information about the test server in BETA, so they can have the more information possible about the problems.
     
    • Agree Agree x 2
  15. Stede

    Stede Active Member

    Joined:
    Jan 4, 2016
    Ratings:
    +30 / 0
    Unfortunatly I had no time to test yesterday.
    Today I could test from 08:00 p.m. (CET), so please keep us informed, if you plan to start a new Beta-Test.
     
  16. ufo4u

    ufo4u Member

    Joined:
    Nov 18, 2016
    Ratings:
    +17 / 0
    Hi everyone,
    in order to get rid of the known problems Ive got some more questions!

    1st: What System-Browser are in use (Firefox,Chrome,Opera,etc,)?

    2nd: Is Steam overlay enabled or disabled?

    3rd: Is Steam autoupdater (steam itself,not the games) enabled or disabled?


    As n old (Ex) It-Support fart Ive learned to look in all directions to solve Problems that occur out of a sudden!
    Its surely related to the November Patch,but to rule out something you have to think different!
    Just food for thought!
     
    • Like Like x 1
    • Disagree Disagree x 1
  17. Xon3

    Xon3 Well-Known Member

    Joined:
    Nov 19, 2016
    Ratings:
    +168 / 0
    Not sure if any changes have been made but it seems that everything is more stable. There isnt a server with many players so we will have to wait to see.

    Edit:
    Did a 10 car race in an australian server (im in europe) and it seemed way more stable in fact.
     
    Last edited: Dec 2, 2016
  18. Dreamliner

    Dreamliner Active Member

    Joined:
    May 14, 2015
    Ratings:
    +29 / 0
    Hello,
    - in my case the car stays unstable over the whole race ( the same in Qualiy and Training )
    - it doesn´t matter how much players are in the race so far ( my observation )
    - in my case i´m always one of the disappearing players ( no issues before the patch )
    - i´m using Windows 7 64 bit
    - My Windows Firewall is turned off
    - Switched my Fritzbox Router to IPV6 but no change at all

    Thanks Sector 3 for checking the issues which are present at the moment.
    Hopefully you get it done as quick as possible.

    All the best in the meantime
     
  19. Woodie von Wood

    Woodie von Wood Member

    Joined:
    Nov 28, 2016
    Ratings:
    +9 / 0
    Hi Guys,
    What does it look like there is already something new in this matter? I hope the log files could help you for a new round of testing, I am gladly willing to just say modest.
    Greeting Woodie
    This is all translated by Google who finds errors may keep them XD
     
  20. Sonat Ozturk

    Sonat Ozturk Well-Known Member

    Joined:
    Jan 13, 2015
    Ratings:
    +2,009 / 0
    We are continuing to revert and fix things and will update the beta branch again for further tests.

    We would like to check some things out in detail with one of the players who are disappearing. If you are around to do some tests with us let me know here please. The server is quite empty at the moment as it's early in the day but maybe some of you are available.