Known Issue Multiplayer: Flickering, disappearing cars issue

Discussion in 'Community Support' started by Sonat Ozturk, Dec 1, 2016.

  1. Woodie von Wood

    Woodie von Wood Member

    Joined:
    Nov 28, 2016
    Ratings:
    +9 / 0 / -0
    Since I have the problems I am willing to continue to test.
     
    • Like Like x 1
  2. kL1ck

    kL1ck Member

    Joined:
    Oct 4, 2016
    Ratings:
    +18 / 0 / -0
    files from 13:58pm
     

    Attached Files:

    Last edited: Dec 2, 2016
  3. pargiNOS

    pargiNOS Well-Known Member

    Joined:
    Mar 31, 2015
    Ratings:
    +46 / 0 / -0
    I 'll be home around 15:30 GMT let me know if you want me to join you.

    Last night at a club race, for the 2 first laps my car was possessed :D and going like crazy driving round and round and going off track, at least thats what others was seeing, at my end i was racing normally. After the 2 first laps everything was normal.
    I attach the log files from that race.
     

    Attached Files:

  4. Timo Heyden

    Timo Heyden Well-Known Member

    Joined:
    Jul 1, 2016
    Ratings:
    +66 / 0 / -0
    I would like to test the BETA tonight when the server is online.
     
  5. Woodie von Wood

    Woodie von Wood Member

    Joined:
    Nov 28, 2016
    Ratings:
    +9 / 0 / -0
    First race immediately disqualified and then the game crashed. I'll send you the report.
     

    Attached Files:

  6. Vojvoda

    Vojvoda Well-Known Member

    Joined:
    Jan 31, 2015
    Ratings:
    +145 / 0 / -0
    Another test right now, my car blinked and the ping ranged between 30 and 600.
    I can make some test from 16:00 to 17:00
     

    Attached Files:

  7. OverTheClock

    OverTheClock Member

    Joined:
    Sep 5, 2016
    Ratings:
    +13 / 0 / -0
    Logs from 13:58pm
     

    Attached Files:

  8. Sonat Ozturk

    Sonat Ozturk Well-Known Member

    Joined:
    Jan 13, 2015
    Ratings:
    +2,010 / 0 / -0
    We now have a 100% reproducible scenario so we changed the password to isolate it to those players for a while.

    Some info.
    It is reproducible between just 2 players. It is always the same players.

    The key part is 2 players with something specific getting close to each other. The issue occurs when player 1 and player 2 get within p2p range. Then one of them start spiking up in latency and disappear/flicker for everyone. The moment they get out of each others p2p range things go back to normal for the player.

    Odd part is that it's not just any 2 players, they have something in particular that causes this issue.

    Just thought i'd give an update. We will keep you guys posted.
     
    • Like Like x 10
    • Informative Informative x 2
  9. BullKopp

    BullKopp New Member

    Joined:
    Jul 7, 2016
    Ratings:
    +4 / 0 / -0
    I join the Server after work. At the earliest around 8 pm.
     
  10. Woodie von Wood

    Woodie von Wood Member

    Joined:
    Nov 28, 2016
    Ratings:
    +9 / 0 / -0
    Oh man up before the update it ran so well. I just want to drive nice races. I really hope you can do it again.
     
  11. ufo4u

    ufo4u Member

    Joined:
    Nov 18, 2016
    Ratings:
    +17 / 0 / -0
    Hi,
    if you need some more players/testers I could give it a go now!
     
    Last edited: Dec 2, 2016
  12. Sonat Ozturk

    Sonat Ozturk Well-Known Member

    Joined:
    Jan 13, 2015
    Ratings:
    +2,010 / 0 / -0
    Hi again,

    We will disable p2p altogether for the time being as the problem is with that.

    After some sanity checks we will patch the game for everyone within a few hours. Breaking our own rules by pushing on a Friday but this is ruining the driving experience so we'll go for it.

    Keep in mind though gents there are some other known issues so you still might experience DQ's and reverse grid issues. Those we'll solve next week with another hotfix patch. Workaround to avoid those problems for now is to turn them off. Reverse grid off and flag rules off are the only workarounds for the time being.

    So no testing needed for the moment. I'd like to thank everyone who participated and provided information. While we haven't really fixed the issue yet we now know that it is isolated to p2p between certain clients. But we can disable it and investigate further now.
     
    • Like Like x 11
    • Winner Winner x 6
    • Informative Informative x 2
    • Wonderful Wonderful x 1
  13. fischhaltefolie

    fischhaltefolie Well-Known Member

    Joined:
    Feb 12, 2015
    Ratings:
    +931 / 0 / -0
    Though I don't race mp and therefore not being affected by these bugs I want to give kudos to the devs for listening to the concerns of the community and forcing efforts to eliminate them.
    Gives a good feeling.:D
    [​IMG]
     
  14. Sonat Ozturk

    Sonat Ozturk Well-Known Member

    Joined:
    Jan 13, 2015
    Ratings:
    +2,010 / 0 / -0
    So we have now pushed the update.

    https://forum.sector3studios.com/index.php?threads/02-12-2016-raceroom-has-been-updated.6781/

    To those of you who switched to the beta branch you now have an out of date build and should switch back to the default. To go back to regular game you have to opt out by choosing "NONE - Opt out of all beta programs" from Properties.

    Right click on RaceRoom Racing Experience and click Properties in your Steam Library.
    - Select the "BETAS" tab.
    - Select "NONE - Opt out of all beta programs" from the dropdown and close the properties window.
     
    • Like Like x 8
    • Wonderful Wonderful x 1
  15. Woodie von Wood

    Woodie von Wood Member

    Joined:
    Nov 28, 2016
    Ratings:
    +9 / 0 / -0
    The patch works. A thousand thanks to the team finally you can race again.
     
    • Like Like x 5
  16. kL1ck

    kL1ck Member

    Joined:
    Oct 4, 2016
    Ratings:
    +18 / 0 / -0
    nice work !!!
    thanks
     
  17. Stede

    Stede Active Member

    Joined:
    Jan 4, 2016
    Ratings:
    +30 / 0 / -0
    Invisible cars are history with the hotfix, thanks for that.
    But there are some new bugs:
    1. You get no drive-through-penalty, when you get to fast into the box (maybe because of disabled flag-rules).
    2. If you disable tyre-change, you get even new tyres at pit stop

    I personaly had 6 big freezes after pit-stop of nearly 5 sec. ... after that all was fine again. But this could be on my side, because all others hadn't this issue.

    We were 15 drivers with GT3 on Mid-Ohio at virtualracing.org #1

    Logs attached..
     

    Attached Files:

  18. Christoph

    Christoph Well-Known Member

    Joined:
    Sep 26, 2016
    Ratings:
    +83 / 0 / -0
    Hi I ran today a few online races and I have the flicker still?
    Have the other driver here also the problem ? Or I am standing alone with the problem here?
     
  19. sbtm

    sbtm Well-Known Member

    Joined:
    Mar 29, 2016
    Ratings:
    +575 / 0 / -0
    no flickering at all. made about 15 online races the past few days
     
    • Agree Agree x 3
  20. Christoph

    Christoph Well-Known Member

    Joined:
    Sep 26, 2016
    Ratings:
    +83 / 0 / -0
    @sbtm,
    thanks for the fast feedback. Someone has an idea what I must make?
    Otherwise my system runs very well and stable. Or is R3E still working on the topic?