Resolved No 3D render in game, only control interface and driver names are visible

Discussion in 'Community Support' started by aSab, Dec 2, 2019.

  1. aSab

    aSab New Member

    Joined:
    Apr 14, 2018
    Ratings:
    +1 / 0 / -0
    To be honest I'm fed up with this crazy fail of R3E. I'm fighting this ever since I've built my new gaming rig. I've got this strange no-render-anything fail only in R3E.
    I've tried to set different resolution in game, change FXAA, AA settings, V-SYNC, deleted shadercache, graphicsoptions.xml, you name it, all to no avail. Heck, the game was freshly installed yesterday.
    Please solve this, I obviously can't play like this.
    Short vids:
     
    Last edited: Dec 4, 2019 at 8:01 PM
  2. Andi Goodwin

    Andi Goodwin Moderator Beta tester

    Joined:
    Jan 16, 2015
    Ratings:
    +460 / 0 / -0
    can you add your full system specs and the driver for the gpu please

    Andi
     
  3. aSab

    aSab New Member

    Joined:
    Apr 14, 2018
    Ratings:
    +1 / 0 / -0
    Hello Andi,

    thanks for the quick reply.

    I was fighting this issue already some months ago when I installed my 5700 XT, but then I solved it - yet I wasn't sure back then what exactly solved it.

    Now I took the time and experimented more and found the solution, I admit I was a crybaby cause this issue p*****d me off.

    tldr:
    Whenever there is no specific gaming profile set for RRRE64 within Adrenalin and 2-8x AA is set in the game, it won't render.
    If there is no specific gaming profile set for RRRE64 within Adrenalin but no AA is set in the game, it will render.

    Whenever there is a specific gaming profile set for RRRE64 within Adrenalin, no matter what AA is set in the game or in the settings for the game within Catalyst, it will render.
    2019-12-03 07_39_46-2019-12-03 07_35_48-RADEON SETTINGS2.png

    No other setting was found to have an effect, e.g. what Multisampling should be used, whether or not the app AA settings are used or they are enhanced or overridden etc etc. BTW, the best AA is achieved with the ingame settings 8x AA, or so it seems for now.
    tldr end

    How to create that specific profile for RRRE64? The simplest way is to open the Radeon Overlay within a practice session, fiddle with some settings no matter what, close the Radeon Overlay, quit the game and the Radeon profile will be ready waiting for you.

    the config:
    MSI B450 Gaming Plus Max
    Ryzen 5 3600 (not OCd)
    2x8 GB RAM
    GBT 5700 XT GAMING OC (original FW), not OCd (that's a funny controversy regarding the name of the card, isn't it)
    Plantronics HD1 USB soundcard (I've had this issue with the int. Realtek soundcard as well) - this is a Cmedia chip btw.
    Win10 1903 18362.476
    Radeon 19.11.2 (I've had this issue with previous Radeon drivers as well)
    TM TX Leather Edition, drivers: 11/17/2017,02.10.09.00
     
    • Like Like x 1
    • Informative Informative x 1
    Last edited: Dec 3, 2019
  4. Christian Göpfert

    Christian Göpfert Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,243 / 0 / -0
    Thanks for reporting back your solution.

    What's curious to me is that the Radeon suit doesn't seem to create a profile for RR out of the box. On my end, with a meager RX 570 and latest recommended non-beta driver it will add a general profile for any game it detects.

    If you don't mind expanding a little, where have you installed RR and/or Steam? Maybe there's some connection between the installation dir and whether the Radeon software detects a game automatically.
     
  5. aSab

    aSab New Member

    Joined:
    Apr 14, 2018
    Ratings:
    +1 / 0 / -0
    Hi Christian,

    uhm, I have many drives and many partitions. W10 and the Steam library is on the same ssd, but on different partitions: C: and N:\Steam\
    R3E is installed in this folder, the usual: N:\Steam\Steamapps\common\raceroom racing experience\

    The "My Games" folder is on another drive: S:\My Docus\My Games\

    I think that your suspicion is going in the right direction, since Catalyst doesn't usually create gaming profiles for my games on its own, I usually have to use the Overlay to get such a profile generated - this might be caused by the fact that my games are never installed on C:, but rather on N: or maybe on another drive on F:

    Still the root cause lies beneath the question: why the game / the drivers need that extra profile to render 3D.