Question Nvidia drivers and DX9

Discussion in 'Community Support' started by RavingLunatic01, Jan 5, 2019.

  1. RavingLunatic01

    RavingLunatic01 New Member

    Joined:
    Feb 10, 2018
    Ratings:
    +3 / 0
    Been trying to solve issue with RR since Nvidia update driver 417.35. I had 2 lengthy qualify/races prior to UD then straight back in to RR. After around 5 - 6 laps I start getting choppy screen each and every time. It wont let up even if I park on side of road or run replay so it is game over. Set up PC1, PC2, rF2, AC, ACC to match CPU, GPU, Ram, FPS usage/temps etc and was quite surprised I managed to get so close between all of them messing with the settings that the only thing I noticed was RR was DX9. I could not reproduce the issue in the other programs and in some cases run a full hour without so much as a wobble. Usually run 1920 x 1080p but went back and hammered some of them again with settings high at 3840 x 2160. Does anyone know if the DX9 is getting unruly with the latest drivers?? because I am running out of ideas.
     
  2. RWB 3vil

    RWB 3vil Member

    Joined:
    Dec 5, 2018
    Ratings:
    +11 / 0
    Roll back,

    The drivers after 417.01 gave me stutters in other games so I wouldnt be surprised if thats your issue too
     
    • Like Like x 1
  3. RavingLunatic01

    RavingLunatic01 New Member

    Joined:
    Feb 10, 2018
    Ratings:
    +3 / 0
    @RWB 3vil I cant roll back because I use work computers for in depth research and inspiration(Play my games) and the software we use generally require the latest drivers. Last PC I left at 38X.XX forever in fear of the update blues.

    Anyone has issue with this the problem on Windows 10 is the Nvidia Control Panel. The drivers etc all load correctly but W10 store has issue when updating the panel so kicks it off. When I updated driver I had to reset the store app after several install errors, then it installed but was not functioning correctly. After 3 days of messing around I booted the PC and there was a grey line thru the app icon in start bar once it downloaded second time it was all fixed.
     
  4. Hache

    Hache New Member

    Joined:
    Jan 13, 2019
    Ratings:
    +1 / 0
    Exactly the same problem (Choppy screen after some laps) but i'm on NVIDIA 388.59 (win10). I have a GTX980 and a GSYNC screen (ASUS ROG 34). I have setup NVIDA config panel to GSYNC and VSYNC ON (as recommended). GSYNC indicator is ON ingame so it's working.

    Last night i turned VSYNC ON also in RR and no problem during my two hours session. Steady 95 FPS.

    I will try again, but it's non-sense because all other racing games works fines (AC, PCARS2, RFactor2...) with VSYNC OFF ingame setting.

    Each time i tried (over past years) RR i always video problems... I think there are serious problems with this DX9 graphic engine. It's not reliable.

    Maybe DX9 is too old for modern GPU, and GSYNC high refresh rate screen ?

    Don't tell me my settings or hardware is the problem because all other games works smoothly...

    I will continue to test the reliability of the graphic engine before buying Premium Pack and it's a shame because eveything else in this sim is great.
     
    • Like Like x 1
  5. RavingLunatic01

    RavingLunatic01 New Member

    Joined:
    Feb 10, 2018
    Ratings:
    +3 / 0
    I can tell you nothing Hache as it is a mystery. I could run all other sims fine only RR was basically unusable. I was leaning towards the DX9 mainly because of it being the only difference I could see between the games that were working great and RR. However, I think the culprit might be the Vertical Sync was dodgy on Microsoft side over Nvidia. With Vertical Sync ON both in-game and Nvidia Control Panel, I see a steady 60 fps capped and silky smooth running where after the update it was all over the place. The other games rF2 PC1&2 etc I get 100-140 fps. I like all my Sims but RR is my fave so it was enough to give diarrhea the poops when this happened. Since the MS store instigated reinstall of the Nvidia Control Panel app, back to 60 fps steady I have had 2 micro stutters in about 70 laps on max settings and they were only on Monza for some reason, and I can live with that. Keep in mind Windows 10 is still in beta.
     
  6. Hache

    Hache New Member

    Joined:
    Jan 13, 2019
    Ratings:
    +1 / 0
    Ok just tried again and even with vsync on (both nvidia and ingame) i had steady 95fps and after 5 laps game become suddenly unplayable with massive stutter like 4fps. I will try with gsync off maybe RR dont support it ? I might give up on this sim... So dispointed...
     
  7. RavingLunatic01

    RavingLunatic01 New Member

    Joined:
    Feb 10, 2018
    Ratings:
    +3 / 0
    I am not sure what the exact difference is between G Sync and V Sync. I think G Sync is supposed to be a little more forgiving. V Sync will control the fps and keep it at the appropriate setting according to the refresh rate of the monitor. Mine is currently 60 Hz and 99.999999999% of the time I am getting 60 fps and usually only in the menu or splash screens would it fall below which don't matter. Check your refresh rate because if V Sync is on it should really be around that. Windows 10 > Settings > System > Display > Advanced Display Setting and you will see it. Looking at your 95 fps it appears to be similar to the issue I had. Both settings on but were not matching the fps to Hz and had a mind of its own. Hopefully, someone with more expertise will weigh in on this so hang in there. RR is too good to give up on.

    PS In the Nvidia Control Panel I have V Sync set to - Use the 3D Application settings.
    You could also check the Windows Store Downloads and Updates to make sure u don't have updates sitting there that can't install without resetting the app due to error.
     
    Last edited: Jan 13, 2019