OpenVR support

Discussion in 'General Discussion' started by RaceRoom, Jan 25, 2017.

  1. Sebastien Brunier

    Sebastien Brunier Active Member Beta tester

    Joined:
    Dec 17, 2017
    Ratings:
    +36 / 0
    25/30% CPU usage can still mean CPU bound, 25% is 100% on one core, and game is mostsly single threaded. My previous config was an i7 4790K like you with my GTX1080 and it was hard to maintain 90fps, now I switched to Ryzen 2700X and it is much easier.
    There are two things your computer might be struggling with:
    - the first is GPU idle (it is the case for almost any GPU above 1070 kind of performance so with V56 it is your case too) if the GPU load isn't intensive enough it might even not try to reach higher GPU clock speeds, try to find wath settings taxes your GPU
    - the second is VR adds background application that are as important as the main game itself and in CPU power terms they become concurrent (vrcompositor & vrserver) so maybe you could try in the task manager to increase process priority of RRE64.exe to above normal as well as for vrcompositor & vrserver. This will tell the windows task scheduler that every requests from those processes must be served before other processes, otherwise it is FIFO and that can add very small delays that leads to inconsistant frame rates that will in the end trigger ASW (don't go to high or realtime there are diminishing returns for the first one and wrse perf with the later).
    If you can in steam VR activate the frame time graph in the head set to look to the smoothness and or spikes of the frame time as you test these changes. It will help to find when you tweak graphical settings wich hammers the GPU, wich hammers the CPU.
     
  2. Kollo

    Kollo Active Member

    Joined:
    Dec 27, 2015
    Ratings:
    +37 / 0
    As I already wrote the utilisation is spread equaly over all cores -no core is above 30%. I tried to assign a single core to RRE64.exe and also increased process priority but performance became even worse.

    You should actually know that R3E is the least demanding of all currently popular sims in terms of hardware requirements. My hardware might be a little outdated but still is total overkill for running R3E. So why are there no similar problems with any other VR Software?

    Raceroom runs perfectly smooth with 45FPS and reprojection. I can use very high quality settings with 200% Supersampling while my hardware remains cool. But I would like to find out why it behaves as it does. These issues are not hardware related!
     
  3. SylverFyre

    SylverFyre Well-Known Member

    Joined:
    Jun 21, 2015
    Ratings:
    +78 / 0
    Do you have a driver profile for RaceRoom that is killing performance somehow? Or for steamVR?
     
  4. franfx85

    franfx85 New Member

    Joined:
    Jul 24, 2016
    Ratings:
    +1 / 0
    Hi all! I have a problem that I do not solve and that is when I go to the track with my rvc cv1 everything is centered less the car that is turned 45 degrees to the left and I can not center it. It is not solved by doing a reset of the car's positioning. I do not know what can cause this. I need help. Thank you.
     
  5. Sebastien Brunier

    Sebastien Brunier Active Member Beta tester

    Joined:
    Dec 17, 2017
    Ratings:
    +36 / 0
    Do you have similar problems in other games ? When you are at the main menu in VR is it perfectly centered ?
     
  6. franfx85

    franfx85 New Member

    Joined:
    Jul 24, 2016
    Ratings:
    +1 / 0
    it just happens to me in raceroom. the menus are perfectly centered.
     
  7. Mike W

    Mike W New Member

    Joined:
    Mar 1, 2015
    Ratings:
    +3 / 0
    The solution for me is to turn my wheel on once in game in VR. I have a accuforce, but this works with other wheels too. Leave wheel off until you are in the car. Power up, and you should be centered. You may have to do this only once to fix it.
     
  8. franfx85

    franfx85 New Member

    Joined:
    Jul 24, 2016
    Ratings:
    +1 / 0
    I will prove if it is solved like that. Thank you.
     
  9. franfx85

    franfx85 New Member

    Joined:
    Jul 24, 2016
    Ratings:
    +1 / 0
    the problem is caused by my fanatec csw v2. if I keep it running, the car is turned to the left. if I reset the configuration the problem is solved but if I create a new profile in my csw v2 when I return to the track the problem returns. I hope that with the next update the problem will be solved !!
     
  10. Virtual Apex

    Virtual Apex Member

    Joined:
    Sep 26, 2017
    Ratings:
    +9 / 0
    I was having the same issues for a while, what had to do was delete the look back button assignment. Some how it was getting mapped to my wheel buttons. If your in VR you shouldn't need this function so delete any button assignments from look back and look left and right.
     
  11. FormelLMS

    FormelLMS Well-Known Member

    Joined:
    Apr 8, 2015
    Ratings:
    +151 / 0
    Check the key bindings for looking left, right, back. It's binded to one of your rotary switches, I'm sure.
     
    • Agree Agree x 1
    • Winner Winner x 1
  12. franfx85

    franfx85 New Member

    Joined:
    Jul 24, 2016
    Ratings:
    +1 / 0
    problem solved by canceling the keys to look back, left and right. thank you!!!
     
    • Like Like x 1
    • Wonderful Wonderful x 1
  13. Leynad

    Leynad New Member

    Joined:
    Apr 27, 2015
    Ratings:
    +2 / 0
    The game doesn't launch into SteamVR, when i use Sim Racing System as a launcher. It was working a while ago and the settings in SRS are correct. Also "-VR 2.0" in the Steam-launch-options, but it's just launching the f-ing 2D-game:mad:
     
  14. Flybarless

    Flybarless New Member

    Joined:
    May 3, 2016
    Ratings:
    +3 / 0
    You have to enter the startup options in the SRS user settings.
     
  15. Leynad

    Leynad New Member

    Joined:
    Apr 27, 2015
    Ratings:
    +2 / 0
    Yes, both with -vr and -vr 2.0. Content-detection doesn't work as well, so no surprise RR isn't as popular as AC in SRS...
     
  16. Flybarless

    Flybarless New Member

    Joined:
    May 3, 2016
    Ratings:
    +3 / 0
    For me, SRS also works in VR with the startup options in SRS User settings. Are you sure the username etc are correct?
     
  17. Leynad

    Leynad New Member

    Joined:
    Apr 27, 2015
    Ratings:
    +2 / 0
    It's loading my profile and everything works just not the launch in SteamVR and the content detection. I did already SRS-races in RR with the same settings, but it's a while ago.
     
  18. Enrique Berton

    Enrique Berton New Member

    Joined:
    Dec 3, 2015
    Ratings:
    +0 / 0
    Hola, mi juego se cierra solo, la imagen es inestable, ffb no funciona, uso oculus CV1, plataforma steam, desintale he instale todo de nuevo
    Hello, my game closes alone, the image is unstable, ffb does not work, I use oculus CV1, steam platform, undo it and install everything again

    PC: Intel C i7 4790 3,60 Ghz - 16 GB ram - Nvidia 1080 - Win 10 64 bits x64
     
  19. Dux

    Dux New Member

    Joined:
    Dec 24, 2015
    Ratings:
    +0 / 0
    Why cannot find that option setting ?
     
  20. sherpa25

    sherpa25 Member

    Joined:
    Jul 2, 2018
    Ratings:
    +14 / 0
    Which exactly?