OpenVR support

Discussion in 'General Discussion' started by RaceRoom, Jan 25, 2017.

  1. fl0wf1r3

    fl0wf1r3 Well-Known Member

    Joined:
    Apr 24, 2016
    Ratings:
    +228 / 0 / -0
    Hello, is this actually still valid of how to start Raceroom in VR? why not using the VR startup option instead of using this custom launch option? when using the orther startup option one could set SS in SteamVR? but honestly I don't see or experience any differences between the two options? default SS is set to 100% in SteamVR. I don't see any difference when using 40% or 200%, kind of strange.

    - In your Steam client library, right click RaceRoom and select "Properties".
    - In the Properties pop-up window, under the "General" section, click the "Set Launch Options..." button.
    - In the dialog box that opened, just type in "-vr" (without the quotation marks) and it will use the default value for render target multiplier, which we currently have set to 1.5.
    - To experiment with different render target multipliers, you can simply add the desired value after the argument, for example: "-vr 2.0" will start the game with the multiplier at 2.0. This multiplier can go as low as 0.5 and as high as 4.0 which is very high, so we recommend small steps here.
     
  2. Andrew_WOT1

    Andrew_WOT1 New Member

    Joined:
    Dec 24, 2019
    Ratings:
    +2 / 0 / -0
    You don't need it anymore.
    https://forum.sector3studios.com/index.php?threads/openvr-support.7109/page-67#post-193799

    And shortcut to launch in VR
    steam://launch/211500/vr
     
    • Informative Informative x 1
  3. Ciccina2016

    Ciccina2016 Member

    Joined:
    May 24, 2018
    Ratings:
    +5 / 0 / -0
    Hello , when in VR , I cannot read the setup screen as too blurry, what is the parameter I need to change?
     
  4. keanos

    keanos Well-Known Member

    Joined:
    Oct 29, 2015
    Ratings:
    +109 / 0 / -0
    Start the game without VR,
    set the Resolution to match your natve monitor resolution,
    and then start the game again with VR;
     
    • Like Like x 1
    • Disagree Disagree x 1
  5. RWB 3vil

    RWB 3vil Active Member

    Joined:
    Dec 5, 2018
    Ratings:
    +41 / 0 / -0
    Check the overall screen resolution in general video settings. You may be running at something really low like 1024x768
    The desktop screen resolution shouldnt cause any VR FPS loss when set at your monitors screen resolution so run it at your monitor res ( you may have to set this in non VR mode)
     
  6. Ciccina2016

    Ciccina2016 Member

    Joined:
    May 24, 2018
    Ratings:
    +5 / 0 / -0
    Thank you soo much. it worked.

    Does this mean I was running at a lower resolution even in VR? Am I so stupid?
     
  7. ndwthx1138

    ndwthx1138 Well-Known Member

    Joined:
    Dec 4, 2017
    Ratings:
    +100 / 0 / -0
    No it’s only for the overlay , however , there is some misinformation above. Monitor resolution absolutely affects over all performance. It IS a hit on your system to run higher monitor resolutions while in VR.

    So choose the lowest monitor resolution you can get away to read your text easily. I run 720p resolution (1280x720).

    I run with motion smoothing/asw/re-projection/etc all off and maintain 80fps with AAx4. I’m on a index so 80hz is available to me. If I bump up to 90hz/90fps there are a couple of tracks that stutter with a full set of opponents - I’m running 165% pixel density. If I bump my monitor resolution up to native screen res 2160x1440 my pixel density has to be reduced to 135% which is way too big a visual impact for clear over-lay text..
     
  8. Hangon

    Hangon Member

    Joined:
    Aug 23, 2015
    Ratings:
    +14 / 0 / -0
    Is there a way to increase the clarity of the picture in VR other than SS? Im Im running a index, bumping up SS to 150% I find the motion is not smooth..that's on a I76700k OC to 4.5 and a 1080ti 11gb. If I run at default 100% SS it's fairly decent, but the image is so blurry/ pixallated. As example, in iracing it is alot clearer at same SS? I wonder sometimes that the lighting in the game has alot to do with the clearness of the images? I tried negative lod bias but it did not seem to make much difference..I used a -0.7500 , Im assuming going higher is supposed to give clearer image? Eg : -1.2500 ? I see last post that person is running at 165%SS ..must not be running that smooth? Unless they have way better system?? Any suggestions? Thanks in advance
     
  9. ndwthx1138

    ndwthx1138 Well-Known Member

    Joined:
    Dec 4, 2017
    Ratings:
    +100 / 0 / -0
    In order to get a 80fps vr experience on my index - Turn shadows to low (I'd suggest very low on a 1080ti). I'd suggest reducing visible cars (I think I have 18). My anti-aliasing level is 4X. Car reflection quality at it's lowest possible setting. Particle detail on low. I have contact shadows on but at a low number (7 I think). Lastly mirror quality - as low as you can stand.. Everything else I have on high.. I run at 1.65 SS but I did note the other day - spa with a full grid is causing me stutters on the down hill post turn 1 if I am middle or back of pack.. I'd sware a few months ago this was not the case..

    I will not play a sim at 45fps - so I turn off motion smoothing etc and simply find a place where it no longer stutters..

    this is with a 2080ti over-clocked a few percent.. and a 6960X i7 over clocked to 4.1
     
  10. Hangon

    Hangon Member

    Joined:
    Aug 23, 2015
    Ratings:
    +14 / 0 / -0
    Thanx for the reply ndwthx1138 ! ..i did the settings that you recommended. Previously my settings were a little higher eg: AA 8x,and others were higher that you mentioned to decrease.At 150% SS i was getting average 59 fps and reprojection at about 26 % . I went back to just default 100%SS and then average was 72.9 fps and reprojection down to 9%. The gameplay was pretty good ..very smooth ...but visuals were as I described previously. I do think like you said ,something had changed in the last month or so ,as I used to get pretty well 80fps and below 10% reprojection with my previous higher in game settings (but 100%SS) . I think something to do with steamvr?? They fucked something up. I sure hope Sector 3 holds off ..or just does not worry about rain or weather,as that will only increase the performance requirements.Instead, get DX11 implemented and hopefully that gives a substantial performance boost...something we need more so than the other stuff. Hell, no one hardly uses the rain and weather in other sims ,even though thier userbase cried for it. I guess i will also have to look at the new 3xxx nvidia cards when they come out..and a new processor ..which requires a new motherboard ..and the domino effect continues $$$$$
     
  11. ndwthx1138

    ndwthx1138 Well-Known Member

    Joined:
    Dec 4, 2017
    Ratings:
    +100 / 0 / -0
    SteamVR likes to update every week. The most stable VR experience I have is from October of 2018! that's not a typo.. I literally have a backup of that release and will often delete the folder and copy that old version in.. There is no way to stop steamvr from updating either.. so from time to time when I get hit with their update that slows it down I literally go back 1.5 years - and to this date in raceroom (not iracing) it's the best performance. Steamvr is trying to design their software for middle of the road technology/performance and really want to push re-projection/motion smoothing.. This isn't a win for sim racing where we are often fighting for 100ths of a second and need fps.. instant feedback is necessary to be competitive in my opinion..

    Also note a 2080ti is about 30-35% faster than a 1080ti - that will not make up for our difference in pixel density though. Assuming you did reduce shadows and reflections to the lowest and your AA is 2 or 4 and your cars visible is sub 18 - you really should be at at least 1.3-1.35 pixel density with near 80fps. Might have to start looking at your invidia settings -

    Last thing I am going to note - what is your monitor resolution set to in game? People often leave this set really high - this is a rather large hit. I've turned down mine to 720p and this has gained me quite a bit of performance. The HUD and menus will be softer in VR but that's the only draw back.
     
  12. fl0wf1r3

    fl0wf1r3 Well-Known Member

    Joined:
    Apr 24, 2016
    Ratings:
    +228 / 0 / -0
    Let me summarise all the tips and tricks here = Raceroom needs a new or improved graphics engine asap. I started losing the interest in driving with Raceroom.

    From my experience, Assetto Corsa with Content Manger and SOL is the best looking VR experience out there. With sound mods from Fonsecker it has the perfect driving experience. But AC had no updates since a long long time.
     
  13. ndwthx1138

    ndwthx1138 Well-Known Member

    Joined:
    Dec 4, 2017
    Ratings:
    +100 / 0 / -0
    You mean like ACC? Which has the worse performance of any sim out there by a huge margin? Even on a monster machine it's not playable at reasonable frames unless you have every off or at low.. even then it still creates stutters and wants to run in reprojection..

    So rather than disagree with you - I am just gonna say that newer technology on the engine front does not equal great VR performance. Iracing has everyone beat in this regard.. and has working mirrors.. It's pretty old engine tech at this point..
     
    • Agree Agree x 2
  14. fl0wf1r3

    fl0wf1r3 Well-Known Member

    Joined:
    Apr 24, 2016
    Ratings:
    +228 / 0 / -0
    SOL ist not available for ACC. I'm talking about the old AC "Assetto Corsa". It has working mirrors as well. Great Particle effects with the Shader Patch and other things (Content Manager). ACC is not a great experience, the sounds are great but thats it. I still have AA issues on my monitor and I'm not going to buy a new +4k Monitor to fix this. The unreal engine is not great for racing sims in my opinion. Nice try but does not work
     
    • Agree Agree x 1
    • Disagree Disagree x 1
  15. troch22

    troch22 New Member

    Joined:
    Dec 31, 2018
    Ratings:
    +0 / 0 / -0
    I have VERY bad & blurry resolution. No matter what I try below, nothing fixes it . Anyone know how to "force" VR into a desired resolution. because right now it looks like its locked into 480p or something like that. For an example its the same issues that these guys have...
    https://forum.sector3studios.com/index.php?threads/extremely-blurry-vr.12118/#post-165524
    https://forum.sector3studios.com/index.php?attachments/rre-vr-jpg.15289/

    I have built a new computer, here are the specs.
    Samsung Odyssey Plus+
    i9 7980xe
    1080 Ti
    32GB ram
    x4 970 pro m.2
    Asuz Rampage VI apex
    EVGA 1600 T2 supernova
    However Race Room works great on my OLD PC (, i5-6600k, GTX980, 16GB Ram) with the same VR headset.

    So far i have tired..
    Reinstalling windows
    reinstalling raceroom
    reinstalling windows mixed reality
    reinstalling video drivers
    reinstalling Odyssey Plus+ drivers
    latest Odyssey Plus firmware
    tried -vr x.x launch settings (1.3, 1.5, 2.0, 2.5, ect)
    turned on/off raceroom monitor mirror
    set resolution in 2D to match my desktop (3440x1440)
    also tried setting 2D resolution to other setting 1080p, 720p, ect
    turn off DSR in nvidia control panel
    set steam VR SS to 100% and other setting (75%, 150%, 200%, ect)
    deleted the MYGames/Simbin folder and try everything above
    copied MyGames/Simbin folder from old PC to new PC and try everything above
    change/check "Override high DPI scaling behavior" for RRE64.exe (and 32 bit)

    no matter what, the graphics in game are very pixelated like its 360p

    my other computer with the same VR headset... works fine.

    I am out of ideas & need HELP!
     
  16. RWB 3vil

    RWB 3vil Active Member

    Joined:
    Dec 5, 2018
    Ratings:
    +41 / 0 / -0
    I had that low res issue because I forgot i had added a spectator mode URL to the Steam launch parameters from a previous session
     
  17. troch22

    troch22 New Member

    Joined:
    Dec 31, 2018
    Ratings:
    +0 / 0 / -0
    Hi, and thanks for the reply RWB 3vil. Wish I had something like that causing the issue. But my issue is on a fresh install and nothing in the launch parameters. I also ran steam to verify files & things. no luck.
     
  18. RWB 3vil

    RWB 3vil Active Member

    Joined:
    Dec 5, 2018
    Ratings:
    +41 / 0 / -0
    The only other thing to try is resetting any GPU profile for the game, using Nvidia Inspector or the Nvidia Control panel or AMDs equivalent and deleting the profile settings in My Documents
    (which dont get deleted if you uninstall/reinstall the game in Steam)
     
  19. sergeich

    sergeich Member

    Joined:
    Oct 27, 2019
    Ratings:
    +12 / 0 / -0
    Same problem - Radeon 5700XT, Oculus Rift S.
    When I setup launch parameters - ingame resolution looks like 320x240.
    vr -2.0, 4.0, 10.0 - no changes. Always ultra-low resolution. Why?
     
  20. troch22

    troch22 New Member

    Joined:
    Dec 31, 2018
    Ratings:
    +0 / 0 / -0
    After 4 days I have finally got it to work.. THANK GOD!! However I have no idea what was the cause or the fix. I could take a guess, but it could have no value..

    After trying everything, the 2 things I did different was installing the game on the same drive as steam & reinstalling windows mixed reality. Each one done after a reboot.

    So to recap here is everything I did to get it working.
    Had a fresh windows 10 install as i just finished build a new PC (back story, RRE was not working on fresh win10 and game install)
    Uninstall/Install Nvidia drivers
    Uninstall/Install Windows mixed reality
    Uninstall/Install Steam VR
    Uninstall RaceRoom from my D drive, Reinstall RaceRoom on C drive where steam is located
    turn off DSR in nvidia control panel
    check "Override high DPI scaling behavior" for RRE64.exe (right click - properties)

    Now running a steady 90FPS in VR with 170% SS. Such a big upgrade from my old PC, its night and day!!
    Hope this helps and works for others. Cuz i know the aggravation!!!