Problem OSW No FFB

Discussion in 'Community Support' started by RWB Rodders, Dec 12, 2019.

Tags:
  1. RWB Rodders

    RWB Rodders Member

    Joined:
    Nov 15, 2018
    Ratings:
    +24 / 0 / -0
    Cheers Christian.

    This is probably useless info but I could not help having a poke about and found a reg entry for my wheel here

    upload_2019-12-18_23-8-24.png

    I have settings ConstantForce, Sine, Spring, Damper, Inertia and Friction. A friend with a Fanatec Podium compated and had a load of extra entries for diff attributes like RampForce and Triangle wave and others.

    [​IMG]

    I duplicated these entries and with some tweaks to match my settings but still unique where it mattered, added to my registry. The moment I entered the car with these settings (and the FFB activates) the game crashes.

    This showed that this had an effect but I quickly got out my depth lol and all I managed to do was make the game crash. I had to manually tweak the key names, default RZ name and Attribute setting with educated guesses so probably cocked something up but seemed to be on to something so sharing just encase it helps.

    Sounds like you are well on it anyway and likely much more accurately than I :D

    Cheers.
     
    • Like Like x 1
    • Funny Funny x 1
  2. Christian G

    Christian G Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,310 / 0 / -0
    @RWB Rodders
    Tbh I'm not sure if this info might come in handy at this point, but thanks anyway, I've forwarded it just in case.
    What I do know is that the issue seems to be connected to how the new flat spot FFB is generated and this is what's being looked at right now.
     
    • Like Like x 1
    • Informative Informative x 1
    Last edited: Dec 19, 2019
  3. Johann

    Johann New Member

    Joined:
    May 13, 2018
    Ratings:
    +2 / 0 / -0
    Thanks for UP DATE:)
     
    • Like Like x 1
  4. RWB Rodders

    RWB Rodders Member

    Joined:
    Nov 15, 2018
    Ratings:
    +24 / 0 / -0
    Just seen this on Sim-plicity Facebook:

    upload_2019-12-19_14-59-6.png

    Can we get some guidance asap with this out - do we need to get in touch with SImplicity to get hold of this firmware and instructions or will Sector 3 be coordinating the rollout? Whatever way please instruct ASAP! ;)

    At work - home in 4hrs and wanna hit the ground running!
     
  5. Topshelf147

    Topshelf147 Active Member

    Joined:
    Jan 4, 2019
    Ratings:
    +33 / 0 / -0
    Good news!!! Well for users of the newer systems at least, not sure about the previous gen devices. But a new firmware I received a few hours ago from Simplicity for my SW12C has returned working FFB back to RaceRoom! I only tested for 2 minutes as I was heading to bed when it arrived, so will test more today and verify it across all sims I have. But if you want to get in on the testing, reach out to Simplicity about an update.
     
    • Like Like x 2
  6. Topshelf147

    Topshelf147 Active Member

    Joined:
    Jan 4, 2019
    Ratings:
    +33 / 0 / -0
    Dang man, I was getting to it. Lol

    Contact Simplicity for the update. The fix appears to be firmware related, so will definitely need to come from them. I don't know which devices are/are not supported or any limitations at this point. I only installed, tested working and went to bed. Will update in a bit though.

    You can email them at
    support@sim-pli.city
     
    Last edited: Dec 19, 2019
  7. RWB Rodders

    RWB Rodders Member

    Joined:
    Nov 15, 2018
    Ratings:
    +24 / 0 / -0
    I've emailed them - thanks.

    Still think this update needs spread or at least news spread centrally by Sector 3 as not all affected users will know about this and certainly won't be on Sim-plicity Facebook. Plus not all affected users have wheels from Sim-plicity. I suspect they will be putting together an announcement soon.
     
  8. axelpaq

    axelpaq New Member

    Joined:
    Feb 7, 2016
    Ratings:
    +0 / 0 / -0
    I hope so for Raceroom
    I don't have any Sim-Plicity wheel so the firmware update is not for me
    so my Raceroom is still unusuable
    after the DLC problem I can't use it since last week now - it begins to be a long time
    it's time now for raceroom to get an update solving this problem
     
    • Agree Agree x 1
  9. Johann

    Johann New Member

    Joined:
    May 13, 2018
    Ratings:
    +2 / 0 / -0
    I agree.
     
  10. RWB Rodders

    RWB Rodders Member

    Joined:
    Nov 15, 2018
    Ratings:
    +24 / 0 / -0
    No answer from Sim-plicity yet. I'm finding it ludicrous to have to find out about this on a Facebook page, have to email another company for what I know is now available (which will be answered when? Not today by the looks) and on official Raceroom forum and Discord - not one message even mentioning this let alone some help and guidance to get hold of the fix.

    Pretty much had enough of this now as this is completely killing my ability to keep running a race club where this is the main racing game.

    Please hurry up.
     
    • Creative Creative x 1
  11. ravey1981

    ravey1981 Well-Known Member Beta tester

    Joined:
    Apr 15, 2018
    Ratings:
    +483 / 0 / -0
  12. J-F Chardon

    J-F Chardon Sector3 Producer Developer

    Joined:
    Jan 15, 2015
    Ratings:
    +4,634 / 0 / -0
    Thanks @ravey1981 for linking me here.

    I have a potential fix for you guys to try out. Please contact me for some early access and verification that it works, as I don't have such a wheel to test the fix here.
     
  13. Stacy Newcomb

    Stacy Newcomb New Member

    Joined:
    Apr 23, 2019
    Ratings:
    +2 / 0 / -0
    I'll come back to Raceroom sometime next year ..... once this fiasco is over, Rf2 here I come.
     
    • Funny Funny x 3
    • Agree Agree x 2
    • Creative Creative x 1
  14. RWB Rodders

    RWB Rodders Member

    Joined:
    Nov 15, 2018
    Ratings:
    +24 / 0 / -0
    Done - messaged J-F here and Discord. Didn't work unfortunately.
     
  15. RWB Rodders

    RWB Rodders Member

    Joined:
    Nov 15, 2018
    Ratings:
    +24 / 0 / -0
    For anyone with a Simplicity SW20 v2 - Simplicity contacted me and cannot patch it's firmware so not an option unfortunately.
     
  16. putzm1

    putzm1 New Member

    Joined:
    Dec 19, 2019
    Ratings:
    +3 / 0 / -0
    For me the early acces "patch" from J-F worked very well.
    Force Feedback is back,(Simucube1 with MMOS)
     
    • Like Like x 3
  17. ravey1981

    ravey1981 Well-Known Member Beta tester

    Joined:
    Apr 15, 2018
    Ratings:
    +483 / 0 / -0
    So it's a hardware issue then.
     
  18. Jota Ele

    Jota Ele Active Member

    Joined:
    Aug 15, 2017
    Ratings:
    +33 / 0 / -0
    8 days late but sw20v3 finally is working again on early access patch too, better FF less oscillations and zero inputlag.
     
    • Like Like x 1
  19. RWB Rodders

    RWB Rodders Member

    Joined:
    Nov 15, 2018
    Ratings:
    +24 / 0 / -0
    It has a hardware element to it but calling it a hardware issue is a stretch when it works in all other 8 sims I've got.
     
  20. [RWB] FxUK

    [RWB] FxUK Well-Known Member

    Joined:
    Dec 2, 2018
    Ratings:
    +94 / 0 / -0
    Illogical.

    If the hardware worked perfectly in raceroom before the major patch that was just released.. and the hardware works as it did in other all other sims, then.. the common thing that has changed causing the problem and exhibiting it, is related to the major raceroom patch, a software issue.
     
    Last edited: Dec 19, 2019