OtterHud - A custom WebHud - With additional features

Discussion in 'Community Workshop' started by OtterNas3, May 7, 2019.

  1. Arthur Spooner

    Arthur Spooner Well-Known Member

    Joined:
    Feb 5, 2015
    Ratings:
    +297 / 0 / -0
    Do you actually have the quotes in your parameters or do they come from the error message only?
     
  2. John Fetz

    John Fetz New Member

    Joined:
    Nov 27, 2019
    Ratings:
    +1 / 0 / -0
    they are from the error message, link is clean :)
     
  3. Balrog

    Balrog Well-Known Member

    Joined:
    Apr 10, 2015
    Ratings:
    +288 / 0 / -0
    I'm just guessing here, but did you add the parameters through Steam? Library -> RaceRoom -> Right-click -> Properties -> General -> Set Launch Options. I think you shoudn't modify the launch options directly on the .exe file.
     
  4. John Fetz

    John Fetz New Member

    Joined:
    Nov 27, 2019
    Ratings:
    +1 / 0 / -0
    yep, did it like it's being told on page 1
     
  5. fischhaltefolie

    fischhaltefolie Well-Known Member

    Joined:
    Feb 12, 2015
    Ratings:
    +894 / 0 / -0
    My foggy remembrance tells me, you had to download and run a dash-file from the link in thread In-Gameplay Web Overlays.
     
  6. Arthur Spooner

    Arthur Spooner Well-Known Member

    Joined:
    Feb 5, 2015
    Ratings:
    +297 / 0 / -0
    You have to, but not having the dash.exe does not lead to RR not starting. It just leads to no webhud showing and displaying an error message at the left edge of the screen, saying that the dash.exe is not running.
     
  7. sherpa25

    sherpa25 Member

    Joined:
    Jul 2, 2018
    Ratings:
    +17 / 0 / -0
    I believe he's running CC, so no need for the dash.exe, just the weblink parameters. I don't know why though R3E won't run. I remember getting a similar prompt message but only when testing a car from the store.
     
  8. [RWB] FxUK

    [RWB] FxUK Well-Known Member

    Joined:
    Dec 2, 2018
    Ratings:
    +94 / 0 / -0
    How are you launching the game? Directly/manually from steam or via another app?
    If its another app, certain launch commands can trigger that dialog, there are ways to launch externally (not from steam directly) without triggering it though.

    i.e

    I have two shortcuts on my desktop (because I sometimes play in vr or triples)

    Target:
    C:\Steam\Steam.exe -gameidlaunch 211500 -webdev -webHudUrl=https://otterhud.github.io/

    Try that, although need to change steam path to match yours.
     
    • Like Like x 1
  9. sherpa25

    sherpa25 Member

    Joined:
    Jul 2, 2018
    Ratings:
    +17 / 0 / -0
    I presume this is for triples (no triscr parameters?)? And then what's your shortcut for VR? TIA.
     
  10. [RWB] FxUK

    [RWB] FxUK Well-Known Member

    Joined:
    Dec 2, 2018
    Ratings:
    +94 / 0 / -0
    • Like Like x 1
  11. John Fetz

    John Fetz New Member

    Joined:
    Nov 27, 2019
    Ratings:
    +1 / 0 / -0
    yes, i am running crewchief and therefor don't use dash.exe

    the game is usually started from steam, but just tried a shortcut like this. without success, it just takes a whole lot longer for steam know recognize that it doesn't like the link... :/
     
  12. fischhaltefolie

    fischhaltefolie Well-Known Member

    Joined:
    Feb 12, 2015
    Ratings:
    +894 / 0 / -0
    I'm lazy and let Crew Chief do all the work:
    starting RR and starting dash.exe.
    Works fine.
     
  13. [RWB] FxUK

    [RWB] FxUK Well-Known Member

    Joined:
    Dec 2, 2018
    Ratings:
    +94 / 0 / -0
    Post a screenshot of your launch option (ignore that mine is blank, its because I use a different method to launch it)

    upload_2019-12-7_19-30-24.png
     
  14. John Fetz

    John Fetz New Member

    Joined:
    Nov 27, 2019
    Ratings:
    +1 / 0 / -0
    [​IMG]
     

    Attached Files:

    Last edited: Dec 7, 2019
  15. John Fetz

    John Fetz New Member

    Joined:
    Nov 27, 2019
    Ratings:
    +1 / 0 / -0
    just tried it without CC, but using dash.exe
    same thing, just that it takes ages for steam to complain.
    dash.exe is stalling in a series of repeated messages:
    "Found R3E process, mapping shared memory..."
     
  16. Arthur Spooner

    Arthur Spooner Well-Known Member

    Joined:
    Feb 5, 2015
    Ratings:
    +297 / 0 / -0
    That's normal. As soon as dash.exe detects a running R3E-process it starts to repeat this message until the connection to the shared memory API is established. This always takes some time. But in your case - for a still unknown reason - R3E never really manages to complete the start procedure. So the message continues to be repeated.

    Can't see your image btw...
    2019-12-07 21_48_23-Window.png
     
  17. NL-Jos

    NL-Jos Well-Known Member

    Joined:
    Jun 5, 2015
    Ratings:
    +164 / 0 / -0
    Is it possible to create shortcuts in the HUD?
    For example, the standing list on the legt side is very usefull but sometine
    Annoying because it takes your view away when entering the corners
     
  18. Arthur Spooner

    Arthur Spooner Well-Known Member

    Joined:
    Feb 5, 2015
    Ratings:
    +297 / 0 / -0
    Looks exactly the same on my side. Have you tried to remove the parameters to see if R3E starts again like normal without the webhud? If it still doesn't start then the webhud might not be the reason for your trouble. You could try to do an integrity check on the R3E-files.
     
    • Agree Agree x 1
  19. John Fetz

    John Fetz New Member

    Joined:
    Nov 27, 2019
    Ratings:
    +1 / 0 / -0
    Well, the problem is solved. It was caused by admin rights in RRRE64.exe which is putting steam on alert mode as this is considered to be in "compatibility mode".
    when installing the HUD and CC i was trying other hud solutions and with one of them i got that "Launch with admin rights" box checked, it seems.
    Sorry for ringing the alarm in here, but it happened certainly related to the installation of the HUD... ;)
     
    • Informative Informative x 2
    • Like Like x 1
  20. sherpa25

    sherpa25 Member

    Joined:
    Jul 2, 2018
    Ratings:
    +17 / 0 / -0
    Funny, I don't have RRRE64.exe (nor CC) running in Admin mode.