HUD OtterHud - A custom WebHud - With additional features

Discussion in 'Community Workshop' started by OtterNas3, May 7, 2019.

  1. Rox

    Rox New Member

    Joined:
    Oct 19, 2020
    Ratings:
    +1 / 0 / -0
    I am sorry to insist but dash.exe does not start, cc does not open websochet, it happens not only to me but also to 2 of my friends, as well as to many others on the web.
    I have not found solutions even cleaning the whole computer
    we use updated windows 10
    port 8070 appears to be compromised
    if on CC I change port the websoket starts but in the game hud it doesn't work.
    do you have any idea ... we can have this hud too or is it only for a few advantaged
    NB.hud di rre really does ....
     
  2. CaptainCoffee

    CaptainCoffee Active Member Beta tester

    Joined:
    Oct 11, 2020
    Ratings:
    +29 / 0 / -0
    It really is a problem that only a select few users have, port 8070 unavailable. There is some software/service using it.

    Have you tried running it under administrative account with elevated privileges? Only other solution is to check which software you have installed that is using port 8070... Or a complete reinstall of the OS..
     
  3. Rox

    Rox New Member

    Joined:
    Oct 19, 2020
    Ratings:
    +1 / 0 / -0
    Thanks for the reply,
    I checked everything I could from cleaning the windows registry looking for any software connected to the 8070 but nothing asks for it.
    NetStat does not show it connected or waiting
    other huds work but i have seen they use other ports but too many problems with them
    if on CC I set the 8072 or other port the websoket is created, I was wondering if it is possible to have the flow on another port.

    ProRacing Web Dashboard for example uses 57777 and 7777.

    A I forgot, created rule in the windows firewall and in the rotter.
    the thing is making me cry
     
  4. OtterNas3

    OtterNas3 Well-Known Member

    Joined:
    Jan 9, 2018
    Ratings:
    +252 / 0 / -0
    See attachment
     

    Attached Files:

    • Useful Useful x 1
  5. Rox

    Rox New Member

    Joined:
    Oct 19, 2020
    Ratings:
    +1 / 0 / -0
    Many thanks for this advice now it works.
    it remains for me to discover what works on the 8070
    Thanks again
     
    • Like Like x 1
  6. hazardpro

    hazardpro New Member

    Joined:
    Jan 12, 2020
    Ratings:
    +1 / 0 / -0
    Hi all

    what am I doing wrong? Getting nothing in game.

    Exe is running (says ‘memory mapped successfully’)

    have added the required info to steam (launch options)
     
  7. hazardpro

    hazardpro New Member

    Joined:
    Jan 12, 2020
    Ratings:
    +1 / 0 / -0
    Here are screen shots

    but in game I have nothing on screen (no hud info)
     

    Attached Files:

  8. NL-Jos

    NL-Jos Well-Known Member

    Joined:
    Jun 5, 2015
    Ratings:
    +167 / 0 / -0
    -webdev -webHudUrl=https://otterhud.github.io/

    Copy/past this rule
     
  9. hazardpro

    hazardpro New Member

    Joined:
    Jan 12, 2020
    Ratings:
    +1 / 0 / -0
    DOH yep just seen my type.... what a pleb.

    Thanks :)
     
  10. Pumo

    Pumo New Member

    Joined:
    Jan 23, 2021
    Ratings:
    +0 / 0 / -0
    I am new with R3E and otterhud. I play with VR (valve index) but when driving whole screen in VR goes grey for half to 3 seconds. Any idea how can it be fixed, or just not to use otterhud at all?
     
  11. Goffik

    Goffik Well-Known Member

    Joined:
    Jun 30, 2017
    Ratings:
    +156 / 0 / -0
    Have you confirmed that it's definitely OtterHUD causing this? I've never heard of this issue before.
     
  12. Balrog

    Balrog Well-Known Member

    Joined:
    Apr 10, 2015
    Ratings:
    +395 / 0 / -0
    I've been using OtterHUD on an Index for over one and a half year now. Are you sure that the headset sees the base(s) perfectly when you sit behind the wheel? I had some funky behavior as well when I simply forgot a random object in the way for example.
     
  13. Pumo

    Pumo New Member

    Joined:
    Jan 23, 2021
    Ratings:
    +0 / 0 / -0
    Yes base station is ok. All other games works and even this when I start without crewchiefs hud enabled.
    Before this menus does flicker in that grey screen sometimes but not while driving.
    I have ryzen 7 3700x and rx6800xt.

    Edit: I just remembered that steamvr is beta version, I did install because msfs2020 +openxr.
    I try to change it back to stable tomorrow.
     
    Last edited: Jan 28, 2021
  14. Pumo

    Pumo New Member

    Joined:
    Jan 23, 2021
    Ratings:
    +0 / 0 / -0
    How do I edit layout? I can't find in first page only those shif up/down/left/right buttons..
     
  15. sherpa25

    sherpa25 Member

    Joined:
    Jul 2, 2018
    Ratings:
    +23 / 0 / -0
    Just move your mouse and you will see the 'Cog' symbol at the left side (together with presets 1 and 2), then click on the 'Cog' to open settings.
     
    • Like Like x 1
  16. Pumo

    Pumo New Member

    Joined:
    Jan 23, 2021
    Ratings:
    +0 / 0 / -0
    Ok, I tested now:
    -changed steamvr beta to stable, grey screen appears.
    -launching otterhub with dash.exe grey screen appears.
    -launching otterhub with crewchief grey screen appears
    -launched otterhub with crewchief and hided from eye icon, no grey screen at any point, well doesnt help then..
    -disabled from game option enable steam overy and desktop game theatre which are enabled by default.

    I might test next what simhub overlay or drive without any because with this its unusable...
     
  17. Balrog

    Balrog Well-Known Member

    Joined:
    Apr 10, 2015
    Ratings:
    +395 / 0 / -0
    How much SS do you use?
     
  18. Pumo

    Pumo New Member

    Joined:
    Jan 23, 2021
    Ratings:
    +0 / 0 / -0
    120% and 90hz, smoothing off

    edit: just tested with 100% manage to get half lap of brandhatch before grey screen.
    should these be off in crewchef?
    edit2: didnt help, I even shutdown fpsvr for running.
    and it is messing like it loosing tracking, sometimes after when picture returns it comes somewheree from down left up or right. but why doesnt do that when I hide otterhud..
    upload_2021-1-29_16-19-14.png
     
    Last edited: Jan 29, 2021
  19. Pumo

    Pumo New Member

    Joined:
    Jan 23, 2021
    Ratings:
    +0 / 0 / -0
    I might solve the problem, I disabled that monitor view and also removed chilldex from my valve index.
    now only couple times came grey screen in 15min race. it is still too much. "blackout" in wrong place can cost win..
     
  20. NL-Jos

    NL-Jos Well-Known Member

    Joined:
    Jun 5, 2015
    Ratings:
    +167 / 0 / -0
    What else is there as an overlay wich come near to Otterhud
    Because otterhud won't be upgraded if i understand it wel
    And because of that the difference in the timetables are stil difficult to understand