(Problem) Fanatec Pedals V3 Rumble wont stop in R3E

Discussion in 'Hardware' started by HomieFFM, Nov 16, 2019.

  1. HomieFFM

    HomieFFM Well-Known Member

    Joined:
    Dec 21, 2017
    Ratings:
    +280 / 0 / -0
    Brake and throttle rumble motors are continuously in action, as soon as I touch the brake it starts directly rumbling and the throttle motor as soon as I drive a corner or sometimes on a straight.

    And it's a very weird rumble, at first I thought they are broken, but I did a test with the property page and they sound completely normal.

    I can't even turn them off with the Fanalab software and no matter which settings I use (everything disabled) they act the same weird way and keep going in Raceroom (no problem in ACC, but there you just have the brake rumble)

    thankful for any help,
    Cheers :)
     
  2. fischhaltefolie

    fischhaltefolie Well-Known Member

    Joined:
    Feb 12, 2015
    Ratings:
    +931 / 0 / -0
    Having problems with fanatec stuff, I always made a new install of driver and firmware. Always solved my problems.
    Maybe also your rcs file is corrupted. Have you tried to make a new controler profile?
     
    • Informative Informative x 1
  3. HomieFFM

    HomieFFM Well-Known Member

    Joined:
    Dec 21, 2017
    Ratings:
    +280 / 0 / -0
    I have created a new controler profile, didn't changed anything.
    Now I deinstalled the driver, downloaded the new ones and now I can't start fanalab xD

    Requies Driver Package V339
    fanalab error.jpg

    Then I tooked a look into the version Number and it was 335 (Firmware both updated)
    property.jpg

    And now to get completely confused: There exists no Driver above 335 xD
    driver 335.jpg
     
    Last edited: Nov 16, 2019
  4. fischhaltefolie

    fischhaltefolie Well-Known Member

    Joined:
    Feb 12, 2015
    Ratings:
    +931 / 0 / -0
    @HomieFFM sorry, didn't want to make it more complicated!:oops:
    Maybe you'll find it here
     
    • Like Like x 1
  5. HomieFFM

    HomieFFM Well-Known Member

    Joined:
    Dec 21, 2017
    Ratings:
    +280 / 0 / -0
    Alright solved the problem with the Driver:
    1. Don't use the update firmwarebutton, it will install an older version
    2. The Driver on the Fanatec page are old ones, so don't use themeather
    3. use this link for the actually new driverlist (what a mess by Fanatec)


    however the problem still remains, as I wrote in the first post, so I think this is a problem from Raceroom.
    It's so annoying when you can't turn off or calibrate the rumble motors and they do what they want xD unplayable...


    you don't need to be sorry, without you I wouldn't had even noticed I was using very old drivers xD so thank you bro :)



    But I'm curious if anyone else with Fanatec V3 pedals have the same problem in R3E.
     
    • Like Like x 1
    Last edited: Nov 16, 2019
  6. Skybird

    Skybird Well-Known Member

    Joined:
    Mar 31, 2015
    Ratings:
    +765 / 0 / -0
    No problems with my pedals. I just updated firmware this week since I installed my new shifter that arrived, and also drivers.

    The list by Fanatech and their update button is no messup, as I see it. The list in the link Homie provided, are all beta drivers, and beta drivers should not be presented as the latest default drivers, since they are indeed just - beta drivers. The latest default driver should be free of implicit risks that beta drivers can come with. If Fanatec implies that one or more of their beta-named drivers should indeed be default drivers - then they would have messed their homework up, and should fix it. I am on default driver 3.28, btw. Button-updated on Monday. Latest beta is 3.40. For the pedals it made no difference I would notice.

    If it works, dont touch it. Never change a working installation.

    Worth to try switching between pedals connected to the PC, and to the wheelbase. I have them linked directly to PC.
     
    • Informative Informative x 1
    Last edited: Nov 16, 2019
  7. HomieFFM

    HomieFFM Well-Known Member

    Joined:
    Dec 21, 2017
    Ratings:
    +280 / 0 / -0
    Alright thank you for the response, I'm still having no clue what causes this.
    Are you working with the Fanalab software? Does it have any effects in R3E ?

    Because no matter what I change (even everything disabled) it still keeps rumbling like with a non sense setup.

    The pedals itself are working perfectly without any trouble, it's just these rumblemotors which are going crazy.

    Ok thank you, gonna try that, because I have them directly connected into the base.
     
  8. Skybird

    Skybird Well-Known Member

    Joined:
    Mar 31, 2015
    Ratings:
    +765 / 0 / -0
    No FanaLab software in use over here. Was not even aware of it until you mentioned it. :) Since I have no hardcore DD wheelbase in use, I also do not think I care for it, I am happy with what I have, and how it is set up currently. So I do not invest the time for trying it.
     
    • Informative Informative x 1
  9. HomieFFM

    HomieFFM Well-Known Member

    Joined:
    Dec 21, 2017
    Ratings:
    +280 / 0 / -0
    Are you able to turn the rumble motors off in raceroom?
     
  10. RWB Charger

    RWB Charger Well-Known Member

    Joined:
    Nov 26, 2018
    Ratings:
    +94 / 0 / -0
    You can disable them in the controlset file, I hate the rumble so did this.
     
    • Like Like x 1
  11. Skybird

    Skybird Well-Known Member

    Joined:
    Mar 31, 2015
    Ratings:
    +765 / 0 / -0
    I don't know, since I never cared. The effect is so minor that I just do not mind it - like I did not care to switch the rumble on in AC via FanaLED.
     
  12. HomieFFM

    HomieFFM Well-Known Member

    Joined:
    Dec 21, 2017
    Ratings:
    +280 / 0 / -0
    Which point did you change in the controlset file? there are so many options xD
    I would be happy if I just could turn it off that way. Thank you for your help!
     
  13. HomieFFM

    HomieFFM Well-Known Member

    Joined:
    Dec 21, 2017
    Ratings:
    +280 / 0 / -0


    here is a small showcase of whats happening, I'm giving up now, tried everything.
    @RWB Charger would be very helpful if you can tell me what exactly you have done in the controlset to deactivate the rumble. thank you
     
  14. Christian G

    Christian G Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,332 / 0 / -0
    upload_2019-11-17_9-29-14.png
    If you set all of these settings to 0.0 it should be off.

    Did this issue start happening out of the blue, i.e. did the pedals work normally before and just started doing this or have you bought them recently and they did this from the get-go?

    In any case, this certainly isn't intended, so I'd suggest testing with a fresh documents folder first (the one called Raceroom Racing Experience in My Games/Simbin). Rename the existing folder and let the game create a new one. If the problem persists, you can delete the new folder and re-rename your old one.
     
    • Like Like x 1
  15. Andy Blade

    Andy Blade Well-Known Member

    Joined:
    Feb 21, 2016
    Ratings:
    +303 / 0 / -0
    Question no one has asked are pedals connected to pc or to wheel base ?
     
  16. HomieFFM

    HomieFFM Well-Known Member

    Joined:
    Dec 21, 2017
    Ratings:
    +280 / 0 / -0
    Ok thank you very much.

    I have them over 2 years now and never had any problems with raceroom, the rumble motors did actually a very good job, the rumble always made sense and added kind of good information what the car is doing.

    I can't tell a directly a time when this startet, but I have the feeling this started slowly and is now increasing. I always use headphones and 3-4 weeks ago I noticed some weird noise from time to time coming from the pedals, but ignored it and now it looks like in the video.

    Ok thank you, gonna try this with the document folder. Thank you for helping :)


    They are connected to the DD1 wheelbase, but I also tried them directly to the PC with the same result. Also made an fresh install of Raceroom, checked all drivers and cable connection, nothing helped xD

    Edit:
    Even setting all the FFB pedal settings to 0 didn't changed anything, they continue to rumble.
    Also letting the Sim create a new documents folder didn't have any effect.

    I think I'm gonna unplug these rumble motors xD
     
    Last edited: Nov 17, 2019
  17. Skybird

    Skybird Well-Known Member

    Joined:
    Mar 31, 2015
    Ratings:
    +765 / 0 / -0
    Homie,

    how are the pedals doing in other driving sims supporting the rumble motors? If they work fine there, then it is a setting in RR. If they work erratic there, too, then it is somethign with the Fanatech software - or hardware.
     
  18. HomieFFM

    HomieFFM Well-Known Member

    Joined:
    Dec 21, 2017
    Ratings:
    +280 / 0 / -0
    Other sims like rF2 and ACC doesn't have this rumble support, there I just use the ABS setting for the brake (so you get a brake rumble when you hit 80% of the brake for example) - works with no problem, non of the rumble motors goes crazy.
     
  19. Skybird

    Skybird Well-Known Member

    Joined:
    Mar 31, 2015
    Ratings:
    +765 / 0 / -0
    Try AC1 with FanaLED, I used FanaLED (longer time ago) to add rumble support to the rumble motors.

    I also think the rumbles work in ACC, but I must recheck that in an hour when i go racing. - There you have it, the rumbles are so minor to me that I do not even notice whether they are there or not.
     
    • Informative Informative x 1
  20. Skybird

    Skybird Well-Known Member

    Joined:
    Mar 31, 2015
    Ratings:
    +765 / 0 / -0
    Okay, no rumble in ACC as well, thats strange, I would have sworn that I once was positively surprised in the beginning to have it there without needing to use a secondary tool to activate it. Memory can be a bitch.
     
    • Funny Funny x 1