R3E Usage and FPS

Discussion in 'Hardware' started by Patrick.B, Jun 11, 2017.

  1. Patrick.B

    Patrick.B Well-Known Member

    Joined:
    Mar 20, 2017
    Ratings:
    +105 / 0
    Hi guys.

    I just bought a GTX1080 but im not able to reach 60 FPS with FULL Grid and Maxed Out Graphics .. here can u see my Usage at Spa with 55 AI. Started from Last Place ... i have a 1080p 60Hz screen (Single) i tried Vsync ON and OFF but it still the same Problem. Same as in rF2. what could it be ? newest driver is installed.

    Just for fun.. i have much better FPS at GTA 5 with maxed Out Grpahics. you can see the Usage at the other Pic. and here is also my Benchmark Result

    http://www.3dmark.com/3dm/20399663

    My PC

    I7 4790
    16GB RAM
    GTX1080
    Win10 - 64 Bit
     

    Attached Files:

  2. Nir Tal

    Nir Tal Member

    Joined:
    Aug 29, 2016
    Ratings:
    +24 / 0
    its a known issue in SPA - the 38% GPU usage just proves it.
    as a beta tester u should know better then me
     
    • Disagree Disagree x 1
    • Informative Informative x 1
  3. sbtm

    sbtm Well-Known Member

    Joined:
    Mar 29, 2016
    Ratings:
    +519 / 0
    he's just beta tester to get hands on new stuff early :p

    :D
     
    • Disagree Disagree x 1
    • Funny Funny x 1
  4. Sascha Reynders

    Sascha Reynders Well-Known Member

    Joined:
    Feb 18, 2016
    Ratings:
    +98 / 0
    I don't think so: I just ran a short race at Spa against 55 AI (starting in 56th position) in 4K (using Nvidia DSR) and apart from one small drop to 59 at La Source at the start, R3E ran at a solid 60fps with Vsync on.
    All graphics settings maxxed except for motion blur (high - fast), and 4xMSAA with 4xSSAA added in Nvidia Inspector. CPU usage was 50-80% and GPU usage 70-99%.
    So @Patrick.B , I see no reason why you shouldn't be hitting 60fps at 1080p on max graphics settings. Have you tried setting your 1080's power management mode for R3E to "prefer maximum performance" in Nvidia Control Panel (or Nvidia Inspector, if you're using that) ? When it's set to "adaptive" or "optimal power", it sometimes downclocks the GPU when you don't want it to. You could also try deleting your graphic_options.xml file and set your graphics settings again from scratch, see if that makes a difference. Deleting the ShaderCache.bin and letting it rebuild might be another thing worth trying.

    For reference, here are my benchmark results and you can find my system specs in the spoiler in my sig.

    Firestrike benchmark result.jpg

    Firestrike benchmark result 2.jpg
     
    • Like Like x 1
    Last edited: Jun 11, 2017
  5. Nir Tal

    Nir Tal Member

    Joined:
    Aug 29, 2016
    Ratings:
    +24 / 0
    • Informative Informative x 1
  6. ChatCureuil

    ChatCureuil Well-Known Member

    Joined:
    Feb 10, 2017
    Ratings:
    +307 / 0
    You can also check that you plugged your card on a PCI Express 3.0 16x slot, and not a x4 if your motherboard has also this kind.

    I did this mistake with a GTX 1060 and had to find why this card was slower than expected... :rolleyes:
     
  7. Manolete

    Manolete Member

    Joined:
    Feb 16, 2015
    Ratings:
    +5 / 0
    Hi test driver 376.09
     
  8. Patrick.B

    Patrick.B Well-Known Member

    Joined:
    Mar 20, 2017
    Ratings:
    +105 / 0
    Hello. Thanks for the Help Guys. @sbtm thats not funny...

    i talked with the Devs .. and they said that R3E are not able to use the full 8GB of my Card .. just 4 GB is possible. its a bug in the game and should be fixed soon. and as u alreday know... the game still DX9.. so we have to wait for Updates.

    @Manolete why Driver 376.09? do u have aby infos about it? im with Driver 382.53 (newest)

    @Sascha Reynders i tried your way but there was no better result.

    And i dont think that my I7 4790 Bottleneck my GTX 1080... because i have ~ 60% CPU usage and 99% GPU Usage in GTA5 with full Graphics... Also ~55% CPU and 98% GPU Usage at Dying Light with Full Graphics
     
  9. sbtm

    sbtm Well-Known Member

    Joined:
    Mar 29, 2016
    Ratings:
    +519 / 0
    ooooh.. I thought it was funny :(
    :rolleyes:
     
    • Agree Agree x 1
  10. Manolete

    Manolete Member

    Joined:
    Feb 16, 2015
    Ratings:
    +5 / 0
  11. Patrick.B

    Patrick.B Well-Known Member

    Joined:
    Mar 20, 2017
    Ratings:
    +105 / 0
  12. Manolete

    Manolete Member

    Joined:
    Feb 16, 2015
    Ratings:
    +5 / 0
    To tube the same problem and controller age
     
  13. Sascha Reynders

    Sascha Reynders Well-Known Member

    Joined:
    Feb 18, 2016
    Ratings:
    +98 / 0
    You could try an older driver version, but just a heads up in case you're on W10 with the Creators Update: driver 381.65 was the first one to add support for this update. I have no idea how important that is for the driver to function correctly though...
     
  14. Andy Kettler

    Andy Kettler Well-Known Member Beta tester

    Joined:
    Jan 15, 2015
    Ratings:
    +559 / 0
    As i said too much AI for the Cpu... And it will always be a Cpu limit when it comes to big grids AI in every sim...

    Looking at the overall Cpu usage is useless... Check the cores separat and you will see Core 0 on over 80%-90% usage and thats cleary it for the Cpu with 55 AI at Spa...

    This should help you to understand this: https://www.computerbase.de/forum/showthread.php?t=818979

    "Warum Du dabei nicht auf die CPU-Anzeige schauen sollst. Ist auch ganz einfach: Du siehst nur das Multitasking von Windows. Die Zeiten in denen eine CPU erst limitiert wenn sie zu 100% ausgelastet ist, ist mit der Einführung von Dualcores gestorben"
     
    Last edited: Jun 12, 2017
  15. Sascha Reynders

    Sascha Reynders Well-Known Member

    Joined:
    Feb 18, 2016
    Ratings:
    +98 / 0
    Not in my case, but OP should check for himself of course. The 50-80% CPU load I'm seeing is on cores 0, 1 and 3 and it was more often in the 50% than the 80% range. Core #2 usually has a slightly higher load, maybe because I limited affinity for certain processes (Crew Chief amongst others) to that core. I didn't even look at overall CPU usage to be honest.

    If my i5 (albeit overclocked) can handle 55 AI at 60fps, I don't see why OP's i7 couldn't. At default clocks both CPU's should be quite close in (gaming) performance, and I find it hard to believe that my system's 4.5ghz vs his 4ghz would account for a difference of 15fps.
    Just my 2 cents.
     
  16. Christian Göpfert

    Christian Göpfert Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,186 / 0
    Why?
    Remember that by overclocking your K CPU you're permanently raising the clock on all cores. I mean compare both of your firestrike scores, you're almost 2000 points higher, there's gotta be a reason for that.

    But maybe you guys should share your exact settings, including replay recording on/off and alike, stuff like that does have a major impact.
     
    Last edited: Jun 12, 2017
  17. Georg Ortner

    Georg Ortner Sector3 Developer

    Joined:
    Jan 13, 2015
    Ratings:
    +2,696 / 0
    One thing you can also try, is to delete your documents folder, and let the game create a new one, to start completely fresh (make a backup first, if you want to keep you car setups etc.), just to make sure it's not because of a modified or old setting in there.

    My Documents\My Games\SimBin\RaceRoom Racing Experience
     
    • Informative Informative x 1
  18. Rodent

    Rodent Well-Known Member Beta tester

    Joined:
    Dec 26, 2015
    Ratings:
    +318 / 0
    No, it's a bug with Windows 8/10 and DX9. Microsoft dropped that ball, and are thankfully fixing it.
     
    • Agree Agree x 1
  19. Sascha Reynders

    Sascha Reynders Well-Known Member

    Joined:
    Feb 18, 2016
    Ratings:
    +98 / 0
    I did some more testing tonight, both at 3840x2160 and 1920x1080, and I think I found the problem, or at least part of it: the motion blur and motion blur quality settings.

    At both resolutions I can crank up all graphics settings to the max (with 4xMSAA + 4xSSAA + FXAA at 3840x2160, and 8xMSAA + 8xSSAA + FXAA at 1920x1080) and stay at 60fps all throughout a race, as long as I set motion blur and quality no higher than "fast-high". From the moment I set it to "complex-high" or "fast-ultra", I suffer frame drops to the low 50's at La Source and at the top of Eau Rouge. When I set it to "complex-ultra", frames drop to the high 40's in these spots, and this at 1920x1080.
    So @Patrick.B , if you by any chance maxxed out the motion blur settings, set them to "fast"& "high" (or lower) and see if that fixes your fps problems.

    This I find a bit strange though...during my testing, max GPU memory usage was 61.1%, so roughly 5Gb.

    Anyways, hope this helps, cheers.
     
    • Informative Informative x 1
  20. Patrick.B

    Patrick.B Well-Known Member

    Joined:
    Mar 20, 2017
    Ratings:
    +105 / 0
    i will try it :)