Problem R3E will not display on 2nd monitor

Discussion in 'Community Support' started by Clearkill, Sep 21, 2019.

  1. Clearkill

    Clearkill New Member

    Joined:
    Aug 19, 2019
    Ratings:
    +0 / 0 / -0
    Hi, I am having an issue getting R3E on my ultrawide. In game, there is a setting to select which display to use. Whenever I try to change it from Display 1 to Display 2 (the ultrawide), nothing happens and the setting immediately reverts once I back out of the video settings page.

    I do not wish to set my ultrawide as the primary monitor, as it is on the rig about 15 feet from my desk. I would like to get the Display selection setting working properly. I've searched and found 2 other threads on this from 2017 but neither offered any solutions. Can someone please help?
     
  2. Hervé45

    Hervé45 Well-Known Member

    Joined:
    Jan 25, 2017
    Ratings:
    +46 / 0 / -0
    Delete graphics_options.xml ?
     
  3. Case

    Case Well-Known Member

    Joined:
    Apr 7, 2017
    Ratings:
    +98 / 0 / -0
    I've never tried this before and I don't have an ultrawide, but I don't seem to be able to make the game run on my second monitor either. If I select to run it on display 2, it stays on the primary monitor, and if I restart the game, it resets to the primary monitor.

    Up to date Windows 10 64bit pro, 1660Ti, monitors set to extend desktop.
     
  4. Balrog

    Balrog Well-Known Member

    Joined:
    Apr 10, 2015
    Ratings:
    +261 / 0 / -0
    Interesting, just out of curiosity, I checked it as well - I also have 2 monitors - and it works for me (although RaceRoom cannot use my second monitor's native resolution).
     
  5. Christian Göpfert

    Christian Göpfert Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,228 / 0 / -0
    This is a known "issue".

    I'm setting quotation marks because it can work, but only under the right circumstances.

    If you have edited your game's FOV to be anything but 1.0, switching to display 2 will not work.
    If you set the FOV to 1.0, the notification you see after switching to the 2nd display and clicking 'apply' will be slightly different and ask you to restart the game. If you do so, it should then start on display 2.
     
    • Informative Informative x 1
    Last edited: Sep 21, 2019
  6. Case

    Case Well-Known Member

    Joined:
    Apr 7, 2017
    Ratings:
    +98 / 0 / -0
    Yep, indeed, if I set the FOV to 1 (from my 0.7), then the display can be switched and the switch sticks. And it seems you can then adjust the FOV back to what you normally use and it will still stick with the secondary display.
     
    • Agree Agree x 1
  7. Balrog

    Balrog Well-Known Member

    Joined:
    Apr 10, 2015
    Ratings:
    +261 / 0 / -0
    Ah, so the game set the FOV value back to the default 1.0 because of my Index, that's why it works for me.:)
     
    • Agree Agree x 1
  8. Christian Göpfert

    Christian Göpfert Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,228 / 0 / -0
    Yep, all correct.
    Probably should have added that of course I reported it as a bug, so hopefully this bug shouldn't be with us for much longer. :)

    Ideally the game should also restart itself, or at least give a big red prompt to do so, the one we have right now looks just like the normal "apply changes, yes or no" notification.
     
  9. Clearkill

    Clearkill New Member

    Joined:
    Aug 19, 2019
    Ratings:
    +0 / 0 / -0
    Awesome, thanks guys. I will give this a shot next time I am on R3E.