Resolved RACE 07 mostly unplayable, crashes when track loads. Please fix this.

Discussion in 'Community Support' started by RoadRunner11, Jun 22, 2016.

  1. RoadRunner11

    RoadRunner11 New Member

    Joined:
    Aug 4, 2015
    Ratings:
    +0 / 0
    Hi

    There seems to be a serious problem that has been happening in one of your classic titles, RACE 07, recently. When a track loads up, the game crashes. It was never a problem previously, but it's been happening when joining the online servers and in single player mode. The only tracks that are playable at the moment are those from third party mods and add-ons (non Simbin/Sector3 tracks). Me and other RACE 07 players experience this same issue and are hoping that it is resolved soon.

    Thank you in advance.

    EDIT: As stated below, the last update/patch may have caused this to occur.
     
    • Agree Agree x 1
    Last edited: Jun 24, 2016
  2. theravenousbeast

    theravenousbeast Well-Known Member

    Joined:
    Jan 30, 2015
    Ratings:
    +152 / 0
    I can confirm this. I had just decided today to reinstall R07 and it crashes when loading a track all the time, with a minidump error. I didn't try MP though.
    Clean install, I tried it with only R07 and with some of the DLCs.

    Here are 2 minidump files from the crashes.
     

    Attached Files:

    • Agree Agree x 1
  3. Matthew_Wheeler

    Matthew_Wheeler Member

    Joined:
    Apr 20, 2016
    Ratings:
    +17 / 0
    What is in your GameData/Locations/shared folder?
     
  4. Pursang

    Pursang Member

    Joined:
    Jun 23, 2016
    Ratings:
    +7 / 0
    Same problem. All comunity of steam race07 players with same problem. Please fix it as soon as possible. Thanks.
     
    • Agree Agree x 1
  5. Matthew_Wheeler

    Matthew_Wheeler Member

    Joined:
    Apr 20, 2016
    Ratings:
    +17 / 0
    You're right, actually. I can't seem to load a track either...
     
  6. Matthew_Wheeler

    Matthew_Wheeler Member

    Joined:
    Apr 20, 2016
    Ratings:
    +17 / 0
    I believe that it's had something to do with the "Added support for track-side third-party advertisement campaigns" which was included in the patch late last year.

    Whilst Sector3 work on a fix, here's a temporary solution:

    Go into GameData\Locations
    Search for "IGA"
    Delete every folder called IGA
     
    • Winner Winner x 3
    • Like Like x 1
  7. Pursang

    Pursang Member

    Joined:
    Jun 23, 2016
    Ratings:
    +7 / 0
    That workaround seems work fine. Tested for some steam players.

    Thanks a lot.
     
  8. RoadRunner11

    RoadRunner11 New Member

    Joined:
    Aug 4, 2015
    Ratings:
    +0 / 0
    Thanks a lot man, appreciate it. Hopefully they release that fix (if any) soon.
     
    Last edited: Jun 23, 2016
  9. ThatSabineGirl

    ThatSabineGirl New Member

    Joined:
    Jun 15, 2016
    Ratings:
    +0 / 0
    I thought I'd broken the game because it first happened to me when I loaded the game after putting my own livery in...
    Hope it's fixed soon, this is one of my favourite sims. In the meantime, thanks for the IGA workaround, Matthew!
     
  10. camsgs13

    camsgs13 New Member

    Joined:
    Jun 24, 2016
    Ratings:
    +0 / 0
    I don't have that "IGA" folder in DameData/Locations :/ don't know what to do
     
  11. camsgs13

    camsgs13 New Member

    Joined:
    Jun 24, 2016
    Ratings:
    +0 / 0
    I have found all the "IGA" folders, I thought it was a single folder :p
     
    • Funny Funny x 2
  12. Yevgeny Lazorenko

    Yevgeny Lazorenko Well-Known Member

    Joined:
    Mar 29, 2015
    Ratings:
    +754 / 0
    Hello.
    Same problem here.
    Game crashes on loading screen.
    Here are the dumps.
     

    Attached Files:

  13. Yevgeny Lazorenko

    Yevgeny Lazorenko Well-Known Member

    Joined:
    Mar 29, 2015
    Ratings:
    +754 / 0
    There are plenty of "IGA" files there, I don't want to spend so much time deleting each, I'd better wait for hot-fix from the developers... I am already paid for the game, so I am asking myself why should I waste my time deleting each file that has issues?

    By the way, any news when it will be playable again? I just bought GTR Evo on sale, wanted to check it out and got punched in my face...

    And please, fix the main menu music, it doesn't play for a long time...
     
  14. Matthew_Wheeler

    Matthew_Wheeler Member

    Joined:
    Apr 20, 2016
    Ratings:
    +17 / 0
    Edit: Depending on the expansions, you might also need to delete all of the GMT files that come up with "IGA" in them. (I think this only applies to STCC, STCC2 and WTCC 2010 but it could include others). You can also delete all of the .scn files with "IGA" in them as well, but it's not necessary.


    Hopefully they will fix it soon. But we don't know when that will be, so I came across a work-around.
     
    Last edited: Jun 24, 2016
  15. theravenousbeast

    theravenousbeast Well-Known Member

    Joined:
    Jan 30, 2015
    Ratings:
    +152 / 0
    Just go into the Locations folder, search "iga" without the quotation marks and delete everything the search finds.

    It's really that simple.


    Off topic a bit, but one thing that I'd really love to see is for us (the players) finally being able to change the hidden AI settings in the PLR file without them resetting back to default. RACE really is a legacy title now and that would go a long way for offline racers that still play it. One of the few things that RACE had over GTR 2 is the AI but to be able to tweak it even further would be awesome.
     
  16. Yevgeny Lazorenko

    Yevgeny Lazorenko Well-Known Member

    Joined:
    Mar 29, 2015
    Ratings:
    +754 / 0
    Did this way, agree, that took less than minute.
     
  17. Matthew_Wheeler

    Matthew_Wheeler Member

    Joined:
    Apr 20, 2016
    Ratings:
    +17 / 0
    Completely agree. I find it quite odd that the default AI Corner Speed is only 0.93 when everything else is 1.0...
     
  18. ThatSabineGirl

    ThatSabineGirl New Member

    Joined:
    Jun 15, 2016
    Ratings:
    +0 / 0
    I wouldn't delete EVERYTHING it finds - there's other files which contain the letters 'IGA' together..

    I found just renaming all the .scn files containing IGA in the filename to .scn.null worked. Or you could delete them, but I didn't feel like doing that in case I needed to revert them in future. It doesn't have to be .null that you append, just anything that stops the game finding those files.

    That means just going to the locations folder, searching "*iga*.scn" without quotation marks and renaming the files.
     
    • Agree Agree x 1
  19. RoadRunner11

    RoadRunner11 New Member

    Joined:
    Aug 4, 2015
    Ratings:
    +0 / 0
    I deleted every IGA folder in the Locations folder, but certain tracks still does not work. Do I have to remove the IGA.scn files too?
     
  20. kendoslow

    kendoslow Active Member

    Joined:
    Apr 22, 2015
    Ratings:
    +44 / 0
    I didn't and it worked fine. Did you definitely get them all?