Race Reports Generation on Dedicated Server

Discussion in 'General Discussion' started by Lee aka Ginge, Mar 25, 2020.

  1. Lee aka Ginge

    Lee aka Ginge New Member

    Joined:
    Mar 25, 2020
    Ratings:
    +0 / 0 / -0
    Any help or suggestions welcome please...........

    I successfully run leagues for NXTGEN Racing on my created dedicated server but for the last two official rounds the Race Results file has not been generated so I'm not able to get all the stats and results. Has something changed in the last two weeks or is there a limit as to how many are stored and so I need to clear the old ones out to make space for new ones? I've tried the "Update Race Results" button on the server detail page but nothing has changed.

    Any pointers please?

    Thanks in advance.
     
    Last edited: Mar 26, 2020 at 2:34 AM
  2. Lee aka Ginge

    Lee aka Ginge New Member

    Joined:
    Mar 25, 2020
    Ratings:
    +0 / 0 / -0
    Any know anything please?
     
  3. Paul Darke

    Paul Darke Moderator Beta tester

    Joined:
    Jan 29, 2015
    Ratings:
    +216 / 0 / -0
  4. OldFart

    OldFart Member

    Joined:
    Aug 23, 2019
    Ratings:
    +24 / 0 / -0
    I have had the same; always by chance around the time I lose the sever setting so not had chance to troubleshoot, works fine after resetting the severs
     
  5. J-F Chardon

    J-F Chardon Sector3 Producer Developer

    Joined:
    Jan 15, 2015
    Ratings:
    +4,498 / 0 / -0
    Can you guys share the output.log located in C:\Users\[WINDOWS USER]\AppData\Local\Sector3_Studios_AB\logs
     
  6. OldFart

    OldFart Member

    Joined:
    Aug 23, 2019
    Ratings:
    +24 / 0 / -0
    Happy to, will it help as had to rebuild the servers again because of the ip problem so I cant pinpoint any that went missing
     
  7. J-F Chardon

    J-F Chardon Sector3 Producer Developer

    Joined:
    Jan 15, 2015
    Ratings:
    +4,498 / 0 / -0
    If you noticed a missing json file, try to share with me right after you noticed it:

    - The output.log (path above)
    - Maybe the game.log and mwtransport.log from the dedicated server (those get cleared after a while, so if it happened a while ago, you won't find the logs from that time where it failed). - Located in My Documents\My Games\RaceRoom dedicated\userdata\logs
     
  8. OldFart

    OldFart Member

    Joined:
    Aug 23, 2019
    Ratings:
    +24 / 0 / -0
    Thank you for your reply next time I notice it I will post to this thread if that is ok with you
     
    Last edited: Mar 26, 2020 at 6:26 PM
  9. Paul Darke

    Paul Darke Moderator Beta tester

    Joined:
    Jan 29, 2015
    Ratings:
    +216 / 0 / -0
    When you do make sure you tag J-F. He may miss it otherwise.
     
  10. OldFart

    OldFart Member

    Joined:
    Aug 23, 2019
    Ratings:
    +24 / 0 / -0
    Of course no problem at all
     
  11. Lee aka Ginge

    Lee aka Ginge New Member

    Joined:
    Mar 25, 2020
    Ratings:
    +0 / 0 / -0
    @J-F Chardon , I found this after taking some time trying to understand what I was looking for, the last time a report was generated or tried to be, the log recorded this message, and not produced another report since?? Is this what you are after:

    2020-03-02 10:33:46 ERROR ResultsUploader.UploadFileToHttp
    System.Net.WebException: The remote server returned an error: (503) Server Unavailable.
    at System.Net.WebClient.UploadFile(Uri address, String method, String fileName)
    at CommunityMultiplayer.Upload.ResultsUploader.UploadFileToHttp(Object file, Object httpUpload)


    @J-F Chardon
     
  12. keanos

    keanos Well-Known Member

    Joined:
    Oct 29, 2015
    Ratings:
    +98 / 0 / -0
    Is it possible you used the autoupload to raceroomresults in the past?