Problem Stuttering

Discussion in 'Community Support' started by Fanapryde, Oct 28, 2016.

  1. Christian G

    Christian G Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,310 / 0 / -0
    Cookie? ;)

    Glad you found the culprit, seems like there's a weird interference between nvidia vsync and game vsync, whoever caused it. (But when in doubt, blame nvidia [/setmessageinvisible for user @pixeljetstream ] ;) )
     
    • Funny Funny x 1
  2. Pullrod

    Pullrod New Member

    Joined:
    Mar 25, 2016
    Ratings:
    +3 / 0 / -0
    There is no option in my Nvidia Control panel for "fast" ..only on/off/adaptiv/half.
    Btw: my "stutter test track" is Zolder, esp. over the crest it stutters very bad.
    FPS are fine, minimum is about 44.
     
  3. Fanapryde

    Fanapryde Well-Known Member

    Joined:
    Jan 22, 2016
    Ratings:
    +409 / 0 / -0
    Weird... Mine has that option...
     
  4. Christian G

    Christian G Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,310 / 0 / -0
    Could you provide your system specs and in-game video settings?
    Also, make sure you got the latet drivers and that you did a clean install, meaning not through 3rd party application.
     
  5. Pullrod

    Pullrod New Member

    Joined:
    Mar 25, 2016
    Ratings:
    +3 / 0 / -0
    Sys: Board: Asus Z87-Pro (C2), CPU: i7 4770K@4100, RAM: 8GB Crucial Ballistix Sport, Grafic: MSI GTX 780 Ti Gaming, Power:750 Dark Power Pro 80+ Gold,
    SSD: 2x 120GB Samsung 840 Evo, Tactile: 4x Sinustec ST-BS 250 (Chassis-Mode), Motion Seat: SX 3000 / SCN5,
    Monitors: 3x 40" Samsung OS: Windows 10 64bit

    Latest driver (.70) clean install.
     
  6. Christian G

    Christian G Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,310 / 0 / -0
    Thanks. Anything noteworthy about your video settings? Are you using any form of vsync?
     
  7. Sascha Reynders

    Sascha Reynders Well-Known Member

    Joined:
    Feb 18, 2016
    Ratings:
    +103 / 0 / -0
    I used to have it too, but somehow on the latest GeForce 375.70 driver and NVinspector 2.1.2.0 I only have "standard" and "adaptive" o_O


    EDIT: my bad, I was looking at he wrong settings field... I do have it, but it's called 0x18888888 in NVinspector.
     
    Last edited: Nov 11, 2016
  8. Pullrod

    Pullrod New Member

    Joined:
    Mar 25, 2016
    Ratings:
    +3 / 0 / -0
    @Christian Göpfert

    Video settings: nothing special, atm "program settings" - R3E via Steam x86
    5821x1080 (with bezel correction)

    I have tried your hint " vSync in the Nvidia Control panel to fast and anabled in-game "
    (in my case instead of "fast" -> "on"). So far the best compromise.

    GeForce Experience is not installed.
     
  9. Christian G

    Christian G Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,310 / 0 / -0
    And in-game video/graphics options?
    Just asking because when you say your system is dipping below 60 fps that makes me suspect a general performance issue. Afaik (and from personal experience) going below 60 fps with vsync enabled can cause massive lag/stutter and the only fix for me was to lower some graphics options so I could reach stable 60 fps...
    Have you tried disabling replay recording already? (Right click game in steam, properties, launch options, enter -disableReplay including the hyphen)
    What's your shadow split setting, and shadow settings in general? Those can cost a lot of performance.
    'd be good if you could screenshots of your graphics settings.
     
  10. Pullrod

    Pullrod New Member

    Joined:
    Mar 25, 2016
    Ratings:
    +3 / 0 / -0
    Thx Chris!

    After some hours of testing ..

    right, when the fps is droping below 50 I recognize a slightly stutter.
    This only happens with lots of detailed things ( i.e. many trees) closed to the track (like Nords -Wippermann- / Zolder -crest- etc.)
    Nürburgring GP, Spa, etc. all is fine.

    Recording is -so far-on. I'll give it a try tomorrow.
    Shadow is set to medium, also reflections, .. (screenshot also tomorrow- enaugh for today) ;)

    Anyway, after the clean driver install, the Nvidia setting "vSync -on" and "in game on", the stutter is almost gone!
    Just the micro stutter -under some sircumstances- has to be ironed out ... if possible.
     
    • Like Like x 1
  11. Pullrod

    Pullrod New Member

    Joined:
    Mar 25, 2016
    Ratings:
    +3 / 0 / -0
    This morning I've tested some hours more .. and I'm happy again! :)
    Even with "replay on" it's fine now!!
    Thx!

    I hope this will help some of you guys:
     

    Attached Files:

    • Like Like x 1
  12. pixeljetstream

    pixeljetstream Well-Known Member Beta tester

    Joined:
    Jan 29, 2015
    Ratings:
    +391 / 0 / -0
    I felt a great disturbance in the Force with that post somehow
     
    • Funny Funny x 3
  13. pixeljetstream

    pixeljetstream Well-Known Member Beta tester

    Joined:
    Jan 29, 2015
    Ratings:
    +391 / 0 / -0
    how to find/fix/avoid stutter for developers
    https://developer.nvidia.com/sites/default/files/akamai/gameworks/CN/Stuttering_Analysis_EN.pdf
    https://developer.nvidia.com/sites/...gdc14/AvoidingCatastrophicPerformanceLoss.pdf

    if it occurred, for me setting max pre-rendered frames to 1 and enabling vsync in game + playing with vsync behavior in control panel improved the situation.
    I did run into a 59.9 vs 60 Hz situation as well in win7-970 (not win10 1080 anymore) as the tripples were connected differently (2 daisy chained DP + via hdmi, which is not ideal..). The DP monitors would run out of sync after like 15 minutes and go black shortly, after that things were normal again. Yes not ideal when driving ;)
     
    • Informative Informative x 1
    • Useful Useful x 1
  14. ElNino

    ElNino Well-Known Member

    Joined:
    Feb 7, 2015
    Ratings:
    +470 / 0 / -0
    I just fixed mine by changing full screen to "OFF"...problem solved. at least i know where to look next time - thanks all for the help.
     
  15. Fanapryde

    Fanapryde Well-Known Member

    Joined:
    Jan 22, 2016
    Ratings:
    +409 / 0 / -0
    You are on triples, right ?
    I tried that, but then I get a distorted image, unevenly spread...
     
  16. ElNino

    ElNino Well-Known Member

    Joined:
    Feb 7, 2015
    Ratings:
    +470 / 0 / -0
    Yes on triples, my nvidia settings are all default presumably aside from eyefinity (nvidia equivilent) setup. I just changed the full screen in R3E video settings to "off" and it cleared up the stuttering 100%, 5760x1080 looks same as before, just smooth fps.
     
    • Informative Informative x 1