Thrustmaster TX broken FFB

Discussion in 'General Discussion' started by Missed_The_Apex, Sep 8, 2020.

  1. Missed_The_Apex

    Missed_The_Apex New Member

    Joined:
    Jan 15, 2020
    Ratings:
    +1 / 0 / -0
    Seems to have happen over the last week or so but for some cars the tatus for example after a couple of corners the FFB jolts violently from left to right. Tried all different settings reinstalled driver for wheel but nothing has worked anyone else getting this problem because at the minute its looking like a game uninstall if it cant be fixed!
     
    • Agree Agree x 2
  2. PanVlk

    PanVlk Member

    Joined:
    Oct 12, 2019
    Ratings:
    +8 / 0 / -0
    First I'd try to load default controller profile. Have you tried other sims? It could be hardware issue.
     
  3. Missed_The_Apex

    Missed_The_Apex New Member

    Joined:
    Jan 15, 2020
    Ratings:
    +1 / 0 / -0
    Tried loads of stuff, turning off/down of all the settings nothing makes any difference, works fine in other games. Just gonna go for the uninstall, if I see fix mentioned somewhere I will reinstall it far to many games to waste time trying to fix this issue.
     
  4. BeefMcQueen

    BeefMcQueen Well-Known Member Beta tester

    Joined:
    Jun 26, 2018
    Ratings:
    +131 / 0 / -0
    Before uninstalling, please try the following: If decreasing collision effect in ffb settings down to zero doesn't help, you might try to also disable full damage when starting a new session.

    It's a known issue that some TM wheels and maybe some driver/firmware constellations are having problems rendering flatspots correctly.

    If the above doesn't help, please have a look here https://forum.sector3studios.com/index.php?threads/crazy-ffb-last-update.15222/page-2#post-205945
    Hope that helps!

    Oli
     
    • Informative Informative x 1
  5. Missed_The_Apex

    Missed_The_Apex New Member

    Joined:
    Jan 15, 2020
    Ratings:
    +1 / 0 / -0
    Thanks beefmcqueen, I have turned of collisions and also all the other settings 1 at a time and it still came back. The link you posted is the exact issue and also the same honda so I am going to try and edit the file as stated and see what happens.
     
    • Like Like x 1
  6. Missed_The_Apex

    Missed_The_Apex New Member

    Joined:
    Jan 15, 2020
    Ratings:
    +1 / 0 / -0
    @BeefMcQueen this fixed it for my thrustmaster TX

    This was mine
    FFB flatspot magnitude="0.35" // How strong the flatspot rumble is. Range 0.0 to 1.0, 0.0 disables effect.
    FFB flatspot wave type="0" // Type of wave to use for vibe: 0=Sine, 1=Square, 2=Triangle, 3=Sawtooth up, 4=Sawtooth down.

    Ichanged the magnitude to this and it stopped it.
    FFB flatspot magnitude="0.0" // How strong the flatspot rumble is. Range 0.0 to 1.0, 0.0 disables effect.
    FFB flatspot wave type="0" // Type of wave to use for vibe: 0=Sine, 1=Square, 2=Triangle, 3=Sawtooth up, 4=Sawtooth down.
     
    • Informative Informative x 1
    • Wonderful Wonderful x 1
  7. BeefMcQueen

    BeefMcQueen Well-Known Member Beta tester

    Joined:
    Jun 26, 2018
    Ratings:
    +131 / 0 / -0
    Great to hear that it works for you now!
    It seems really difficult to figure out what exactly causes this error with certain TM constellations, but the devs are on it. There will hopefully be a solution soon, so that everyone can use the flatspot feature properly.

    Oli
     
  8. GooseCreature

    GooseCreature Well-Known Member

    Joined:
    May 30, 2015
    Ratings:
    +602 / 0 / -0
    If this problem returns, which I fear it may, there is a bit of software called usbdview.
    Once installed, open it and check there are no disconnected devices, especially TM wheels, if so uninstall them. I check just before I run RR and get rid of any new ones. I have not had an issue since I began doing this over a week ago. Believe it's a TM firmware issue.
     
    • Informative Informative x 2