VR Performance Tweaks & Tips

Discussion in 'General Discussion' started by Thomas Jansen, Apr 19, 2019.

  1. Thomas Jansen

    Thomas Jansen Well-Known Member Beta tester

    Joined:
    Apr 5, 2018
    Ratings:
    +232 / 0
    I have a batch file to start raceroom which also sets the SS in the debug tool. I'm pretty sure this is exactly what the tray tool does anyway, so either works :p
     
  2. FormelLMS

    FormelLMS Well-Known Member

    Joined:
    Apr 8, 2015
    Ratings:
    +119 / 0
    Is it okay to upload here? Do you change ASW OFF in this batch file, too? And start Crew Chief? Oh, and.... :)
     
  3. Heath

    Heath Well-Known Member Beta tester

    Joined:
    Nov 5, 2016
    Ratings:
    +103 / 0
    Set ASW off in debug tool to disabled run as admin and leave it open or it resets to auto. As @Thomas Jansen mentioned earlier ss parameters are better off being set in debug tool aswell. :D oh almost forgot close oculus home first , before running debug tool otherwise your adjustments you make won't take effect....
     
    Last edited: Apr 23, 2019
  4. FormelLMS

    FormelLMS Well-Known Member

    Joined:
    Apr 8, 2015
    Ratings:
    +119 / 0
    According to this thread:
    Does someone see an advantage in using Oculus Tray Tool over Debug Tool?
    It's nice to have set some things automatically as ASW on/off, but for me I think VR is a bit fragile, so having another program, what has to be up to date and developed the next years, could bring other problems.
     
  5. Goffik

    Goffik Member

    Joined:
    Jun 30, 2017
    Ratings:
    +16 / 0
    It allows you set options you don't have to keep setting every time you restart, has some tweaks not available in the debug tool, and has other useful features besides. I think it's well worth using. As far as I can see it contains nothing that would suddenly cause instability or other problems, at least, nothing the debug tool can't also cause.
     
    • Like Like x 1
  6. Bull Shark

    Bull Shark Active Member

    Joined:
    Mar 14, 2019
    Ratings:
    +27 / 0
    I never bother using those apps/tools. I have a steady FPS without fiddling around.
     
  7. .OG Isaac

    .OG Isaac Well-Known Member

    Joined:
    Feb 17, 2015
    Ratings:
    +163 / 0
    Sadly I can't use supersampling when using opencomposite, and playing at 1x is too ugly to even spot a braking marker; will have to use SteamVR for now.. :(
     
  8. Goffik

    Goffik Member

    Joined:
    Jun 30, 2017
    Ratings:
    +16 / 0
    I don't use it for FPS tweaks. For example, one of the best features for me is that it allows me to minimise Oculus to the system tray, off my taskbar and out of ALT-Tab range. I hate unnecessary clutter.
     
    • Like Like x 1
  9. FormelLMS

    FormelLMS Well-Known Member

    Joined:
    Apr 8, 2015
    Ratings:
    +119 / 0
    How much supersampling are you using in SteamVR?
    I ask because it could be, that your supersampling in opencomposite is bigger, than in SteamVR.
     
  10. .OG Isaac

    .OG Isaac Well-Known Member

    Joined:
    Feb 17, 2015
    Ratings:
    +163 / 0
    2.0 mostly, 2.2 if I know i'm just going to be lapping a certain track alone.
     
  11. Whipdiddywhip

    Whipdiddywhip Member

    Joined:
    Aug 20, 2017
    Ratings:
    +9 / 0
    if you want 90 fps turn shadows off

    you will not hit 90 fps all the time with shadows or car shadows on, only use contact shadows

    i get a constant 90 fps with my settings

    all are on low or off apart from circuit detail - high
    all texture settings - high
    contact shadows - 18
    visable cars - 18
    shaders - high
     
  12. Sebastien Brunier

    Sebastien Brunier Member Beta tester

    Joined:
    Dec 17, 2017
    Ratings:
    +18 / 0
    You can't really compare SteamVR SS and OpenComposite SS values, I have same GPU than you and I was using 200% in SteamVR with only 2xAA in-game settings, now I use 1.2 PPDO and 4xAA ingame, I have better clarity now, better depth of view and so much smoother fps.

    For some reasons (could be placebo but found it better) using supersampleRatio=1.2 in opencomposite.ini with default PPDPO wasn't as smooth as leaving supersampleRatio=1.0 in opencomposite.ini and forcing the PPDPO with OculusDebugToolCLI.exe you need to create a batch for that as said by Thomas.

    Batch file is quite simple called it R3E.bat (change the paths to what matches your config ofc)
    "C:\Program Files\Oculus\Support\oculus-diagnostics\OculusDebugToolCLI.exe" --file "D:\Program Files (x86)\Steam\steamapps\common\raceroom racing experience\PPDO.txt"
    "C:\Program Files (x86)\Steam\Steam.exe" -applaunch 211500 -vr
    timeout /t 10>nul
    wmic process where name="RRRE64.exe" CALL setpriority "above normal"
    wmic process where name="OVRServer_x64.exe" CALL setpriority "above normal"​


    The PPDO.txt file (must be in UTF-8 you can do it in Notepad++)
    service set-pixels-per-display-pixel-override 1.2
    server:disableUsbPowerMgmt
    server:asw.Off
    exit​

    opencomposite.ini settings
    supersampleRatio=1.0
    enableLayers=true
    enableCubemap=false
    threePartSubmit=true
    useViewportStencil=true
    dx10Mode=true​

    Leave your in-game graphics settings as is for now, but you should notice a great performance increase.

    After if you want to give a try to my exact graphics settings:
    Toggle Mirrors............On
    Track Level of detail.....Medium
    Car LOD Distance setting..Low
    Particle detail...........Low
    Tiremarks.................On
    Specular..................Off
    Car reflection quality....Low
    Track animations..........On
    Shadows...................Lowest
    Car shadows...............On
    Contact shadows...........32
    Shadow split..............Off
    Multi-Sampling............4xAA
    FXAA......................Off
    Bloom.....................Off
    Depth of field............Off
    Motion blur quality.......Low
    Lightshafts...............Off
    Lens effects..............Off
    Track texture quality.....High
    Car texture quality.......High
    Rear view mirror quality..Low
    Shader quality............Medium
    Corner markers............Off
    Visible cars..............20
    Opponents cockpits........Off
     
    • Like Like x 2
    Last edited: May 7, 2019
  13. FormelLMS

    FormelLMS Well-Known Member

    Joined:
    Apr 8, 2015
    Ratings:
    +119 / 0
    Trying the batch file now.
    How can I check if the PPDO file is taken correctly? I did everything you wrote, apps are starting, but when I check the Oculus Debug Tool is on PPD 1.0 and ASW on Auto.
    Oh, a nd I try to open Crew Chief an TS3 Client with the batch, but the batch file stops after opening the first programm and runs ahaed only when this program is closed :(
     
    Last edited: May 6, 2019
  14. Sebastien Brunier

    Sebastien Brunier Member Beta tester

    Joined:
    Dec 17, 2017
    Ratings:
    +18 / 0
    Ok so despite still being documented, seems like disabling ASW and USB power management commands are deprecated now...
    Ok my bad, wrong use of the arguments in the CLI now it works !
    But setting SS still works, and is displayed correctly in my Oculus Debug Tool.

    upload_2019-5-7_19-42-52.png

    Just make sure the PPDO.txt file is in UTF-8 coding I've done it with Notepad++ not sure what Windows Notepad does...
    upload_2019-5-7_19-43-48.png

    upload_2019-5-7_19-45-16.png
     
    Last edited: May 7, 2019
  15. Bull Shark

    Bull Shark Active Member

    Joined:
    Mar 14, 2019
    Ratings:
    +27 / 0
    Nice, will try the batch myself. Always handy to have.
     
  16. Sebastien Brunier

    Sebastien Brunier Member Beta tester

    Joined:
    Dec 17, 2017
    Ratings:
    +18 / 0
    Erm, you have an issue with the OculusDebugToolCLI.exe then because it's the first one launched, check the paths to the exe and txt file maybe, or the quotes for the paths.
    If you want to compare with my files, please find them attached.

    New version of the PPDO.txt file ASW Off and USB power managenent properly disabled! (fixed)
     

    Attached Files:

    • Like Like x 1
    Last edited: May 7, 2019
  17. Sebastien Brunier

    Sebastien Brunier Member Beta tester

    Joined:
    Dec 17, 2017
    Ratings:
    +18 / 0
    Edit: found how to fix Disabling ASW via CLI (PPDO.txt file updated in previous post) all screen shots and CLI updated in the posts. Hope it will help!
     
    • Like Like x 1
  18. FormelLMS

    FormelLMS Well-Known Member

    Joined:
    Apr 8, 2015
    Ratings:
    +119 / 0
    Ah, this is awesome!
    All the Oculus things are working fine.

    But I've one question though.
    I want to start Crew Chief, TeamSpeak and Raceroom, but the batch hung after CrewChief. It waits for something and only goes ahaed when closing Crew Chief. Then it loads TeamSpeak and waits again and only after closing, it goes ahaed to the next and so on.

    I've uploaded my file. I guess I made a mistake with my batch file.


    Edit: Nevermind. Solved it with e.g. "start "TS" "C:\Program Files\TeamSpeak 3 Client\ts3client_win64.exe"

    So now I'm searching for the argument to start the CrewChief after launching this application, then I'm done here :)
     

    Attached Files:

    Last edited: May 7, 2019
  19. Sebastien Brunier

    Sebastien Brunier Member Beta tester

    Joined:
    Dec 17, 2017
    Ratings:
    +18 / 0
    for CrewChief, do it in two steps like that:

    cd "C:\Program Files (x86)\Britton IT Ltd\CrewChiefV4\"
    cmd.exe /C start CrewChiefV4.exe
     
    • Like Like x 2
  20. neil

    neil Member

    Joined:
    Sep 18, 2016
    Ratings:
    +10 / 0
    unfortunately OC has stopped working, game loads but VR doesn't load.