VR (WMR) Not Working in RaceRoom For Me

Discussion in 'General Discussion' started by newbert, Nov 24, 2018.

  1. newbert

    newbert New Member

    Joined:
    Nov 24, 2018
    Ratings:
    +0 / 0 / -0
    I cannot get RaceRoom to run in VR (actually Windows Mixed Reality) using my Lenovo Explorer Headset. RR runs fine in single screen, but when I use these steps (that I read in the VR thread),

    "In your Steam client library, right click RaceRoom and select "Properties".
    - In the Properties pop-up window, under the "General" section, click the "Set Launch Options..." button.
    - In the dialog box that opened, just type in "-vr" (without the quotation marks) and it will use the default value for render target multiplier, which we currently have set to 1.5."

    I get 4 choices on how to run RR - 32 bit VR, 64 bit VR, 32 bit non-VR and 64 bit non-VR. No matter which I choose, Windows Mixed Reality loads, then a black screen on both the headset and monitor. When I C-A-D to get out of it, the opening RR music starts right away, but the screen(s) remain black.

    Once I remove "-vr" from RR's properties in Steam, it runs fine, but only on single screen.

    My system runs PC2, iRacing and AC just fine in VR. Only RR is giving me problems.

    Can anyone suggest anything I can try to get RR to run in VR (and explain it as simply as possible, since I'm new to VR)? Maybe I'm leaving out a step somewhere?

    Thanks!
     
  2. Leynad

    Leynad New Member

    Joined:
    Apr 27, 2015
    Ratings:
    +2 / 0 / -0
    You need to start 2D first and map a button for the center VR HMD (or similar, can't remember). You can use the button when the music begins and there is another button you can bind to mirror VR to the display. You can also use "-vr 2.0" for example in the properties, if you want 2x Supersampling or maybe 2.5 if you can. I would also turn of shadows, because they are flickering as hell.

    Maybe some can tell me how to disable that the mouse is bind to the window in window-mode. When i switch screens and i must because of Sim Commander, the mouse often doesn't work in the WMR-headset and win+y doesn't function. Very annoying and RR-only problem...
     
  3. KudBkuik

    KudBkuik Member

    Joined:
    Mar 8, 2016
    Ratings:
    +19 / 0 / -0
    I'm not sure this will 100% solve the issue for you but; from the game, I always Alt+tab, then press the Windows key to get mouse control for other programs. After I'm done, click on the game icon in taskbar and the focus is back on the game.
     
  4. newbert

    newbert New Member

    Joined:
    Nov 24, 2018
    Ratings:
    +0 / 0 / -0
    Thank you so much for this! That worked for me. I never would have figured it out in a million years.

    Now that I have VR working (hopefully permanently), is there a guide somewhere as to the best graphics settings to use in VR (to maximize clarity without taking too much of a performance hit)?

    Thanks again!
     
  5. Onaflyer

    Onaflyer Well-Known Member

    Joined:
    Feb 28, 2017
    Ratings:
    +52 / 0 / -0
    When the mouse doesn't work for me I use the wmr controller to go back to cliffhouse (main thumb button) and aim the pointer at steam VR window and click it with trigger. That will make everything work back in Raceroom correctly.
     
  6. Leynad

    Leynad New Member

    Joined:
    Apr 27, 2015
    Ratings:
    +2 / 0 / -0
    Sorry guys, but both "solutions" are not acceptable and Sector3 should just get their shit together and fix this ridiculous bug with WMR-headsets. Till then i watch RR on YouTube, but not launching this bullshit. And since iRacing, rF2 and pCars 2 can do their job, no need for RR anyway.
     
    • Dislike Dislike x 2
    • Disagree Disagree x 1
    • Funny Funny x 1
    Last edited: Nov 25, 2018
  7. spyshagg

    spyshagg Active Member

    Joined:
    Dec 7, 2015
    Ratings:
    +34 / 0 / -0
    In VR, when in doubt, always turn around!
     
    • Like Like x 1
  8. keanos

    keanos Well-Known Member

    Joined:
    Oct 29, 2015
    Ratings:
    +118 / 0 / -0
    As far as I know there is no need for the -vr command anymore, because R3E is a native VR Application since one of the last patches. So it will be shown if you filter for your owned VR Applications in the steam library.

    All settings for the Supersampling, will be done via the Steam VR Options.