Resolved Workaround if you cannot join your own dedi server

Discussion in 'Community Support' started by Christian Göpfert, Apr 1, 2016.

  1. Nuno Macedo

    Nuno Macedo New Member

    Joined:
    May 25, 2016
    Ratings:
    +1 / 0
    Hi

    I acquired this Dell T5500 (win 10) server and now i can´t join my own sessions.
    Mounting a dedi server on my PC (win 7), using the loopback adapter, it runs perfectly and i can join any session. Using the server or a laptop in the same network i always get "no response from server". Outside players can join.
    Runs perfect with other know sims but this....
    I tryed every step mensioned in previous topics with no results. Also called my ISP to turn off any NAT filter since my router don't show such funcionality. They say that filter turns off everytime i set specific ports.

    Any tips? This is annoying....
     
  2. Racki

    Racki Well-Known Member Beta tester

    Joined:
    Aug 17, 2015
    Ratings:
    +114 / 0
    Could you describe in more detail which special configs you use on your dedi/pc/router?

    loopback is only successful if the dedi is on the same machine as the gaming (packets don't leave the machine but are 'looped-back' to itself)
     
    • Like Like x 1
  3. Nuno Macedo

    Nuno Macedo New Member

    Joined:
    May 25, 2016
    Ratings:
    +1 / 0
    Router IP is 192.168.1.1
    - Active DMZ to 192.168.1.2
    - Port forwarding set to 192.168.1.2 no external IP (also tried with my esternal IP)
    - Active ports TCP 60000-60050 & UDP 60000-60050 - TCP/UDP 9600 for other funcional sim

    Server set with fixed IP: 192.168.1.2 - Sub-mask 255.255.255.0 - Gateway 192.168.1.1

    PC with fixed IP 192.168.1.3 - Sub-mask 255.255.255.0 - Gateway 192.168.1.1
    Loopback off at the moment

    If there is other info u need just mention pls
     
  4. Racki

    Racki Well-Known Member Beta tester

    Joined:
    Aug 17, 2015
    Ratings:
    +114 / 0
    okay, so far so good ;)

    dmz functionality forwards all(!) ports to a designated internal ip address, which might be a security issue in most cases.

    your described tcp and udp port forwardings should be more than sufficient. the forwarding address has to be the 192.168 address from your dedi.

    the next thing to check is to browse and connect to your dedi from outside your network. you can use lte tethering with your notebook, your neighbours computer or what so ever.
    check this first because it decides which troubleshouting road to go next.

    whats the make and model of your router?
    ill try to find out if it supports nat loopback
     
    • Like Like x 1
  5. Nuno Macedo

    Nuno Macedo New Member

    Joined:
    May 25, 2016
    Ratings:
    +1 / 0
    Router is a Huawei HG8247H

    You said "the forwarding address has to be the 192.168 address from your dedi."
    IP is incomplete?!

    The real issue is that anyone can join the server but me.
    Btw... maybe i´m wrong but, deactivating the DMZ no one can access de server... need to test again
     
    Last edited: Aug 1, 2017
  6. Racki

    Racki Well-Known Member Beta tester

    Joined:
    Aug 17, 2015
    Ratings:
    +114 / 0
    You are right with 192.168.1.2 on your port forwarding configuration. I just wrote 192.168 to make clear not to enter your routers public IP there.

    It seems obvious that your router does not support nat loopback mode. Thats the problem here.
    Perhaps you can replace your Huawei with another brand. I just found this list on the first result page from google: http://opensimulator.org/wiki/NAT_Loopback_Routers

    If this is not possible (because of limitations of your internet provider...) I suggest a hacky workaraound solution:

    1. Take a note of the public IP address of your router
    2. Open the network configuration of your dedicated server and enter the same public address as additional address on the network card IPv4 settings. As subnet mask use 255.255.255.0
      see this video for tutorial:
    3. On your PC also open the network card settings and also enter an additional IP address. Use the same first 3 numbers from the public IP but for the fourth number use another number. It doesn't matter as long it is not 0, 255 or the same from the dedi.
    4. For testing disable the windows firewall on your dedi

    I hope this solves your problems :)
     
    • Like Like x 2
  7. Christian Göpfert

    Christian Göpfert Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,167 / 0
    Thanks for chiming in here Racki.
     
    • Like Like x 1
  8. Nuno Macedo

    Nuno Macedo New Member

    Joined:
    May 25, 2016
    Ratings:
    +1 / 0
    Hell YEAH :smiley:

    Racki, thank you soooooo much mate.

    works perfect, i can join now. :hearteyes:
     
    • Like Like x 1
    • Winner Winner x 1
  9. Racki

    Racki Well-Known Member Beta tester

    Joined:
    Aug 17, 2015
    Ratings:
    +114 / 0
    Wohooo! Great to hear that :D
     
    • Like Like x 1
  10. SPEKTRE76

    SPEKTRE76 Member

    Joined:
    Mar 4, 2016
    Ratings:
    +17 / 0
  11. Racki

    Racki Well-Known Member Beta tester

    Joined:
    Aug 17, 2015
    Ratings:
    +114 / 0
    I don't think public IPv6 addresses already work with the server application.
    Did you try to join your server from outside your network? If this doesn't work either I fear there is no solution at the moment.
     
  12. SPEKTRE76

    SPEKTRE76 Member

    Joined:
    Mar 4, 2016
    Ratings:
    +17 / 0
    Well there goes my KTM X-Bow Rookies Challenge. :( Are there server rentals for RRE3?

    [​IMG]
     
  13. Miquel

    Miquel New Member

    Joined:
    Aug 2, 2017
    Ratings:
    +1 / 0
    Yes, It works! thank you very much.
     
    • Like Like x 1
  14. Nicklas Petersson

    Nicklas Petersson New Member

    Joined:
    Jan 1, 2016
    Ratings:
    +4 / 0
    Lets see if i can describe my problem in an understandable way.
    I have 1 Server-PC och 1 Gaming-PC. When i join one of my own servers, it takes approx 1 minute, then i´ll get kicked out from it. After i immediately re-joined it again, its no problem anymore. No kicked out and i can practice and race. There´s no problem for me joining other servers and others can join my servers.
    I´ve been looking for someone with the same problem that i´ve encountered, but nothing.

    Router: Asus N66U
    Port forwarding 60000,60002 UDP, 60001 TCP... and so on the the other servers.

    I dont know if this is the right forum for my problem or if the problem lays in the server or the gaming-PC, i´m just scratching my head. :)

    Best regards.
     
  15. Christian Göpfert

    Christian Göpfert Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,167 / 0
    Hi Nicklas,

    this sounds a bit like you might get kicked from your own server for a bad ping somehow... Do you have the ping limit function enabled on your server(s)? If so, this might be causing you to get kicked. To narrow the problem down, try disabling the limiter.

    Somewhat related to that issue, how is your gaming PC connected, are you using WiFi by any chance? Here J-F explained how WiFi can create a problem when using the ping limiter: https://forum.sector3studios.com/in...room-has-been-updated.8857/page-3#post-125618
     
    Last edited: Jan 21, 2018
  16. Nicklas Petersson

    Nicklas Petersson New Member

    Joined:
    Jan 1, 2016
    Ratings:
    +4 / 0
    Thanks for the quick answer.
    I have wired connection from router to a switch and also wired conn forward to the two computers.
    In general, i haven´t seen or recognised any bad ping in the house. But if the game is kicking me out because of it, i surely would like to find the problem.

    Question... You mentioned ping limit function? Is that the "max ping" option in the serverprogram you meant? or anything else?
    In Max ping, there isn´t any disable button in the dropdown... Feeling kinda noob here. :)

    The kickout comes exactly at the time when i get the Green Flag Go up in the left corner. And when i come back to the lobby, it says Connection Lost.

    I´m gonna try and attach the server-computer directly to the router instead of the switch.

    20180121195605_1.jpg 20180121195613_1.jpg
     
  17. Nicklas Petersson

    Nicklas Petersson New Member

    Joined:
    Jan 1, 2016
    Ratings:
    +4 / 0
    I bypassed the switch and connected the server directly to the router, but it didn´t change anything, i still get kicked out.
    How about this ping limit function, where can i disable it?
     
  18. Pascal Malenfant Tremblay

    Pascal Malenfant Tremblay New Member

    Joined:
    Mar 19, 2018
    Ratings:
    +0 / 0
    Does anyone have been able to find a good workaround to join it's dedicated server on a 2nd PC on the same LAN? It seems that the loopback work well for the same computer (Game and Dedicate server) but it does not work if the server is on another PC. I might be wrong, or I am doing something wrong.

    I was able to join the dedicated server when it was on my Game PC, so I assume that the ports are forwarded correctly.
    Then I copied the RR Server to my Server PC on the same LAN, but now I cannot join my own server (other outside players can).

    Here's my setup:
    ->ISP Modem+Router (Bell Hub 3000 fiber)
    \--> LAN port plugged to my router (TP-link Archer C7)
    \-Gaming PC plugged on the router C7. (Microsoft adapter loopback is set to public address)
    \-RR Dedicated server PC plugged on the router C7

    The ports are forwarded in the C7 and in the ISP router. The C7 is also "DMZ" in the main ISP router.

    RR Server PC is on W7
    Gaming PC is on W10

    Any help will be really appreciated. I can even shime some $ to the one who manage to resolve the issue! :)
    Thanks in advance,
     
  19. Christian Göpfert

    Christian Göpfert Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,167 / 0
    You could try this hack @Racki posted: https://forum.sector3studios.com/in...-your-own-dedi-server.4672/page-4#post-125042

    But it should also work using the loopback adapter. Have you tried using that?
     
  20. Pascal Malenfant Tremblay

    Pascal Malenfant Tremblay New Member

    Joined:
    Mar 19, 2018
    Ratings:
    +0 / 0
    Thanks for the quick update and support. Yes I had tried to add a 2nd IP address on both computers, in reference with the thread you linked there, but it did not work. I will give it another shot, maybe I missed something there. The DHCP is managed by my C7.

    Regarding the loopback adapter, do I need to install it on the Dedicated Server too? I have it on my PC, pointing to my public IP address, which worked when the server was on the same PC.
    I've added it to the Dedicated Server PC, but it did not help.