Problem Dedicated server crashes after a while

Discussion in 'Community Support' started by nipaka73, Jul 7, 2019.

  1. nipaka73

    nipaka73 New Member

    Joined:
    Apr 4, 2019
    Ratings:
    +1 / 0
    Hi,

    I am running RaceRoom dedicated server on Windows 10 Pro on a virtual server.
    I can start it and it works a while but after a few hours it shows the following errors:

    [ERROR] 11:16:42 AnnounceServer
    [ERROR] 06:12:47 AnnounceServer

    When I try to launch it via WebInterface the follwoing message appears:

    [ERROR] 12:44:27 DedicatedServerProcess.Process.Start

    After this message I have to close the dedicated server and start it again.

    Then it starts all over again.

    Does anyone has an idea what I colud do?

    Br,
    Kai
     
  2. nipaka73

    nipaka73 New Member

    Joined:
    Apr 4, 2019
    Ratings:
    +1 / 0
    I had a look to the log files and it tells me that: remote host closed the connection. Which remote host? The Client?

    and the System cannot find the specified file. Which file? Is it a file-stream which cannot be found?
     
  3. nipaka73

    nipaka73 New Member

    Joined:
    Apr 4, 2019
    Ratings:
    +1 / 0
    I could not attach the message because of a SneakyURL in the text I attached
     
  4. nipaka73

    nipaka73 New Member

    Joined:
    Apr 4, 2019
    Ratings:
    +1 / 0
    Today the server crashed again:

    upload_2019-7-10_9-54-38.png

    I got this error message.
    Is there a documentation availbale where I can see how much memory the dedicated server needs and how many CPUs?
     
  5. Christian Göpfert

    Christian Göpfert Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,188 / 0
    Hi @nipaka73 , what's your setup and hardware specs exactly? Usually one dedicated server instance shouldn't need excessive amounts of RAM or CPU power.
     
  6. nipaka73

    nipaka73 New Member

    Joined:
    Apr 4, 2019
    Ratings:
    +1 / 0
    Hi Christian,

    my server is a virtualized server with

    1 CPU (6 cores) Intel Xeon CPU E5-2660 2.20GHz
    6GB memory
    200 GB SSD disk
    1 GBit network interface.

    So I guess it is not a good idea to have a virtualized server for dedicated Raceroom server?


    Br,
    Kai
     
  7. Christian Göpfert

    Christian Göpfert Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,188 / 0
    Hi, I'm still not 100% sure about your setup. Is this a Local PC on which you run a VM or is it a rented cloud server?
    The specs look alright to me, this should be well capable of handling at least one server instance of the dedi.exe, provided there's nothing else running on it?

    Have you already tried restarting the server? I noticed MS seem to have rolled out some .net updates for Win10 recently, maybe your server hasn't performed that yet?

    So please restart your server and check for Win updates. If the error keeps happening after that, quit the process, find the file called output.log in Users\abc\AppData\Local\Sector3_Studios_AB\logs and attach it here.

    PS: If you can and want to, feel free to join our discord and contact me there, it's easier to communicate. ;)
    https://discordapp.com/invite/Raceroom
     
  8. nipaka73

    nipaka73 New Member

    Joined:
    Apr 4, 2019
    Ratings:
    +1 / 0
    Hi,

    so it is a virtual cloud server which I rented.
    I am alreday in the Raceroom Discord Channel.
    Where can I post server related things?

    Br,
    Kai