Resolved Fanatec Missing Device

Discussion in 'Community Support' started by Kitsune Magyar, Jun 8, 2017.

  1. Kitsune Magyar

    Kitsune Magyar Professional Betatester Developer

    Joined:
    Dec 12, 2016
    Ratings:
    +9,233 / 0
    We sneakily deployed a patch and the rims should now be detected correctly, this is only for the Default Profile. To update an existing profile read this guide I made, deleted, and then brought back from the dead.

    ID numbers for Fanatec Rims have been changed and as a result cats and dogs are best friends, rain falls up and your BMW rim is missing but for some reason you now have a Formula rim.

    Fear not, there is a workaround. Locate your controller profile... file:
    Documents\My Games\SimBin\RaceRoom Racing Experience\UserData\ControlSet

    Locate the following line in the profile file you're using:
    DeviceId[00]="(xxxxxxxx, x, X, x)" [There will be actual numbers, not x:es.]

    See that big fat red X? That's where the number you want to change will be. Depending on the rim you're using, it will be a different number. Here's a list for your convenience:

    BMW M3 GT2 = 2
    Formula = 3
    Porsche 918 RSR = 4
    Universal Hub = 5


    So if you're using a nice Formula rim you will want the line to look like this:
    DeviceId[00]="(xxxxxxxx, x, 3, x)" [Again, there will be actual numbers, not x:es.]

    (I also made it red and bold, just in case.)

    That's it! Save the file. Start the game. It should work perfectly.
     
    • Like Like x 4
    • Informative Informative x 3
    • Agree Agree x 1
    Last edited: Jun 8, 2017
  2. Gopher04

    Gopher04 Well-Known Member

    Joined:
    Mar 6, 2015
    Ratings:
    +199 / 0
    This is abit confusing, how does it recognize which rim is being used? I've never seen it in the profile you create or has it effected my setup, yes my ID numbers were identical for both rims, maybe I'm not understanding this properly.
     
  3. Kitsune Magyar

    Kitsune Magyar Professional Betatester Developer

    Joined:
    Dec 12, 2016
    Ratings:
    +9,233 / 0
    Well, since it was a very small fix we've already sneakily patched this. Nothing to worry about.
     
    • Like Like x 1
  4. Gopher04

    Gopher04 Well-Known Member

    Joined:
    Mar 6, 2015
    Ratings:
    +199 / 0
    So if you patched it all ready, why is it still showing the wrong numbers then?
     
  5. Kitsune Magyar

    Kitsune Magyar Professional Betatester Developer

    Joined:
    Dec 12, 2016
    Ratings:
    +9,233 / 0
    It was patched like a minute before I posted that reply. :p
     
    • Funny Funny x 1
  6. Gopher04

    Gopher04 Well-Known Member

    Joined:
    Mar 6, 2015
    Ratings:
    +199 / 0
    Ah, see you made it sound it was sneakily patched a while back, so it actually hasn't been deployed yet.
     
  7. Kitsune Magyar

    Kitsune Magyar Professional Betatester Developer

    Joined:
    Dec 12, 2016
    Ratings:
    +9,233 / 0
    Yup, I realized. :oops:
     
  8. DerHek

    DerHek Active Member

    Joined:
    Jan 30, 2015
    Ratings:
    +33 / 0
    Oké I'll give it a try, hope the missing device message is gone now.
    I do have an question regarding the fanatec update, did you change something in the ffb settings for this wheel, I set my wheel up for the WTCC and now I have a different feeling in the wheel . Or is it just me :)
     
  9. Kitsune Magyar

    Kitsune Magyar Professional Betatester Developer

    Joined:
    Dec 12, 2016
    Ratings:
    +9,233 / 0
    Nope, nothing regarding FFB has been changed.
     
  10. DerHek

    DerHek Active Member

    Joined:
    Jan 30, 2015
    Ratings:
    +33 / 0
    The default BMW rim is recognized now , but my old profile for the BMW rim isn't, this one I have to do manually, like in the first post (xxxxx,X,x) changed the big X into 2 and now it's recognized and I don't get the missing device message anymore.

    I noticed that the first post has been edited.
     
  11. Kitsune Magyar

    Kitsune Magyar Professional Betatester Developer

    Joined:
    Dec 12, 2016
    Ratings:
    +9,233 / 0
    Oh my. I understood it as everything was just going to work... I should've kept my guide! :eek:
     
  12. GrimeyDog

    GrimeyDog Active Member

    Joined:
    Apr 4, 2017
    Ratings:
    +35 / 0
    I have No Clueo_O... I dont Notice a Missing device alert.... Using CSW V2.5--> 918 Porsche Rim/ F1 Rim:)

    Can you tell Me when or if the Joysticks and Buttons on the wheel Rims will have or get Native Support so i can use them to Navigate the Game Menu screens.

    I found a work around -->Currently i use the Emulate Mouse Feature in the Fanatec properties page so I can move the Mouse with left joy stick and i push in the left joy stick to Execute commands--> Enter/Exit etc... But using VR haing to feel around for My mouse or contoller to Scroll or do every other thing thats Not point and Click is annoying:mad:
     
    Last edited: Jun 8, 2017
  13. Kitsune Magyar

    Kitsune Magyar Professional Betatester Developer

    Joined:
    Dec 12, 2016
    Ratings:
    +9,233 / 0
    That's certainly something worth looking into, especially in VR times. From my experience one standard seems to be to look at what you want to select. I will add this to our wiki and hope it's not forgotten. :D
     
    • Like Like x 1
    • Useful Useful x 1
  14. GrimeyDog

    GrimeyDog Active Member

    Joined:
    Apr 4, 2017
    Ratings:
    +35 / 0
    This is How to set up My work around in Fanatec properties page just
    Follow the pic to activate and set the Emulate Mouse feature to use Left Joy stick to Move Mouse and Push/Click in Right Joy stick to Execute/ Make selections
     

    Attached Files:

  15. GrimeyDog

    GrimeyDog Active Member

    Joined:
    Apr 4, 2017
    Ratings:
    +35 / 0
    I tried this with the 918 Porsche Rim and i did Not see it pop up in default settings---> only saw the BMW Rim and i think the F1 Rim----> what ever the case all is working well with My wheel wheel so im Going to Leave stuff alone unless there is a reason to change stuff--> Scared something that's Not Broken will Break...LOL

    what benefit will this have other than just renaming the wheel--->will it affect DOR in any way if i go from the 918 Porcshe rim to the F1 Rim???
     
  16. Magus

    Magus Member

    Joined:
    Jan 29, 2015
    Ratings:
    +6 / 0
    I'm having issues with my Fanatec BMW Rim being recognised. Using WIndows 10, Fanatec Drivers 261 FW204. Sometimes the game loads and it says device found and I have to set the button up. Sometimes it loads and my wheel is not detected at all but pedals work (connected separately to PC), and sometimes neither work. This is unique to R3E. I have gone to the C:\Users\xxx\Documents\my games\SimBin\RaceRoom Racing Experience\UserData\ControlSet and when it has not been on the correct number (2), I have changed it. If I load it up it might work, if it doesnt, I go back to that file location and I have a :
    C:\Users\xxx\Documents\my games\SimBin\RaceRoom Racing Experience Install 2\UserData\ControlSet folder, and this can keep going on, so I get an Install 3 if I change the figure to '2' in Install 2 and load and again not recognized.

    I've deleted the whole folder in my docs so now I only have one folder in the C:\Users\xxx\Documents\my games\SimBin\ location but again after exiting and loading the game again, it will not recognise my wheel.
     
  17. axxis278

    axxis278 Well-Known Member

    Joined:
    Jan 29, 2015
    Ratings:
    +45 / 0
    thank you, it was annoying to have the error popup everytime back in the menu.
    Will try this tonight.
     
  18. Magus

    Magus Member

    Joined:
    Jan 29, 2015
    Ratings:
    +6 / 0
    I'm still having issues with my Fanatec CSW v2 & CSP v2.

    Today the pedals won't be recognised, yet they work in the hardware controller and in rF2. It is quite frustrating as they are just not picked up by the game so I cannot bind the keys even if i wanted to go through the rigmarole of setting it all up again.

    What is causing this if people are saying it is fixed/resolved?

    I see in my ControlSet folder I now have 5 different .rcs files (3 for the BMW rim, & 2 for the Formula wheel), yet on the last load of the game my pedals were not being detected. Sometimes, it happens to the rim.

    I should add that my pedals are connected to the pc via usb and not to the wheel.
     
    Last edited: Jun 15, 2017
  19. Magus

    Magus Member

    Joined:
    Jan 29, 2015
    Ratings:
    +6 / 0
    Anyone??
     
  20. GrimeyDog

    GrimeyDog Active Member

    Joined:
    Apr 4, 2017
    Ratings:
    +35 / 0
    Try this -->Go to game properties and Verify game file then--> do a Defrag on your HD--> Restart Pc and test to see if you still have the issue.---> Maybe after the last update your Game controller files got screwed up.

    Also because you have sooo many rcs. files you may Need to delete them and create a Fresh controller profile for the wheel rims you use---> Im on a v2.5 and i only have 1 CSW v2.5 profile and use the same controller profile Porsche and F1 rim.
     
    • Like Like x 1
    Last edited: Jun 16, 2017