64bit in VR

Discussion in 'General Discussion' started by Gazza, Dec 1, 2017.

  1. SylverFyre

    SylverFyre Well-Known Member

    Joined:
    Jun 21, 2015
    Ratings:
    +69 / 0
    Have you tried closing steam and/or steam VR, then launching Raceroom from a shortcut?

    This works for me. The shortcut starts the 64bit exe and launches steam VR itself. If steam VR is already running, Raceroom won't start at the moment.
     
    • Informative Informative x 1
  2. hothatch01

    hothatch01 New Member

    Joined:
    Dec 4, 2017
    Ratings:
    +0 / 0
    I can launch raceroom on my CV1 but when the game window shows the oculus view on my desktop half of it is lost off to the left side of the screen and what I can see looks massive.I cant reposition my game window so my mouse then cant get to either the settings of single player options. any ideas from anyone.
     
  3. Skybird

    Skybird Well-Known Member

    Joined:
    Mar 31, 2015
    Ratings:
    +525 / 0
    Rift CV1 and 64 Bit, working flawlessly here. Win 10 Pro.

    I read in many threads and places that some people have big problems with 64 Bit exe, and their fps getting massively dumped.
     
  4. hothatch01

    hothatch01 New Member

    Joined:
    Dec 4, 2017
    Ratings:
    +0 / 0
    64 bit was my issues, 32bit works fine but I can’t get 64 bit to work properly, at least it isn’t completely screwed. I’ll wait for a patch.
     
  5. Onaflyer

    Onaflyer Active Member

    Joined:
    Feb 28, 2017
    Ratings:
    +32 / 0
    Same here, can't get VR 64 bit working but 32 works fine. Also just giving devs some time to see if there is a patch.

    Great freaking update though!
     
  6. AnToN_CheZ

    AnToN_CheZ New Member

    Joined:
    Mar 14, 2017
    Ratings:
    +0 / 0
    I went back to VR tonight after a little while away from R3E and also since have been using the newly implemented triples set up, very nice. My performance in VR (64 bit) is atrocious now. 1080Ti, even setting pixel density as low as I could go before not being able to make the track out didn't help it. Stuck at 45fps and I don't even run ASW on my Rift. I turn it off and always aim to hit 90fps with headroom at all times. Something is very weird with that. I used to run it no problems, with a decent PD and a track full of cars. Tonight's test was even just me alone on track.

    Will test the 32 bit exe tomorrow but it's really frustrating. rF2 used the be the worst for me in VR with Raceroom trailing a little behind it, but was always able to get 90hz.
     
  7. II./JG77_Manu

    II./JG77_Manu New Member

    Joined:
    Dec 3, 2017
    Ratings:
    +1 / 0
    Solved the starting issue for me, thanks
     
  8. SylverFyre

    SylverFyre Well-Known Member

    Joined:
    Jun 21, 2015
    Ratings:
    +69 / 0
  9. Gazza

    Gazza New Member

    Joined:
    Mar 4, 2017
    Ratings:
    +3 / 0
    I use Simvibe and i had to add "Wait On" box to RRRE64.exe in a box in the settings, worked for me .
     
  10. AnToN_CheZ

    AnToN_CheZ New Member

    Joined:
    Mar 14, 2017
    Ratings:
    +0 / 0
    Just to further my above post, I have since solved the performance issue I was having that I thought may be attributed to the 64 bit exe. Turns out, turning off Force Vsync On in Nvidia Inspector cured the horrible performance I was getting even at lowest settings. I don't remember this setting ever having an effect in VR but since the update it seems to be causing issues so I have turned it off (I use it for triple screens) and performance is once again 90hz on the Rift.
     
  11. m.bohlken

    m.bohlken Well-Known Member

    Joined:
    Jan 29, 2015
    Ratings:
    +771 / 0
    maybe you have a global profile in NV Inspector in which the "Force Vsync"-Option was "On" and a dedicated profile for Raceroom in which Force Vsync was off? With the 64bit-Version you need to add the rrre64.exe to the Raceroom-Profile in NV-Inspector - otherwise the global settings will be used.
     
  12. AnToN_CheZ

    AnToN_CheZ New Member

    Joined:
    Mar 14, 2017
    Ratings:
    +0 / 0
    Nah I added the 64 bit exe to the 'Race Room' profile when I was setting up triples. I left the Force Vsync on for that, as I disable in game Vsync on everything. My global profile is set to 'Application Controlled'. I just wasn't aware that Oculus paid attention to any Vsync setting apart from it's own native refresh rate. Drove me mad for the night. All sorted now :)
     
  13. OlivierMDVY

    OlivierMDVY Member

    Joined:
    Jan 29, 2015
    Ratings:
    +18 / 0
    I've solved my issue with x64 crashing: I've switched off the Rivatuner application and now I can start RRRE x64 in VR.
     
    • Informative Informative x 1
  14. Onaflyer

    Onaflyer Active Member

    Joined:
    Feb 28, 2017
    Ratings:
    +32 / 0
    I can get 64 bit to work in VR if I open Steam VR but close Steam (down in sys tray, right click Steam icon and choose exit) then click the shortcut on my desktop with Steam VR open. RRRE64.exe starts up and runs nicely. :)

    Hope this helps someone or the devs to figure out a permanent fix.