In-Gameplay Web Overlays

Discussion in 'Community Workshop' started by J-F Chardon, Apr 4, 2019.

  1. ducman888

    ducman888 Well-Known Member

    Joined:
    Jan 7, 2018
    Ratings:
    +94 / 0 / -0
    I know it is vastly popular for mods, and my hats off to those talented enough to produce quality work. My complaint is with the game developers. Establish integrity within the platform and if you see work out there, such as this, and they feel as though it deserves it, make it part of the game not a separate add on.
    I tried the new HUD and like the ability to see fuel consumption, but if it means a higher maintenance level than allowing it to update itself I can do without.
    Edit: the DASH file OK I got it now. My bad.
    https://github.com/sector3studios/webhud/blob/master/dist/dash.zip
     
    Last edited: Jun 15, 2019
  2. MattYKee

    MattYKee Member

    Joined:
    May 16, 2019
    Ratings:
    +17 / 0 / -0
    Is it possible to have this data appear on another computer on the network (in a browser)?
     
  3. OtterNas3

    OtterNas3 Well-Known Member

    Joined:
    Jan 9, 2018
    Ratings:
    +227 / 0 / -0
    The previously here provided way, does not work, sorry!
     
    • Useful Useful x 1
    Last edited: Jul 3, 2019
  4. MattYKee

    MattYKee Member

    Joined:
    May 16, 2019
    Ratings:
    +17 / 0 / -0
    Thanks so much! fantastic write up and more than i could possibly ask for.
    Use this launch parameter correct? "Add -webdev -webHudUrl=https://sector3studios.github.io/webhud/dist/"
    It sort of works. The client systems browser is showing the message you see when "dash.exe" isnt running "run dash.zip and remember to set launch parameters....".

    I opened Mozilla on the game machine and typed in the same address as i typed in the clients and it appears as it should. The 2nd machine is just showing the dash.zip message though. Tried loading on my phone browsers too just to be sure and just the dash.exe message.

    Gonna have think about what it might be the issue and write up somethings to try. Might be a configuration in windows 7. Does seem strange though how i can get the data on the host machine browser but not on any of the ones connecting. If it was a communication error then i should'nt be able to load the page at all.
     
  5. yoori

    yoori Well-Known Member

    Joined:
    Feb 10, 2017
    Ratings:
    +51 / 0 / -0
    I think it won't work on a second Machine like that. The app in the Webbrowser is looking for a local data feed (dash.exe).
    It's logic we all use the same Web address but we all get our personal dashes.
    For it to work on a second machine you would have to stream the shared memory feed to the second machine and run a dash.exe functionality on the second machine. Then you wouldn't need to run a webserver.
     
    • Informative Informative x 1
  6. OtterNas3

    OtterNas3 Well-Known Member

    Joined:
    Jan 9, 2018
    Ratings:
    +227 / 0 / -0
    Yeah seems about right.
    As long as we cant provide a way to share the data feed, this will not work, sorry @MattYKee for the false hope there.
    It was late, brain was numb...
     
    • Like Like x 1
  7. mape

    mape Sector3 Developer

    Joined:
    Jan 14, 2015
    Ratings:
    +132 / 0 / -0
    If you only want to see the overlay on a secondary machine you can try
    Code:
    https://sector3studios.github.io/webhud/dist/?ws=ipToMachineRunningDash:8070
    As seen in: https://github.com/sector3studios/webhud/blob/master/src/lib/r3e.ts#L27
     
    • Informative Informative x 1
    • Wonderful Wonderful x 1
  8. OtterNas3

    OtterNas3 Well-Known Member

    Joined:
    Jan 9, 2018
    Ratings:
    +227 / 0 / -0
    https://sector3studios.github.io/webhud/dist/?ws=192.168.178.228:8070
    Not working (Even on the Machine which runs the Game)
    https://sector3studios.github.io/webhud/dist/?ws=127.0.0.1:8070
    Working (On the Machine running the Game)
    https://sector3studios.github.io/webhud/dist/?ws=localhost:8070
    Working (On the Machine running the Game)

    I guess the WebSocket Server is bound to localhost(127.0.0.1)?
    In this case it would not listen to any other networks, no?
     
    • Like Like x 1
  9. mape

    mape Sector3 Developer

    Joined:
    Jan 14, 2015
    Ratings:
    +132 / 0 / -0
    Sorry, my bad.
    This worked when I tested it during development because the files were served over HTTP.
    When hosted on Github it is served through HTTPS and Chrome throws a Mixed Content error.
    To solve that issue you can click on the shield icon with a red cross in the right side of the Chrome address bar.
    Then click "Load unsafe scripts" in the popup.
    Hope that helps.
     
    • Useful Useful x 2
    • Informative Informative x 1
  10. OtterNas3

    OtterNas3 Well-Known Member

    Joined:
    Jan 9, 2018
    Ratings:
    +227 / 0 / -0
    Yeah that did the trick, thanks a lot!
     
  11. TomQuid

    TomQuid New Member

    Joined:
    Sep 21, 2016
    Ratings:
    +1 / 0 / -0
    Everything is working fine for me in VR, expect the relative.
    I have it enabled but I don't get the relative to show.
    Any suggestions?
     

    Attached Files:

  12. TomQuid

    TomQuid New Member

    Joined:
    Sep 21, 2016
    Ratings:
    +1 / 0 / -0
    update: I did a gt3 race at mid-ohio and the relative showed up (but just showing the names, no time/ meter distance).
    Is the relative only available during the races, and if so only at certain tracks/cars?
    Thanks
     

    Attached Files:

  13. TomQuid

    TomQuid New Member

    Joined:
    Sep 21, 2016
    Ratings:
    +1 / 0 / -0
    I am thinking this might have to do with some of the 64-bit issues (which I am running - the game will not find my pedals running in 32-bit) as the 'in game' position bar is not showing position (usually on the left side of the bar) or time left (usually on the right side of the bar), but only the drivers names and my relative time to the drivers.
    Anyways, I have decided to uninstall webhud for the time being.
    Capture3.JPG
     
  14. Stuntman Daz

    Stuntman Daz New Member

    Joined:
    Jul 16, 2019
    Ratings:
    +0 / 0 / -0
    Hello, is there a way to switch this to MPH please? It's absolutely brilliant otherwise.

    And to my European friends, I use both metric and imperial I just prefer MPH as it's what I grew up with
     
  15. Bauer

    Bauer Member

    Joined:
    Apr 25, 2019
    Ratings:
    +5 / 0 / -0
    Maybe
    Options>Gameplay Settings>HUD Settings>Speed Indicator
     
  16. Stuntman Daz

    Stuntman Daz New Member

    Joined:
    Jul 16, 2019
    Ratings:
    +0 / 0 / -0
    Thanks for the reply, but unfortunately that only changes the standard in-game HUD. It doesn't affect webhud
     
  17. Bauer

    Bauer Member

    Joined:
    Apr 25, 2019
    Ratings:
    +5 / 0 / -0
  18. Stuntman Daz

    Stuntman Daz New Member

    Joined:
    Jul 16, 2019
    Ratings:
    +0 / 0 / -0
    That's perfect. Thank-you!
     
  19. Goffik

    Goffik Well-Known Member

    Joined:
    Jun 30, 2017
    Ratings:
    +46 / 0 / -0
    You're not alone there mate. I'm a Brit so we use a ridiculous "hybrid" system... miles/MPH for distance/speed, both litres/pints for liquid volume, feet/inches for a person's height yet metres for most other length measurements... the list goes on. :p
     
    • Funny Funny x 1
  20. totalgamertb21

    totalgamertb21 Active Member

    Joined:
    Mar 9, 2017
    Ratings:
    +26 / 0 / -0
    If anyone here's ever played Euro Truck Simulator 2, then I'm sure you can see how odd this is.
     
    • Like Like x 1
    • Agree Agree x 1