Resolved No Sound Continually!

Discussion in 'Community Support' started by BigSarge, Jul 14, 2018.

  1. BigSarge

    BigSarge New Member

    Joined:
    Jul 7, 2018
    Ratings:
    +1 / 0 / -0
    Wondering if anyone else has had this problem, I keep loosing all sound in game upon starting R3E. I have contacted Sector3 for support, still waiting a response. I found a thread in a forum to delete the audio_options file, and restart the game. I have done that now many times, sometimes sound returns, sometimes it doesn't. I have had the game files verified, ok.
    When the sound does return, it only plays through my speakers, not in my usb headphones. Both devices are set as default in Windows and I can switch back and forth between speakers and headphones in Assetto Corsa, ATS, Battlefield... with no problem. Using Realtek onboard sound.
    Any help would be greatly appreciated.
    i7 3770k @ 4.9ghz, MSI Z77a gd65a, GTX780, 16gb G.Skill, Samsung SSD, Win 8.1
    Turtle Beach Z60
     
  2. nate

    nate Well-Known Member

    Joined:
    Jan 31, 2015
    Ratings:
    +874 / 0 / -0
  3. Andy Blade

    Andy Blade Well-Known Member

    Joined:
    Feb 21, 2016
    Ratings:
    +303 / 0 / -0
    He is on windows 8.1 @nate
     
    • Useful Useful x 1
  4. nate

    nate Well-Known Member

    Joined:
    Jan 31, 2015
    Ratings:
    +874 / 0 / -0
    Whoops...

    Well who knows, Microsoft is known for breaking stuff regardless of what OS you are using :D
     
    • Agree Agree x 1
  5. Christian G

    Christian G Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,336 / 0 / -0
    But it used to work normally in the past, or have you recently started using RR and it's been like that from the start?

    In any case, I'd suggest making sure that you're actually on the most recent build, apparently the inconsistent patch distribution per Steam is still not resolved 100 %.
    To do so, navigate to RR's folder (wherever you installed steam -> \Steam\SteamApps\common\raceroom racing experience\Game\x64) right click RRRE64.exe select properties and go to the details tab. Here you'll find the client version, which should be 0.3.0.6412
    Do the same with the RRRE.exe file in the parent folder (\Steam\SteamApps\common\raceroom racing experience\Game).

    Then in Steam right click RR, go to properties -> local files tab and look for the content BuildID in the lower left. This one should be 2939416.
     
    Last edited: Jul 14, 2018
  6. BigSarge

    BigSarge New Member

    Joined:
    Jul 7, 2018
    Ratings:
    +1 / 0 / -0
    Christian, I checked the version numbers, and I have as you suggested the latest build. I'm not sure but there may be an issue with the game and USB headphones.
     
  7. Andy Blade

    Andy Blade Well-Known Member

    Joined:
    Feb 21, 2016
    Ratings:
    +303 / 0 / -0
    Usb headset work just fine , must be something else
     
    • Agree Agree x 1
    Last edited: Jul 15, 2018
  8. Fanapryde

    Fanapryde Well-Known Member

    Joined:
    Jan 22, 2016
    Ratings:
    +409 / 0 / -0
    Same here, USB headphones work fine.
    I also use Realtek sound (if that should matter).
     
  9. Christian G

    Christian G Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,336 / 0 / -0
    Drivers are up-to-date?
    Is the Turtle Beach set as "Default Device" and "Default Communication Device"?

    Maybe Windows detects incoming sound and gets stuck? I'd check the Windows Audio panel -> Communications tab and select "do nothing" instead of "mute all other sounds" if that is set.
     
  10. BigSarge

    BigSarge New Member

    Joined:
    Jul 7, 2018
    Ratings:
    +1 / 0 / -0
    Chris, the Turtle Beach USB headphones are "default" when plugged in. However if I start the game when the headphones are plugged in, I have no sound... until I unplug the headphones, then the sound plays through my Logitech 513 speakers. Any other game I play, the sound will go to the headphones as soon as I plug in the USB, just like listening to music, if the headset is plugged in, the sound is in the headset, if not, then it plays through the speakers.But RaceRoom, for some reason won't do this.
     
  11. m.bohlken

    m.bohlken Well-Known Member

    Joined:
    Jan 29, 2015
    Ratings:
    +986 / 0 / -0
    Doesn't have Windows 8.1 still the Volume-Settings per app in the Audio-Mixer? Maybe Raceroom is muted there in the Volume-Settings of the headphone?
     
  12. BigSarge

    BigSarge New Member

    Joined:
    Jul 7, 2018
    Ratings:
    +1 / 0 / -0
    Found it! It was muted in the sound mixer, how I have no idea. It wasn't showing it in the volume controls so I guess I skipped over it. Thanks to all who helped out with suggestions, now I can play without disturbing anyone else in the house.
     
    • Like Like x 1
    • Funny Funny x 1
  13. LaundroMat

    LaundroMat New Member

    Joined:
    Nov 28, 2020
    Ratings:
    +0 / 0 / -0
    Necroing this thread, but I had the same issue! How weird that for some reason or another, the sound mixer decided to mute the game :confused: