Problem Mega stuttering!

Discussion in 'Community Support' started by Tuborg, Mar 15, 2019.

  1. Tuborg

    Tuborg Well-Known Member

    Joined:
    Feb 4, 2015
    Ratings:
    +453 / 0
    Actually it's a slideshow and the sound too, this happens after a couple of minuts in singelplayer, multiplayer or whatever. Then i have to restart Raceroom and it works again (a couple of minuts).
    Only in Raceroom. Verified steam. Latest drivers.
    Help please!

    Edit: The solution for me was to use the Raceroom 32-bit
     
    Last edited: Mar 27, 2019
  2. Christian Göpfert

    Christian Göpfert Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,084 / 0
    Hi @Tuborg ,

    sorry to hear you're experiencing these issues. A few questions:

    Did the game work normally before or have you just started using Raceroom and it's been like this from the get go?

    Have you checked your hardware's temperatures when this issue occurs, ensuring it's not related to overheating from dust or alike?

    Is your CPU overclocked? If so, have you tried at stock settings?

    Recently we've seen reports of people experiencing issues with games freezing which turned out to be related to the audio driver they had installed. Which audio driver do you have installed? Maybe try re-installing the latest audio driver for your mobo/audio device.

    Do you have any third party capturing software running, or other software that might have an impact, like MSI Afterburner?
     
  3. Tuborg

    Tuborg Well-Known Member

    Joined:
    Feb 4, 2015
    Ratings:
    +453 / 0
  4. Tuborg

    Tuborg Well-Known Member

    Joined:
    Feb 4, 2015
    Ratings:
    +453 / 0
    @Christian Göpfert My former nickname was Turbo. 17000+ laps completed...

    But i haven't used Raceroom much lately and now i have a new GPU and CPU.

    Tried without OC both on GPU and RAM. Uninstalld Afterburner, turned of Fraps.

    It happens anyway, even happens when i watch a replay.

    I have recently reinstalld everything including Windows 10 so i guess my drivers are up to date.

    Is it possible that my headphones software interfere even if i don't use them?
     
  5. Christian Göpfert

    Christian Göpfert Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,084 / 0
    It could well be, tho I doubt it. But it's really hard to tell with all the hardware and drivers out there. If it ain't too much of a hassle I'd see if uninstalling changes anything.

    One other thing that crossed my mind when I saw you're using a Ryzen 7: https://forum.sector3studios.com/in...ng-with-my-brand-new-ryzen7-and-1080ti.12283/

    Apparently some wrong RAM clock settings can cause major issues, so make sure you got those BIOS settings correct.

    EDIT: Sorry, c&p'ed the wrong link. Corrected.
     
    Last edited: Mar 15, 2019
  6. Tuborg

    Tuborg Well-Known Member

    Joined:
    Feb 4, 2015
    Ratings:
    +453 / 0
    The Ram memory does not seem to be compatible with the motherboard (they are not on it's QVL list)

    That is nothing new but might got worse now with Ryzen 7 than with Ryzen 3. A new Mobo maybe is the only solution.
     
  7. Not Lifting Off

    Not Lifting Off Well-Known Member

    Joined:
    Dec 5, 2015
    Ratings:
    +340 / 0
    Beacuse it isnt on the QVL list dosnt mean its not compatible or wont work, just means the manufacturer hasnt tested it on that particular board, i would be sure all options were exhausted before taking such a drastic measure as to replace the motherboard on the off chance that its a compatibility issue, have you run memtest or any other memory checking software, is your bios up to date? Have you searched google for that Mobo ram combo and found others with issues?
    It could be anything from pagefile settings to a dodgy hard drive to the 2nd sound card your specs list or even a usb issue, maybe a gpu issue new card driver teething troubles, or it may well be incompatible
    Try the game alone, no sim commander, disable the second sound card, no peripherals just keyboard and mouse attached.
     
  8. Christian Göpfert

    Christian Göpfert Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,084 / 0
    What @Not Lifting Off said. I'd also recommend eliminating every other possibility (like driver incompatibility, faulty connections, peripherals etc.)
    But as you're the only user reporting sth like this right now I would assume there is no general incompatibility between RR and the latest gpu drivers (which is always a suspect in such cases) or some other global issue. So some kind of third party software, driver or hardware issue does seem a likely reason.

    If everything else doesn't succeed I would however try a compatible mobo (or RAM that's compatible with the mobo you got) and make sure the clock settings etc. are correct, sometimes the default values are off. Worst case would be it ain't that either and you could return the new mobo (if that's legally possible where you live).

    Before going there we can have a look at some game log files to see if there's any hint at a possible cause in them. So please start a session and wait for the issue to occur, then close the game, navigate to ...\Documents\My Games\Simbin\RaceRoom Racing Experience\UserData\Log and attach the latest Game-, Performance- and MWTransport-log files here.
     
    Last edited: Mar 16, 2019
  9. Sebastien Brunier

    Sebastien Brunier Member Beta tester

    Joined:
    Dec 17, 2017
    Ratings:
    +19 / 0
    Technically DDR4 is DDR4, and with the right mobo, and skill you can make them work at their advertised speed (aka XMP profile).
    BUT
    RAM sticks that are listed in QVL are sticks that will contain the appropriate timings in the SPD chip, otherwise they will default to JEDEC profile, that is the standard timings for DDR4 and 2133 MT it is... with very loose timings...
    Intel platforms aren't very sensitive to RAM latency, Ryzen loves RAM speed and low latency, gaming with Ryzen you need a quality kit like 3200CL14 (FlareX or TridentZ or RipJaws e.g. all Samsung B-Die)
    But you could do it with other kits if your mobo allows you to manually set the RAM timings. They don't all do. Sometimes they allow you to set primary timings, but not secondary or tertiary timings either. In this last case your mobo will train the RAM and choose very loose timings.
    You need this tool to calculate the timings for Ryzen
    https://www.techpowerup.com/download/ryzen-dram-calculator/
    select the Ryzen processor generation, the RAM Die type, the speed you'd like to achieve, click on R-XMP buton then click on Calculate Safe or Calculate Fast button, and you'll get all optimized timings for your system.
    The higher quality RAM (Samsung B-Die) the best speed/latency you'll achieve)
    To check how your existing timings compare to ideal values given by the calculator you have this tool
    https://www.techpowerup.com/download/ryzen-timing-checker/
    Of course if your RAM kit is already in the QVL, it'll be slightly easier
     
  10. Tuborg

    Tuborg Well-Known Member

    Joined:
    Feb 4, 2015
    Ratings:
    +453 / 0
    @Not Lifting Off Yes that would be drastic considering it`s only affecting raceroom but if i don´t find any other solution i have to. I have the latest bios and the most recent drivers and i have tested the memory with memtest.
    @Sebastien Brunier I have a quality kit. I should be able to use 3200 but i cant (computer is crashing), 2933 is the highest i can use. I will check that calculator later.

    http://www.gskill.com/en/product/f4-3200c14d-16gfx
    https://www.asus.com/Motherboards/ROG-STRIX-B350-F-GAMING/

    @Christian Göpfert
     

    Attached Files:

    • Useful Useful x 1
  11. Sebastien Brunier

    Sebastien Brunier Member Beta tester

    Joined:
    Dec 17, 2017
    Ratings:
    +19 / 0
    Ok @Tuborg it can happen, sometimes the 1.35v of the XMP profile isn't enough, and/or the sillicon lottery wasn't that good in regards to the IMC (integrated memory controller) on your CPU.
    You need to know that Intel can allow XMP certification up to 1.5v, so you can safely increase your memory voltage up to this limit. I'd recommand a small bump to 1.4v in the first place. Try your stability with this first.
    Also to overcome the possible IMC issues (if just bumping the memory voltage wasn't enough) you could try to adjust the vSoC (System On a Chip voltage) to increase it a bit, best practice if your mobo allows it woult be to apply a positive voltage offset something like 0.02v (vSoC is the IMC voltage to make it short). By default your vSoC should be arround 1.08/1.1v you can bump it safely to 1.15v, of course don't go full tilt to this value, proceed by small increments. GamerNexus says 1.2v but he also says (and showed) that sometimes voltage monitoring is flawed and mobo pushes voltages higher than monitored value, this is why I tell you 1.15v should be your threshold.
    Hope it will help.
     
  12. RWB 3vil

    RWB 3vil Member

    Joined:
    Dec 5, 2018
    Ratings:
    +22 / 0
    Check that Windows 10 hasn't set "My Documents" to read only which can happen if you do a reset. Any of your My Games/Simbin/ profile files may have been set to read only, either that or delete them entirely so you can start truly from a fresh install as a steam verification will not touch profile files in My Documents.

    There may be a config file written that was based on your old CPU/GPU combo and its glitching the game.
     
  13. Not Lifting Off

    Not Lifting Off Well-Known Member

    Joined:
    Dec 5, 2015
    Ratings:
    +340 / 0
    Advising someone to delete something that may not be the problem is naive, rename and take it from there.
     
    • Agree Agree x 1
  14. 2ndLastJedi

    2ndLastJedi Well-Known Member

    Joined:
    Aug 22, 2016
    Ratings:
    +88 / 0
    My R3E is completely bored also! Going from 4k 60fps maxed to 25-30 fps at same settings, no change anywhere other than normal Win 10 updates I've tried nVidia drivers going right back to 399.25 to latest where some just won't run the game at all and R3E locks my PC with the little postage stamp size load screen on screen.
    I really want to play but am just so tired of the RaceRoom struggle!
     
  15. Tuborg

    Tuborg Well-Known Member

    Joined:
    Feb 4, 2015
    Ratings:
    +453 / 0
    Thank you all for trying!

    I have tried to raise the volt, didn't work. Now i use "optimized defaults" (no OC CPU, RAM 2400) didn't work.
    Tried without saving replays to disk, didn't work.

    The thing is that it happens on lap 6,7 or 8 (of 10) mostly on lap 7...Why?
     
  16. Not Lifting Off

    Not Lifting Off Well-Known Member

    Joined:
    Dec 5, 2015
    Ratings:
    +340 / 0
    Maybe services, do you have windows search and superfetch enabled, if windows is thinking this is idle time it maybe firing up these two to do some prefetch and database shit, may also be defrag, W updates another possibility, there are a *shedload of services that are not needed and can be disabled.

    You could check or have you checked event viewer to see what is running or starting up at the time of the slowdown?
    *based on my own experience of needing my computer for nothing more than browsing and gaming.
     
  17. Case

    Case Well-Known Member

    Joined:
    Apr 7, 2017
    Ratings:
    +84 / 0
    Are you running 32 bit or 64 bit version of the game? If 64 bit, have you tried 32 bit?
     
  18. 2ndLastJedi

    2ndLastJedi Well-Known Member

    Joined:
    Aug 22, 2016
    Ratings:
    +88 / 0
    I did this (well I renamed it by adding xxxx behind it) and got all my performance back!
    Why does this improve it and how does it go wrong when nothing has been changed?
    Oh well who cares as long as I can play again ;)
     
    • Like Like x 1
  19. Sebastien Brunier

    Sebastien Brunier Member Beta tester

    Joined:
    Dec 17, 2017
    Ratings:
    +19 / 0
    Sorry if my suggestion looks dumb but... have you checked that both your RAM sticks are fully plugged in the slots ? They can be hard to fit sometimes and someone I know had a working PC but couldn't take advantage of full RAM speed because of on stick that was not fully inserted... ¯\_(ツ)_/¯
     
  20. Tuborg

    Tuborg Well-Known Member

    Joined:
    Feb 4, 2015
    Ratings:
    +453 / 0
    I don`t know what I changed yesterday but today I have had zero problems. I have run several single and online races without any problems at all. Buttersmooth!
     
    • Wonderful Wonderful x 1