VR Performance Tweaks & Tips

Discussion in 'General Discussion' started by Thomas Jansen, Apr 19, 2019.

  1. Jose Fernandez de Castro

    Jose Fernandez de Castro New Member

    Joined:
    Jun 24, 2021
    Ratings:
    +0 / 0 / -0
    I'm locked at 45 fps with a Quest 2 even thought he frame times are super low. Anyone know why?
     
  2. rad

    rad Well-Known Member

    Joined:
    Jan 29, 2015
    Ratings:
    +449 / 0 / -0
    Probably you can't make stable 90fps. You would need to go to your Oculus setup folder, then Support/Diagnostics, open OculusDebugTool and under Asynchronous Spacewarp set it to disabled and see what framerate you achieve
     
    • Agree Agree x 1
  3. Jose Fernandez de Castro

    Jose Fernandez de Castro New Member

    Joined:
    Jun 24, 2021
    Ratings:
    +0 / 0 / -0
    Another question 2 issue, my mirror (monitor) screen is black while I play in VR, any way to show the game in 2d at the same time? Also, the images in my on car mirrors look squashed or have the wrong aspect. Any way to fix that?
     
  4. BrianBosch

    BrianBosch Well-Known Member

    Joined:
    Mar 15, 2018
    Ratings:
    +126 / 0 / -0
    You can assign a button to <toggle monitor> in the key bindings. Not sure if if it the exact right name not behind my rig right now.

    Second question is new to me. Maybe play with the mirror resolution in the graphic settings?

    Hope it helps
     
  5. Jose Fernandez de Castro

    Jose Fernandez de Castro New Member

    Joined:
    Jun 24, 2021
    Ratings:
    +0 / 0 / -0
    Is there any way to have the screen mirror on by default? Like with a config file or something?
     
  6. Skev

    Skev Member

    Joined:
    Jan 6, 2020
    Ratings:
    +16 / 0 / -0
    I find that I never have to toggle it on since I did it the first time, so guess it remembers where you left it.
     
  7. Jose Fernandez de Castro

    Jose Fernandez de Castro New Member

    Joined:
    Jun 24, 2021
    Ratings:
    +0 / 0 / -0
    As to the cockpit mirrors, they look like they do in this video (which isn't VR I think):

    Look around 12:37 and anywhere you see cars in the rearview mirror.
    Cars just look squished. I thought I was being chased by an tiny compact cars.
     
  8. Autobox [ARG]

    Autobox [ARG] New Member

    Joined:
    Jun 30, 2021
    Ratings:
    +3 / 0 / -0
    Desde la última actualización (menor) del 27 de junio que, Using Oculus Rift y SteamVR, el juego va a los tirones. Actualice todo (Win 10, Nvidia, Oculus) por si el problema era mío pero, todo siguió igual. Luego en Discord encontré otros usuarios de Oculus que se quejaron de lo mismo. Van a sacar alguna actualización para solucionarlo? Gracias.

    Desde la última actualización (menor) del 27 de junio, using Oculus Rift y SteamVR, el juego va a dar un vuelco. Actualiza todo (Win 10, Nvidia, Oculus) por si el problema fuera mío pero todo sigue igual. Luego, en Discord, encontré a otros usuarios de Oculus que se quejaban de lo mismo. ¿Recibirás una actualización para solucionarlo? Gracias
     
  9. Autobox [ARG]

    Autobox [ARG] New Member

    Joined:
    Jun 30, 2021
    Ratings:
    +3 / 0 / -0
    Ayer corría sin problemas de picado, pero hice algunos cambios drásticos. Cambie la resolución a 1366x768 (sí, mierda), todos los efectos visuales a "Bajo" y borre los parámetros de lanzamiento (tanto Crewchieff / OtterHud como SteamVR). Obviamente, todo parece que tiene una tarjeta de video y un procesador de los 90, pero pude funcionar sin problemas. Hoy trataré poco a poco de añadir definición, efectos y parámetros de lanzamiento hasta intentar entender qué provoca el tartamudeo con todo al máximo.
     
    • Like Like x 1
  10. Jynn

    Jynn Member

    Joined:
    Jun 7, 2015
    Ratings:
    +24 / 0 / -0
    @Thomas Jansen , I noticed from another thread that you used to have a Ryzen 3600. Were you able to achieve 80fps with that? I have the same CPU and although Asw enabled 40fps is perfectly playable, I'm simply unable to achieve 80 even on low settings so really feels like a cpu isuue. I'm beginning to think there's something wrong with the CPU as I get many bsod in normal office usage.
    For reference my GPU should be plenty enough, a amd vega 64
     
  11. TanHammer

    TanHammer New Member

    Joined:
    Jul 1, 2021
    Ratings:
    +1 / 0 / -0
    The issue is likely the 3600 is too slow with it's single core performance. I had a 3600 and couldn't get 80fps on ACC, upgraded to 5600x and now it's flawless at 80fps. I would suggest upgrading to a 5600x as it's single core performance is much improved over a 3600 BUT Raceroom is still very hard to run at 80fps with a 5600x, DX9 wich Raceroom uses is just not intended for VR.
    I can get 80 fps with all settings on low, no shadows, lowest track detail etc. and even then on certain tracks I still see dips - Nordschleife for example won't run over 40 fps regardless of settings.
     
  12. Jynn

    Jynn Member

    Joined:
    Jun 7, 2015
    Ratings:
    +24 / 0 / -0
    Thanks for the reply TenHammer. What I find weird is that back when I first got a rift CV1 in 2016 I was using a (now) old i5 4670k, and I remember it running at 90fps on medium settings no problem. It seems like something changed in the rendering engine that has greatly hindered VR performance.
     
  13. TanHammer

    TanHammer New Member

    Joined:
    Jul 1, 2021
    Ratings:
    +1 / 0 / -0
    No problem. That's intersting, even looking back at the guides here from a few years ago and they all seem to be able to handle higher settings at locked frame rates so I'd be inclined to agree with you - something appears to have changed to affect performance. It also appears to affect all headsets, Oculus, WMR etc. Hopefully Sector 3 will take a look at performance in the future.

    Are you still using the CV1? I've tried using ASW on my Rift S but I find it unplayable.
     
  14. Jynn

    Jynn Member

    Joined:
    Jun 7, 2015
    Ratings:
    +24 / 0 / -0
    No I sold my CV1 and got a rift-s. Actually I find asw totally playable (previously not, think the asw2 is much better than asw1), obviously not quite as good as the only sim I can get to 80fps(RF2), but after I've started racing I barely notice. So this is not a deal breaker at all for me, just hoping there was something I'm missing to unlock the full potential of 80fps.
    If you find it unplayable with ASW, I'd recommend trying again and see how you're finding it after 5 minutes of racing, the brain adapts, happened for me!
    5600x will be on my christmas wishlist to myself! :D
     
  15. TanHammer

    TanHammer New Member

    Joined:
    Jul 1, 2021
    Ratings:
    +1 / 0 / -0
    I'll give it another shot based on your experience but last time I tried not long ago it wasn't good. What specifically are you using to enable ASW2? Last time I tried it I used Oculus Tray Tool and set deafult ASW mode to 45hz (there is no option for 40hz).
     
  16. Thomas Jansen

    Thomas Jansen Sector3 Developer Beta tester

    Joined:
    Apr 5, 2018
    Ratings:
    +552 / 0 / -0
    I upgraded to a 5800x now, but i did use a 3600 with my Valve Index without any issues at 120Hz, it really depends on how you play though, with a lot of AI any CPU will crack. for solo practice or multiplayer with 10-15 cars visible the 3600 should work very well, good RAM can also help a lot. Make sure to try if the opencomposite method from the OP still works for oculus, that can help a lot :)
     
  17. TanHammer

    TanHammer New Member

    Joined:
    Jul 1, 2021
    Ratings:
    +1 / 0 / -0
    Thanks for the info. Would you be able to outline your graphics settings? I'm really tyring to optimize the VR performance in this sim but struggling badly. I've got a 5600x, 5700xt and 16Gb 3200mhz. Using a Rift S with Open Composite setup as per the instructions in this thread I can barely maintain 80fps at all lowest settings, 10 visible cars, no shadows etc. I mainly race in multiplayer, forget AI racing as I can't maintain 80fps with any amount of AI. I can't even maintain 40fps on the Nordschleife in practice without any AI- I assume this is due to the larger track and rendering more objects, again track detail is set to lowest but it doesn't help on this particualr track (it does on others such as RedBull ring). Any suggestions would be appreciated. Thanks
     
  18. Thomas Jansen

    Thomas Jansen Sector3 Developer Beta tester

    Joined:
    Apr 5, 2018
    Ratings:
    +552 / 0 / -0
    I still use the same settings a I did on my 4770k from the OP. I have a 1080ti, which might be the difference. AMD gpu drivers don't seem to work very kindly with DX9, so you could maybe try a few different driver versions and see if any of them work better.
     
  19. TanHammer

    TanHammer New Member

    Joined:
    Jul 1, 2021
    Ratings:
    +1 / 0 / -0
    Thanks for the info. So you're still able to maintain 120fps with a 3600 and a 1080ti?
     
  20. Thomas Jansen

    Thomas Jansen Sector3 Developer Beta tester

    Joined:
    Apr 5, 2018
    Ratings:
    +552 / 0 / -0
    on my own definitely, another tip is to leave time progression off btw, this is pretty harsh on the CPU too. In races it struggled on the starts but as cars spread out it could do 120fps.