Problem Massive FPS Drops

Discussion in 'Community Support' started by kL1ck, May 14, 2018.

  1. Thomas Jansen

    Thomas Jansen Sector3 Developer Beta tester

    Joined:
    Apr 5, 2018
    Ratings:
    +379 / 0 / -0
    Ah i guess I can’t see sigs on mobile :p my bad haha
     
    • Funny Funny x 1
  2. Olijke Poffer

    Olijke Poffer Active Member

    Joined:
    Jul 1, 2018
    Ratings:
    +34 / 0 / -0
    Will do.
    As far as I know the FFB does cut out on frame drop. In other words, when the stuttering begins the screen & and the oculus aswel, will freezes for a second and then some frames and freezes again and when this happens the FFB freezes for a moment as wel. At least I believe it does.. need to check this out.
     
  3. Olijke Poffer

    Olijke Poffer Active Member

    Joined:
    Jul 1, 2018
    Ratings:
    +34 / 0 / -0
    here are 3 files. The game even crashed a few minutes ago. FFB was working normally by the way. so forget my message above regarding the FFB.
    was in a practice session on Road America in a BMW Alphina B6 GT3.
     

    Attached Files:

    • Like Like x 1
    • Useful Useful x 1
  4. Christian Göpfert

    Christian Göpfert Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,285 / 0 / -0
    Great thanks for those files.
    If you want to help the investigation further you could try the following:
    • Unplug your wheel and pedals (and any other peripherals except your mouse and keyboard).
    • Start the game and enter a session to see if the stuttering starts.
    • If it doesn't try connecting your wheel and pedals after starting a session and see if it still works now.
     
    • Useful Useful x 1
  5. Olijke Poffer

    Olijke Poffer Active Member

    Joined:
    Jul 1, 2018
    Ratings:
    +34 / 0 / -0
    Will try, although driving with keyboard and mouse will not be easy I’m affraid. :D
     
    • Agree Agree x 1
    • Funny Funny x 1
  6. Christian Göpfert

    Christian Göpfert Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,285 / 0 / -0
    Looking at your guys' signatures made me wonder if everybody experiencing this issue is running their CPU overclocked? At least @Olijke Poffer and @2ndLastJedi are, those CPUs don't run 4.9 GHz on stock, right?
    What about you @sherpa25 and @David Peres , are you guys also running an overclocked CPU?
     
  7. Olijke Poffer

    Olijke Poffer Active Member

    Joined:
    Jul 1, 2018
    Ratings:
    +34 / 0 / -0
    It has nothing to do with the overclocking. At least I don’t expect it. All my games running very smooth. Also R3E before the latest pach. The 8700k runs on 4,7 stock speed.
     
  8. 2ndLastJedi

    2ndLastJedi Well-Known Member

    Joined:
    Aug 22, 2016
    Ratings:
    +122 / 0 / -0
    I usually just run at 4.5 so to not have excess heat while playing in VR because I want to just play and not worry about temps , so thats just all core turbo .
    Its not the CPU clock thats causing it but maybe GPU as i run undervolt ! But still don't think it's that either because it hasn't happened for me in a while and I always run undervolted .
     
  9. Christian Göpfert

    Christian Göpfert Topological Agitator Beta tester

    Joined:
    Apr 8, 2015
    Ratings:
    +2,285 / 0 / -0
    Well, if I've learned anything while testing RR, it's to never say never. :)
    Not saying it's definitely caused by using an oc'ed CPU, but seeing that the last patch you mention included this
    I'm not putting it on the impossible list for now. ;)
     
    • Like Like x 2
    • Informative Informative x 1
  10. Olijke Poffer

    Olijke Poffer Active Member

    Joined:
    Jul 1, 2018
    Ratings:
    +34 / 0 / -0
    You’re right about that. :D
     
    • Funny Funny x 1
  11. sherpa25

    sherpa25 Member

    Joined:
    Jul 2, 2018
    Ratings:
    +18 / 0 / -0
    Nope, it's at stock, as the 1080Ti cannot seem to fully cope up yet. Just to clarify/add a bit though to what those w/ 8700k have mentioned, this runs 4.7 turbo if an app runs single core, but decreases as the number of cores used increases (ie. 2-cores @ 4.6, 3-cores @ 4.5, 4-5-cores @ 4.4....). Thanks, hope we're getting closer...never say never! :)
     
    • Like Like x 1
  12. David Peres

    David Peres Well-Known Member

    Joined:
    Jul 5, 2017
    Ratings:
    +89 / 0 / -0
    Nope. Running the exact same PC, in pretty much the same state (hardware/software), that allowed me to drive Raceroom before without any issues for about 2 years, until recently. It's an aging gaming laptop, so I used to play mostly with medium settings, but now, even low settings don't solve the problem.

    Lately my gaming time has reduced quite a lot so I didn't manage to do a lot of tests about this issue, so all I can say is that it seems to happen when I'm running with AI but not if I'm driving solo hotlaps, both in 32 and 64 bit. Don't know about multiplayer since I haven't tried it. Things like using the look-back button seem to trigger the longest/slowest slideshows, although there are other triggers, like some corners or driving trough some bumps/kerbs.

    Reducing the number of AI opponents also seems to reduce the issue a bit, and like I said before, it's something that starts with just a few small drops here and there but gets gradually worse during the race before reaching full slideshow-hell that makes the game unplayable. Also, the slideshows can be interrupted by pressing ESC, because once you resume they are gone and everything is back to normal speed for awhile. Some tracks also have it worse then others, it seems like. Laguna Seca in particular was an absolute nightmare almost immediately, while Bathurst took much longer until the drops showed up.

    It almost seems like some kind of memory leak is happening, but if that were the case then everyone should have been affected, so it's probably not that... whatever it is I hope a solution is found because until then I'm forced to use Raceroom just for hotlaping :(
     
    • Agree Agree x 1
  13. sherpa25

    sherpa25 Member

    Joined:
    Jul 2, 2018
    Ratings:
    +18 / 0 / -0
    Just wish to add, I'm in the same scenario... mostly running with AI. Though I've tried MP twice albeit short stints, I don't remember experiencing it there.
     
  14. Olijke Poffer

    Olijke Poffer Active Member

    Joined:
    Jul 1, 2018
    Ratings:
    +34 / 0 / -0
    Esc does notwork for me. It remains a slide show.
     
  15. David Peres

    David Peres Well-Known Member

    Joined:
    Jul 5, 2017
    Ratings:
    +89 / 0 / -0
    Yeah I din't test it more than a couple times when things got out of hand and things where definitely better after resuming the game, but it's possible that it doesn't always work under all conditions.
     
  16. AlleyViper

    AlleyViper Active Member

    Joined:
    Dec 10, 2016
    Ratings:
    +30 / 0 / -0
    I've done a thread about an issue that could be related, Fulscreen Mode isn't being applied correctly, so R3E uses Borderless Windowed mode instead. This can be confirmed if when you press volume keys, the windows GUI overlay still shows when running FS, which shouldn't be possible. Borderless mode can cause heavy stuttering (p.e. AC runs terrible with it), and adds input lag.
     
  17. Case

    Case Well-Known Member

    Joined:
    Apr 7, 2017
    Ratings:
    +103 / 0 / -0
    For me, the stutter usually happened after around 10 minutes of single player racing, no matter the game mode. Only recently it has happened to me in multiplayer as well. Like already mentioned, the fps counter still showed solid 60 fps, but the game started stuttering intermittently. The FFB seemed to "stutter" as well when that happened, in sync with the on-screen stutters.

    As for wheel and all that, I'm using T300 with G25 pedals connected via the Bodnar USB adapter, and a G25 shifter, again connected via the Bodnar USB adapter.

    Be aware that if you are running Windows 10, there have been changes in how the fullscreen mode works. It is now a hybrid between borderless window and the old fullscreen mode. One of the reasons MS did that was precisely to allow better multitasking and the possibility to show apps on top of the game window, even in fullscreen.
    If you want to go back to the old fullscreen mode, you have to disable fullscreen optimizations in the properties of the game .EXE file (individually for each game/file).
     
    • Informative Informative x 1
  18. AlleyViper

    AlleyViper Active Member

    Joined:
    Dec 10, 2016
    Ratings:
    +30 / 0 / -0
    Thanks for pointing it, but if you have read the thread I've linked, the hybrid mode and GameBar/DVR has been disabled (via registry for all apps, by using GameDVR_FSEBehavior = 2 which is the same as doing it manually on every exe, but I've also ticked it on the R3E exe for testing), so true FS just isn't working on R3E on my test system.

    It's also easy to know when you're under it. After alt tabbing out or bringing Windows UI elements overlay, some screen colors will be inverted for a very brief time. This isn't the case, it's just regular Borderless Windowed mode instead of FS, and alt+enter won't enable true FS.

    Update: Nope, I was wrong -- @Case you are correct, it was still running in hybrid mode. The single registry tweak above only seems to affect the behavior of some DX11 games. By disabling Fullscreen Optimizations directly in the RRRE64.exe, true fullscreen will be used. Probably the reason why it failed when I've tested it before was because I've set it on RRRE.exe by mistake instead of the x64 binary.

    I guess the difference might be either because it is/isn't in a GameBar compatibility list, or due to being a DX9 game instead of a DX11 game (all the games I've noticed the momentary color inversion when alt-tabbing or calling volume GUI in hybrid mode are DX11 titles).
    Still, the correct way to disable it system-wide (on current account) in a way that affects all games including RRRE64.exe, one registry line change was missing (credits to OnnA on guru3D forums):

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_CURRENT_USER\System\GameConfigStore]
    "GameDVR_FSEBehavior"=dword:00000002
    "GameDVR_HonorUserFSEBehaviorMode"=dword:00000001
    
    Default values for those keys are 0, 0. For tweak this to work as it should, "GameDVR_FSEBehaviorMode" should be currently set at default dword:00000002.

    After all this, for anyone suffering with stutters, you might try to disable this W10 1803 FS hybrid mode. If you don't want to mess with registry, just leave a check on "Disable fullscreen optimizations" under the compatibility tab of the RRRE64.exe, so it runs in true Fullscreen Mode as it always did in the past.
     
    • Informative Informative x 1
    Last edited: Jul 26, 2018
  19. sherpa25

    sherpa25 Member

    Joined:
    Jul 2, 2018
    Ratings:
    +18 / 0 / -0
    Happened just now, on the 3rd race w/ AI. FFB didn't cut out. As the slideshow was happening, I can still feel FFB. Escape/Resume didn't change anything, neither did Alt-Tab and back, nor Alt-Enter. Attached the logs.
     

    Attached Files:

  20. Olijke Poffer

    Olijke Poffer Active Member

    Joined:
    Jul 1, 2018
    Ratings:
    +34 / 0 / -0
    As far as I know I already have set this manually but I have to check it out to be sure. Could be that I only set it for Pcars.